summaryrefslogtreecommitdiff
path: root/dev-python/varlink/varlink-31.0.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-10-20 21:54:06 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-10-20 21:54:06 +0100
commit62058fa8f1b95418543f8ae008b247d44cc8b09c (patch)
tree48811edf87b513f58aff374c669cdfd5b1827e15 /dev-python/varlink/varlink-31.0.0.ebuild
parentb3830a745865c7d85daf3317603ad23dac6434da (diff)
gentoo auto-resync : 20:10:2023 - 21:54:06
Diffstat (limited to 'dev-python/varlink/varlink-31.0.0.ebuild')
-rw-r--r--dev-python/varlink/varlink-31.0.0.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/dev-python/varlink/varlink-31.0.0.ebuild b/dev-python/varlink/varlink-31.0.0.ebuild
new file mode 100644
index 000000000000..4220117a372e
--- /dev/null
+++ b/dev-python/varlink/varlink-31.0.0.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1
+
+MY_P=python-varlink-${PV}
+DESCRIPTION="Python implementation of the Varlink protocol"
+HOMEPAGE="
+ https://github.com/varlink/python/
+ https://pypi.org/project/varlink/
+"
+SRC_URI="
+ https://github.com/varlink/python/archive/${PV}.tar.gz
+ -> ${MY_P}.gh.tar.gz
+"
+S="${WORKDIR}/python-${PV}"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+
+BDEPEND="
+ dev-python/setuptools-scm[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests unittest
+
+export SETUPTOOLS_SCM_PRETEND_VERSION=${PV}