summaryrefslogtreecommitdiff
path: root/dev-python/uvloop
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-09-20 12:12:03 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-09-20 12:12:03 +0100
commitd60aa36cd97fb2193f756b45820d7c073a49229d (patch)
treeb5ae46dda53baf2afda4cd6b637f36cd3ac809e2 /dev-python/uvloop
parentfe0961fc9674dd24a017f474a34c1edbbd005965 (diff)
gentoo auto-resync : 20:09:2024 - 12:12:03
Diffstat (limited to 'dev-python/uvloop')
-rw-r--r--dev-python/uvloop/Manifest2
-rw-r--r--dev-python/uvloop/uvloop-0.21.0_beta1.ebuild83
2 files changed, 85 insertions, 0 deletions
diff --git a/dev-python/uvloop/Manifest b/dev-python/uvloop/Manifest
index b34cf8b8a4b2..0ead19923c2e 100644
--- a/dev-python/uvloop/Manifest
+++ b/dev-python/uvloop/Manifest
@@ -1,4 +1,6 @@
DIST uvloop-0.19.0-cython3.patch.xz 6352 BLAKE2B 4a7056299d3d430ce5b6986d43ba4f20726ae4f9635042a43e2995ea373ed53ddce6af2eaa32202f81f80a27bd1d814e635a6be091b5f751bcf6825fd2c8e88a SHA512 aeda541f1327860d23b31ffda9923270a56a8311ec86b06f3bd653478bff591372106e8848af5229e3ad298e950b4c3a728ab4dd9056219b8afe55f5dd58ee3d
DIST uvloop-0.20.0.tar.gz 2329938 BLAKE2B c9f230b16227bc98c071e060c98b4920d919c732f20237aedb3af9eb0b21d224bcdd6bd10c77ad45d24c64c70fb7e0d3ccde6d1eb90c67c33c1671bacad2a3b0 SHA512 9597f66e735b039b3eb6ad9ae3a1e58e710e6ba38b9131384befde15795f2a5fde7d5724af0e6f4e6c335fa14605dde5d28256f05b1e36c706e851fbe3ccb46c
+DIST uvloop-0.21.0b1.tar.gz 2492824 BLAKE2B aa9b07ca6f95020e22384e848abc137e1b7fd95092b01e41471a620c4614a48f64fb1031b6f6842a62dcdf2c727c1849421bbfc862e1eb0bbb84173668cd2f07 SHA512 ae0caf4c79102ad12d0b1bedf4ec64929ad15a281908fbb336f806fa35194838ce14993e49d569b53e4aa8824e51a5a5a7156f938111ec4d2e0f1319db72b415
EBUILD uvloop-0.20.0.ebuild 2033 BLAKE2B 81c7a8df786a90ce2916de815784c30d39cc5f048efd339a76684a0e554034eb17bbb31e767a6ebc1d9ef1e3cda00986581bc32745624140e76b5eafb41072d8 SHA512 95318d636b597ea33f86f231239de13f44cf763e8260fdbfcc7a2486f08d35a3f9606e3f9e11e7d502ea89194c4368fa68fb210f714a1d7127f58a001b6a471c
+EBUILD uvloop-0.21.0_beta1.ebuild 1923 BLAKE2B 431c4591622138fad11b3c8763e9c883d6b8497a1bc8b0fc1e7f01b531d0d1934c7854584e8017907d43a9c11b8a27553f12694729dd20f9bc12cb6ad8d6c373 SHA512 44fc25b2bf36f30eccddc05998ae70368a6220ed5b90f493823e0cd79c43a4f3fcdde90f12035b273636105f1aa73becf73841dea0e2fa4ed8ba6ffa3c2d5e42
MISC metadata.xml 527 BLAKE2B 2db44bdfb681fcce35ef35f13155293ac3fdffa12a695b654ed8acc608cf1f769243136e66b6b2c1afd57caa7e59a66a60d34631c37a4b98a474bd0635fcbaa3 SHA512 02540835a23405c467293395fa7984741e02ca1aca75f527edd3b988d307b41db0f729d5cc0b3a826a652fb7104dec7be86a9a57f4d5646d2af87255cc2d90de
diff --git a/dev-python/uvloop/uvloop-0.21.0_beta1.ebuild b/dev-python/uvloop/uvloop-0.21.0_beta1.ebuild
new file mode 100644
index 000000000000..125f4a5d40c3
--- /dev/null
+++ b/dev-python/uvloop/uvloop-0.21.0_beta1.ebuild
@@ -0,0 +1,83 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_EXT=1
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..13} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Ultra-fast implementation of asyncio event loop on top of libuv"
+HOMEPAGE="
+ https://github.com/magicstack/uvloop/
+ https://pypi.org/project/uvloop/
+"
+SRC_URI+=" https://dev.gentoo.org/~sam/distfiles/${CATEGORY}/${PN}/${PN}-0.19.0-cython3.patch.xz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 -riscv ~sparc ~x86"
+IUSE="examples"
+
+DEPEND="
+ >=dev-libs/libuv-1.11.0:=
+"
+RDEPEND="
+ ${DEPEND}
+"
+BDEPEND="
+ >=dev-python/cython-3.0[${PYTHON_USEDEP}]
+ test? (
+ >=dev-python/aiohttp-3.10.5[${PYTHON_USEDEP}]
+ >=dev-python/pyopenssl-22.0.0[${PYTHON_USEDEP}]
+ dev-python/psutil[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ rm -r vendor || die
+ cat <<-EOF >> setup.cfg || die
+ [build_ext]
+ use_system_libuv=True
+ cython_always=True
+ EOF
+
+ # force cythonization
+ rm uvloop/loop.c || die
+
+ distutils-r1_python_prepare_all
+
+ # don't append -O2... however, it's not splitting args correctly,
+ # so let's pass something safe
+ export UVLOOP_OPT_CFLAGS=-Wall
+}
+
+python_test() {
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ local EPYTEST_IGNORE=(
+ # linting
+ tests/test_sourcecode.py
+ )
+ local EPYTEST_DESELECT=(
+ # unhappy about sandbox injecting its envvars
+ tests/test_process.py::Test_UV_Process::test_process_env_2
+ tests/test_process.py::Test_AIO_Process::test_process_env_2
+ # crashes on assertion
+ # https://github.com/MagicStack/uvloop/issues/574
+ tests/test_cython.py::TestCythonIntegration::test_cython_coro_is_coroutine
+ # Internet
+ tests/test_dns.py::Test_UV_DNS::test_getaddrinfo_{8,9}
+ )
+
+ rm -rf uvloop || die
+ epytest -s
+}
+
+python_install_all() {
+ use examples && dodoc -r examples
+ distutils-r1_python_install_all
+}