summaryrefslogtreecommitdiff
path: root/dev-python/uvloop
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-python/uvloop
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-python/uvloop')
-rw-r--r--dev-python/uvloop/Manifest3
-rw-r--r--dev-python/uvloop/metadata.xml21
-rw-r--r--dev-python/uvloop/uvloop-0.8.1.ebuild49
3 files changed, 73 insertions, 0 deletions
diff --git a/dev-python/uvloop/Manifest b/dev-python/uvloop/Manifest
new file mode 100644
index 000000000000..70ec1054a05b
--- /dev/null
+++ b/dev-python/uvloop/Manifest
@@ -0,0 +1,3 @@
+DIST uvloop-0.8.1.tar.gz 1719488 BLAKE2B eba6e15c8eb46286b6e8df6043280ec8b423f097fcf2d4d5be657ff18f0fb97ce83e5268a138cf46700f54b7040353b6588dc4b0140e11f38d7da2e26b1ff120 SHA512 45dba019a0dacaae6c2a732c3f321402c19c945b0d9fa35b9cae28f888a54c7d4b322b450c55a6cf21c1aac01dc49b90eccdffbf4cb8c812a5ec8b9e805e01e4
+EBUILD uvloop-0.8.1.ebuild 1011 BLAKE2B 1b346d72198adca94752c7bdc3612b2c29b5607cba21c1eb7dce812939b3cf6c4d4042eccbab0e7a192dd2c6f8f989765b116bd0a71ca50b59c997ada30c4047 SHA512 49e5aefbf9e4084e00a941ed316fe86372ce98ae02ec7c1c09e8d808e9a30e9f84d316bbbfdf8f670dcc3d04a042ca0522d65ab44bd67f6f5e23f3663a227947
+MISC metadata.xml 700 BLAKE2B 72504f2e608de619c0288610639c44a69048f1ce0cc7caf5b7a1febef1bfbe9ddf4ecea9dbcca97ace3b91428dcf5db8d6eabe49de24e4e28d778c5d0e4bd103 SHA512 c4fd3a1a846bdd4e30272fb923a69da10c97a6cf41a26c255c29412ce0d49da2bb962fb0232c55a98721217de882435260ce4f658bc38b7474d19264eea9ab6d
diff --git a/dev-python/uvloop/metadata.xml b/dev-python/uvloop/metadata.xml
new file mode 100644
index 000000000000..5b546cf7d7a5
--- /dev/null
+++ b/dev-python/uvloop/metadata.xml
@@ -0,0 +1,21 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>elvis@magic.io</email>
+ <name>Elvis Pranskevichus</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+ <longdescription>
+ uvloop is a fast, drop-in replacement of the built-in asyncio
+ event loop. uvloop is implemented in Cython and uses libuv under
+ the hood.
+ </longdescription>
+ <upstream>
+ <remote-id type="pypi">uvloop</remote-id>
+ <remote-id type="github">MagicStack/uvloop</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/uvloop/uvloop-0.8.1.ebuild b/dev-python/uvloop/uvloop-0.8.1.ebuild
new file mode 100644
index 000000000000..84f83ea36651
--- /dev/null
+++ b/dev-python/uvloop/uvloop-0.8.1.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python{3_5,3_6} )
+inherit distutils-r1
+
+DESCRIPTION="Ultra-fast implementation of asyncio event loop on top of libuv"
+HOMEPAGE="https://github.com/magicstack/uvloop"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+KEYWORDS="~amd64 ~x86"
+
+LICENSE="MIT"
+SLOT="0"
+IUSE="doc examples test"
+
+RDEPEND=">=dev-libs/libuv-1.11.0:="
+DEPEND="
+ ${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ doc? (
+ >=dev-python/alabaster-0.6.2[${PYTHON_USEDEP}]
+ dev-python/sphinx[${PYTHON_USEDEP}]
+ )
+"
+
+python_prepare_all() {
+ cat <<EOF >> setup.cfg
+[build_ext]
+use-system-libuv=1
+EOF
+
+ distutils-r1_python_prepare_all
+}
+
+python_compile_all() {
+ use doc && esetup.py build_ext --inplace build_sphinx
+}
+
+python_test() {
+ esetup.py test
+}
+
+python_install_all() {
+ use examples && dodoc -r examples
+ use doc && local HTML_DOCS=( "${BUILD_DIR}/sphinx/html/." )
+ distutils-r1_python_install_all
+}