summaryrefslogtreecommitdiff
path: root/dev-python/uvloop
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-08-16 12:22:56 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-08-16 12:22:56 +0100
commit2ca31eebd5b7496656193e0aa6ae39200d69a017 (patch)
tree6cf0c8f4ce90a3960c27acf45011134fb674dd62 /dev-python/uvloop
parent3ad1879f00b279af69d6b9cd3ef97a2a7496d734 (diff)
gentoo auto-resync : 16:08:2024 - 12:22:56
Diffstat (limited to 'dev-python/uvloop')
-rw-r--r--dev-python/uvloop/Manifest2
-rw-r--r--dev-python/uvloop/uvloop-0.20.0.ebuild87
2 files changed, 89 insertions, 0 deletions
diff --git a/dev-python/uvloop/Manifest b/dev-python/uvloop/Manifest
index 46aa41e3f0c4..4e3f5e032b1c 100644
--- a/dev-python/uvloop/Manifest
+++ b/dev-python/uvloop/Manifest
@@ -1,4 +1,6 @@
DIST uvloop-0.19.0-cython3.patch.xz 6352 BLAKE2B 4a7056299d3d430ce5b6986d43ba4f20726ae4f9635042a43e2995ea373ed53ddce6af2eaa32202f81f80a27bd1d814e635a6be091b5f751bcf6825fd2c8e88a SHA512 aeda541f1327860d23b31ffda9923270a56a8311ec86b06f3bd653478bff591372106e8848af5229e3ad298e950b4c3a728ab4dd9056219b8afe55f5dd58ee3d
DIST uvloop-0.19.0.tar.gz 2318492 BLAKE2B 1c46a8bf3e204c261e3a5e60c3583b75b8b9b20086443725c42842f96ea3f6804242470aa9569f8cc74a6e3bd38b5aaa70f9a9d92b5df3e73911acc169185570 SHA512 b6ca7ba7baf61dc930bb92e35013e5abaf7a227a5e99c88ec4b58fa87a40692151d9891b81d9e514a8481df62bb9721baa789ec234dcbbb34f69e0bee489c57c
+DIST uvloop-0.20.0.tar.gz 2329938 BLAKE2B c9f230b16227bc98c071e060c98b4920d919c732f20237aedb3af9eb0b21d224bcdd6bd10c77ad45d24c64c70fb7e0d3ccde6d1eb90c67c33c1671bacad2a3b0 SHA512 9597f66e735b039b3eb6ad9ae3a1e58e710e6ba38b9131384befde15795f2a5fde7d5724af0e6f4e6c335fa14605dde5d28256f05b1e36c706e851fbe3ccb46c
EBUILD uvloop-0.19.0-r1.ebuild 2021 BLAKE2B fd1e66cf5f2e36fa7c8c556ca1452a5f7deb3a2c8fcf4da6e03baf9ada5c55913659e9906bd63232e0bd5d57ccfdf0d27226fbcfa7edb26713c4dcdd64f2c0ab SHA512 bda01f9c9b1c745ee3eb52e3c4f88dc3abe9d3f8e0a9432066e401ce51bc21e90a1b949f7d69a8f46412b47e2ad15dd1b17d72f2b29806e2aaabe0137f7e9456
+EBUILD uvloop-0.20.0.ebuild 2040 BLAKE2B c5f917f4fa8b1359f5fef525e2ee7004b471757a7c9074f0e6e3f85cd79480ca588e18110a829217c1b5933e3f96672ae36c50aab4fc01764286e0926a95948d SHA512 c434261e62fb8ee4c76d4e7bf4a5df8ad0a3d6845730c44949d4444fdd005944faedf1eddb9f2e2ab41402c3fa90181f7f1790b7ff0d043bf8bdec64cceff07c
MISC metadata.xml 527 BLAKE2B 2db44bdfb681fcce35ef35f13155293ac3fdffa12a695b654ed8acc608cf1f769243136e66b6b2c1afd57caa7e59a66a60d34631c37a4b98a474bd0635fcbaa3 SHA512 02540835a23405c467293395fa7984741e02ca1aca75f527edd3b988d307b41db0f729d5cc0b3a826a652fb7104dec7be86a9a57f4d5646d2af87255cc2d90de
diff --git a/dev-python/uvloop/uvloop-0.20.0.ebuild b/dev-python/uvloop/uvloop-0.20.0.ebuild
new file mode 100644
index 000000000000..e644e65585bc
--- /dev/null
+++ b/dev-python/uvloop/uvloop-0.20.0.ebuild
@@ -0,0 +1,87 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_EXT=1
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Ultra-fast implementation of asyncio event loop on top of libuv"
+HOMEPAGE="
+ https://github.com/magicstack/uvloop/
+ https://pypi.org/project/uvloop/
+"
+SRC_URI+=" https://dev.gentoo.org/~sam/distfiles/${CATEGORY}/${PN}/${PN}-0.19.0-cython3.patch.xz"
+
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 -riscv ~sparc ~x86"
+LICENSE="MIT"
+SLOT="0"
+IUSE="examples"
+
+DEPEND="
+ >=dev-libs/libuv-1.11.0:=
+"
+RDEPEND="
+ ${DEPEND}
+"
+BDEPEND="
+ >=dev-python/cython-0.29.36[${PYTHON_USEDEP}]
+ test? (
+ dev-python/aiohttp[${PYTHON_USEDEP}]
+ >=dev-python/pyopenssl-22.0.0[${PYTHON_USEDEP}]
+ dev-python/psutil[${PYTHON_USEDEP}]
+ )
+"
+
+PATCHES=(
+ "${WORKDIR}"/${PN}-0.19.0-cython3.patch
+)
+
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ rm -r vendor || die
+ cat <<-EOF >> setup.cfg || die
+ [build_ext]
+ use_system_libuv=True
+ cython_always=True
+ EOF
+
+ # force cythonization
+ rm uvloop/loop.c || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ local EPYTEST_IGNORE=(
+ # linting
+ tests/test_sourcecode.py
+ )
+ local EPYTEST_DESELECT=(
+ # TODO: expects some... cython_helper?
+ tests/test_libuv_api.py::Test_UV_libuv::test_libuv_get_loop_t_ptr
+ # unhappy about sandbox injecting its envvars
+ tests/test_process.py::Test_UV_Process::test_process_env_2
+ tests/test_process.py::Test_AIO_Process::test_process_env_2
+ # hangs
+ tests/test_tcp.py::Test_AIO_TCPSSL::test_remote_shutdown_receives_trailing_data
+ # crashes on assertion
+ # https://github.com/MagicStack/uvloop/issues/574
+ tests/test_cython.py::TestCythonIntegration::test_cython_coro_is_coroutine
+ # Internet
+ tests/test_dns.py::Test_UV_DNS::test_getaddrinfo_{8,9}
+ )
+
+ rm -rf uvloop || die
+ epytest -s
+}
+
+python_install_all() {
+ use examples && dodoc -r examples
+ distutils-r1_python_install_all
+}