summaryrefslogtreecommitdiff
path: root/dev-python/uvloop/uvloop-0.15.2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2021-10-08 23:06:07 +0100
committerV3n3RiX <venerix@koprulu.sector>2021-10-08 23:06:07 +0100
commite23a08d0c97a0cc415aaa165da840b056f93c997 (patch)
tree4c5f7db60483518201fef36f8cc0712789a08db2 /dev-python/uvloop/uvloop-0.15.2.ebuild
parent391b5b359a346aff490103da7dddc85047f83830 (diff)
gentoo resync : 08.10.2021
Diffstat (limited to 'dev-python/uvloop/uvloop-0.15.2.ebuild')
-rw-r--r--dev-python/uvloop/uvloop-0.15.2.ebuild54
1 files changed, 0 insertions, 54 deletions
diff --git a/dev-python/uvloop/uvloop-0.15.2.ebuild b/dev-python/uvloop/uvloop-0.15.2.ebuild
deleted file mode 100644
index b10e112d367d..000000000000
--- a/dev-python/uvloop/uvloop-0.15.2.ebuild
+++ /dev/null
@@ -1,54 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{8..9} )
-inherit distutils-r1
-
-DESCRIPTION="Ultra-fast implementation of asyncio event loop on top of libuv"
-HOMEPAGE="https://github.com/magicstack/uvloop"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-KEYWORDS="amd64 ~arm ~arm64 ~ppc ~ppc64 -riscv x86"
-LICENSE="MIT"
-SLOT="0"
-IUSE="doc examples"
-
-RDEPEND=">=dev-libs/libuv-1.11.0:="
-DEPEND="${RDEPEND}"
-BDEPEND="
- doc? (
- >=dev-python/alabaster-0.6.2[${PYTHON_USEDEP}]
- dev-python/sphinx[${PYTHON_USEDEP}]
- )
- test? (
- dev-python/aiohttp[${PYTHON_USEDEP}]
- dev-python/pyopenssl[${PYTHON_USEDEP}]
- dev-python/psutil[${PYTHON_USEDEP}]
- )
-"
-
-distutils_enable_tests setup.py
-
-python_prepare_all() {
- cat <<EOF >> setup.cfg || die
-[build_ext]
-use-system-libuv=1
-EOF
-
- # flake8 only
- rm tests/test_sourcecode.py || die
-
- distutils-r1_python_prepare_all
-}
-
-python_compile_all() {
- use doc && esetup.py build_ext --inplace build_sphinx
-}
-
-python_install_all() {
- use examples && dodoc -r examples
- use doc && local HTML_DOCS=( "${BUILD_DIR}/sphinx/html/." )
- distutils-r1_python_install_all
-}