summaryrefslogtreecommitdiff
path: root/dev-python/uvicorn
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-06-17 17:57:35 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-06-17 17:57:35 +0100
commit7932d472a02d4c016ff7dff4b7a5479ab9d1883d (patch)
treed07709230f82777cae6ba7dab35aee31896060fb /dev-python/uvicorn
parentd18bf1e01b65ee4bf0c804e2843b282d3d4e5d7c (diff)
gentoo resync : 17.06.2021
Diffstat (limited to 'dev-python/uvicorn')
-rw-r--r--dev-python/uvicorn/Manifest3
-rw-r--r--dev-python/uvicorn/uvicorn-0.14.0-r1.ebuild45
-rw-r--r--dev-python/uvicorn/uvicorn-0.14.0.ebuild9
3 files changed, 56 insertions, 1 deletions
diff --git a/dev-python/uvicorn/Manifest b/dev-python/uvicorn/Manifest
index c09800ef5928..0860706834e0 100644
--- a/dev-python/uvicorn/Manifest
+++ b/dev-python/uvicorn/Manifest
@@ -2,5 +2,6 @@ AUX uvicorn-0.13.4-fix-wsproto-1.0.patch 1122 BLAKE2B 4190a5e61af991e77271aef8be
DIST uvicorn-0.13.4.tar.gz 505858 BLAKE2B 486436c0b4c717741c11b7da6a979dc9fe977baa2dbc3e2538ce28551d2dee593076b670b16c099056165624c149f96974f64d2847e38234122ec93b65b31cda SHA512 5332494e0b43b4e87f9d6742be679527b1ec2bc4d2e061768594d44b1fd1d6961a2bd1fa23469fca6c530ef36d6123e453306c2bb664cb27b0cd6145b9a70fd7
DIST uvicorn-0.14.0.tar.gz 511593 BLAKE2B 9f7aee0001874c128e44d31945aaa0ca92237e594debb6fea3c6c6d0f283c96cfad5248578b0e1c170fe2fde96a6b17c56ecf2436783fcae135b8eab1997b701 SHA512 f41a7f01ac6893ceaf4d1f06a4bccd7355e319eee11d6aa290b0d316fb356eb807c926941157ec64f1fc6b7c4601930cfbe271075d6c4cf684bd7e175617390f
EBUILD uvicorn-0.13.4.ebuild 1297 BLAKE2B e2e429e266084c92acf6965e86220494101135001bf656ce9ed1ee08b8ea07b61a8cb844bd416ddfa77ae9c8dd0d3618a8438b3dd1b08d12857efce9e6fbcbbc SHA512 3fd28de46cea2f2b8a2a7aa688155127d1a6d8e7f79137443606019e05825a1f4ab1c1ecd1dd8f4a04c8dc8e6851b59136fdcc68d5d4344be98fe70f97714dc0
-EBUILD uvicorn-0.14.0.ebuild 1236 BLAKE2B b7dcbcfe053d832d01427b573f2dca001469b2529b2b5e98358f44c76aff6397cee3dd832a7bc47f981310d5e7dc0b6408f86dca7a55fb918eadf7626d8dc197 SHA512 a3d4a0dc51e65a89615ed825b8025f39cc57953dde17f595619cfb62312a96514103f9a20e03c8ae5cb444bf4a8dc53919d539767ae8530f8236796fe8ed86d7
+EBUILD uvicorn-0.14.0-r1.ebuild 1257 BLAKE2B db4be7794c303f52f4cf7602546408fc79dcb7e73a810171dfcb4246117b505f18b9a9bd2d6ed356a843ea4dba791f713803671a00bf775534508f9bd9c04c01 SHA512 5f0552bde506e134d066f299b3dbc74d6eba19a1f748f1611a4430cd0d91493681679688bbda5dcb6ff52d85634c24dde54f4970af930b824713836f35f770b6
+EBUILD uvicorn-0.14.0.ebuild 1433 BLAKE2B 4d49fb57499a1e194296a500aca200571e19a4d25e08c239cd34a885e231f5131465e81077075ecaefb0a1291a6f9fb5671560dcf12c96c492360e04ef699907 SHA512 5150ae53a21b71bed057d77b26d0f57c39965dde04768d356569a705898f7cdd5f426d17c5dc5e2cbc546f442d4d66247977f679520539c39bb6117f6b0b414c
MISC metadata.xml 450 BLAKE2B e6413874e7247880323b72113f002ade2edff362d7464ebbd5890ec95946b97bc37d74c2d6e9ff7a6a416a45f32bbab1b6eca70db8964adc6be287793c0fb4b4 SHA512 a1138016ec2d87c77f82333a0d41a68113d87c74d50e1bd6ccef0e0300f53663ecb907959be2547b42cc5cd007f47626e98b8c8cdc7e3557d2dfd0a369447268
diff --git a/dev-python/uvicorn/uvicorn-0.14.0-r1.ebuild b/dev-python/uvicorn/uvicorn-0.14.0-r1.ebuild
new file mode 100644
index 000000000000..3901bfce5fee
--- /dev/null
+++ b/dev-python/uvicorn/uvicorn-0.14.0-r1.ebuild
@@ -0,0 +1,45 @@
+# Copyright 2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{8..9} )
+inherit distutils-r1
+
+DESCRIPTION="Lightning-fast ASGI server implementation"
+HOMEPAGE="https://www.uvicorn.org/"
+SRC_URI="https://github.com/encode/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+RDEPEND="
+ >=dev-python/asgiref-3.3.4[${PYTHON_USEDEP}]
+ >=dev-python/click-7[${PYTHON_USEDEP}]
+ >=dev-python/h11-0.8[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep 'dev-python/typing-extensions[${PYTHON_USEDEP}]' python3_7)
+"
+BDEPEND="
+ test? (
+ dev-python/cryptography[${PYTHON_USEDEP}]
+ dev-python/httpx[${PYTHON_USEDEP}]
+ dev-python/pytest-asyncio[${PYTHON_USEDEP}]
+ dev-python/pytest-mock[${PYTHON_USEDEP}]
+ dev-python/python-dotenv[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ dev-python/trustme[${PYTHON_USEDEP}]
+ >=dev-python/websockets-9.1[${PYTHON_USEDEP}]
+ dev-python/wsproto[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ # watchgod is not in the tree
+ sed -e '/^from uvicorn.supervisors.watchgodreload/d' \
+ -e 's/, WatchGodReload//' \
+ -i tests/supervisors/test_reload.py
+ distutils-r1_python_prepare_all
+}
diff --git a/dev-python/uvicorn/uvicorn-0.14.0.ebuild b/dev-python/uvicorn/uvicorn-0.14.0.ebuild
index f6347568597c..3b12bff47fdf 100644
--- a/dev-python/uvicorn/uvicorn-0.14.0.ebuild
+++ b/dev-python/uvicorn/uvicorn-0.14.0.ebuild
@@ -42,3 +42,12 @@ python_prepare_all() {
-i tests/supervisors/test_reload.py
distutils-r1_python_prepare_all
}
+
+python_test() {
+ local deselect=(
+ # requires python-dotenv that's not keyworded everywhere yet
+ # see 0.14.0-r1
+ tests/test_config.py::test_env_file
+ )
+ epytest ${deselect[@]/#/--deselect }
+}