summaryrefslogtreecommitdiff
path: root/dev-python/utidylib
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-12-15 18:09:03 +0000
committerV3n3RiX <venerix@redcorelinux.org>2019-12-15 18:09:03 +0000
commit7bc9c63c9da678a7e6fceb095d56c634afd22c56 (patch)
tree4a67d50a439e9af63947e5f8b6ba3719af98b6c9 /dev-python/utidylib
parentb284a3168fa91a038925d2ecf5e4791011ea5e7d (diff)
gentoo resync : 15.12.2019
Diffstat (limited to 'dev-python/utidylib')
-rw-r--r--dev-python/utidylib/Manifest2
-rw-r--r--dev-python/utidylib/utidylib-0.6.ebuild58
2 files changed, 60 insertions, 0 deletions
diff --git a/dev-python/utidylib/Manifest b/dev-python/utidylib/Manifest
index ac1e4a917b61..ae9bac0202d3 100644
--- a/dev-python/utidylib/Manifest
+++ b/dev-python/utidylib/Manifest
@@ -1,3 +1,5 @@
DIST uTidylib-0.3.tar.bz2 13809 BLAKE2B c6b495933ecdc21543c79e3ff200cc06ec4ebc1682cf9172bd988a08afef8b69db17eec4b88665aff5dc6cef371f3c665f6de3ffcc1dc515f778b523333c891b SHA512 4503f2a6366e5110740b312df2300d62bb68e1e1032184e9b56dee75995309c76d4f8e5851c73e7c8e08cca7bba9c74436d8dfc0524f115f3abb2bdf5529cc35
+DIST uTidylib-0.6.tar.gz 15771 BLAKE2B 9d4fe57d985ea6e52680bd528862d3236137221227a23fe05b886d01d240e21d7159dbf7d6da3af8020009ca45c60c2297e374bb7aa05cb6b5a8eaf444710c58 SHA512 a85506ef8824f66ee326ad651020dc3b4e00190e20dcd3814984fa27ff319f492fe5bac781b7c43c8694cbfc63409e3abda18981969c9be2c3cd023fe7a4f2f8
EBUILD utidylib-0.3-r2.ebuild 970 BLAKE2B 02aca84cedeb527b3d2a1601d13d8715d3d794b991fc0722e8055ef4ce3761653cd13dae4c9fbe777569fd7bc96b2aea7add931d260828e0f98e50df151e8213 SHA512 d505f5a799f85c9e9a654e02c1595ed84834bf635e74ca34c9c9eae5615f7c9e7cc94c82f5b05716231239332bc3b935ad2cc2cdb92b8ee27a135f92a6143b86
+EBUILD utidylib-0.6.ebuild 1265 BLAKE2B 93e7227f5a5e8e97b7b1420faabb08bcee4d6045d07f5ca4f47019af777c35d95227a0c05ce8cc3b4595b844a2f736ac184d5bf853864181c557cf1305dc7529 SHA512 b8bf3e9994382ee098b04b6bb77b338a3bec7432f33a2db52c2e89967ba2b3a8538ba5078d2752f6d901f45474c2ffed9dbc8ccac5141874a5c8152c234a9820
MISC metadata.xml 372 BLAKE2B 58932a89c0765511f1231a3ea43ac6509792a03b345655f7d15ec306a33a0264d49b32352c57e8d3cc73294c8cfcbd679289011312bdbed55459f6751dabffa0 SHA512 d6602ff98aa2ae6a69cad590ab014cbe5b3f1fc1b28c64e91025140fbecaa78c49d6e45bc8b8b5432b0cfe4c91402db3d3954db92905ddc42c13540a9c1e2ab5
diff --git a/dev-python/utidylib/utidylib-0.6.ebuild b/dev-python/utidylib/utidylib-0.6.ebuild
new file mode 100644
index 000000000000..5e18aa363d3e
--- /dev/null
+++ b/dev-python/utidylib/utidylib-0.6.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python2_7 python3_{6,7,8} )
+
+MY_P="uTidylib-${PV}"
+inherit distutils-r1
+
+DESCRIPTION="TidyLib Python wrapper"
+HOMEPAGE="https://cihar.com/software/utidylib/ https://pypi.org/project/uTidylib/"
+SRC_URI="mirror://pypi/${P:0:1}/${PN}/${MY_P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~ppc ~ppc64 ~x86"
+IUSE="doc test"
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}
+ test? ( || ( $(python_gen_useflags 'python2*' python3_6 python3_7) ) )
+"
+
+BDEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ doc? ( dev-python/sphinx )
+ test? ( $(python_gen_cond_dep '
+ dev-python/flake8[${PYTHON_USEDEP}]
+ dev-python/pycodestyle[${PYTHON_USEDEP}]
+ dev-python/pyflakes[${PYTHON_USEDEP}]
+ dev-python/pytest[${PYTHON_USEDEP}]
+ dev-python/pytest-cov[${PYTHON_USEDEP}]
+ ' 'python2*' python3_6 python3_7
+ ) )
+"
+DEPEND="
+ dev-python/six[${PYTHON_USEDEP}]
+"
+RDEPEND="
+ app-text/tidy-html5
+"
+
+RESTRICT="test" # 1/11 tests fail
+
+S="${WORKDIR}/${MY_P}"
+
+python_compile_all() {
+ use doc && emake -C docs html
+}
+
+python_test() {
+ esetup.py test
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( docs/_build/html/. )
+ distutils-r1_python_install_all
+}