summaryrefslogtreecommitdiff
path: root/dev-python/utidylib
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-12-07 21:14:14 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-12-07 21:14:14 +0000
commit6d44cd74809cea5f81bf52ff9cd0aa902d6b6866 (patch)
tree4045142b80c7e0479c627a84e3f0de03e574df19 /dev-python/utidylib
parent8615c518b1f1d03130f21656a1a026959bb1e9c9 (diff)
gentoo auto-resync : 07:12:2022 - 21:14:14
Diffstat (limited to 'dev-python/utidylib')
-rw-r--r--dev-python/utidylib/Manifest2
-rw-r--r--dev-python/utidylib/utidylib-0.9.ebuild36
2 files changed, 38 insertions, 0 deletions
diff --git a/dev-python/utidylib/Manifest b/dev-python/utidylib/Manifest
index d7237ed39074..80bc03ffbd54 100644
--- a/dev-python/utidylib/Manifest
+++ b/dev-python/utidylib/Manifest
@@ -1,3 +1,5 @@
DIST utidylib-0.8.gh.tar.gz 15285 BLAKE2B 85f0ec1a969f31cb952e326a5bce5f51d9a5bacdf33d7e703cc3a464621df86f568921a9dd17755be67d49c02631782cdabb4112ee7cf8e321079656bb362122 SHA512 cb9c868337e1bbfa80ac36ca1b3f85c4e35f62acb67dbd321167d568da17d9e562fdca6b777d88c08e03107401fbadc7cdebf243654bcde9825259117e36392f
+DIST utidylib-0.9.gh.tar.gz 15778 BLAKE2B 54c9b9b7c0615ac49a90567357f119643311dd6ee2848dcdfcbe00b93431672ee6954738627c0b3fa984a8f2c7b9e127cc1edac06f9760a252621317d2266476 SHA512 58ca8a43ba2e933f02111939ee8496bb63b17220ce5a6fa3cb731659e89000baa17409c10968308cd86bb2a9dc4819ef2029245eecdb3c7a3fa57404f37004fc
EBUILD utidylib-0.8.ebuild 739 BLAKE2B 5be301b3c591c5390e35a0cf10463952436a73fd40c4ff1feba8a96bb7c89290d65e19c2b3ee868237f249e0fd23c4bef301d7d699adf30a83df96a5ab9920f6 SHA512 7417a9e7ae3157b55245164036b28fc9ae76a560ff3743f167d6c7f41cde327214b2db16e48d46b36113e99c9fbc8d4b681f881f7e14e6af8340de467f6e67dc
+EBUILD utidylib-0.9.ebuild 744 BLAKE2B 755b51e4d4cd1f8054b83c8e553ba1c88534c6207964df3455fed19cdcf72c2aba0e697080d830c62484a62ce8bb3efc6e365919583b55227089222a3eada56e SHA512 a1579727beb498bbc54f56b1aeabcb4c8919696b06f15f4818123ec58c6fddc08b929a3509d0c4c4050ce394d629e76ee4be87c41169d225ab228e691f17358d
MISC metadata.xml 366 BLAKE2B bc4aba05448508a1d0a5e6972d253a3389a445627679c7946350ddf7e210b5b1232301e2b5c36822d946c1deb6669a763957982eed3440ab1c517747005d27af SHA512 7a68b5c21f50d81401bc5f0eb1d334679b71891d6aad08c7f1001140e15392482077b554a19e82f0ef451bc0c082b48300d54c32160f07bfb0d9ef0ab700c29a
diff --git a/dev-python/utidylib/utidylib-0.9.ebuild b/dev-python/utidylib/utidylib-0.9.ebuild
new file mode 100644
index 000000000000..095b63b34c3a
--- /dev/null
+++ b/dev-python/utidylib/utidylib-0.9.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="TidyLib Python wrapper"
+HOMEPAGE="
+ https://cihar.com/software/utidylib/
+ https://github.com/nijel/utidylib/
+ https://pypi.org/project/uTidylib/
+"
+SRC_URI="
+ https://github.com/nijel/utidylib/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~ppc ~ppc64 ~riscv ~x86"
+
+RDEPEND="
+ >=app-text/htmltidy-5.0.0
+"
+
+distutils_enable_tests pytest
+distutils_enable_sphinx docs
+
+EPYTEST_DESELECT=(
+ # https://github.com/nijel/utidylib/issues/9
+ tidy/test_tidy.py::TidyTestCase::test_missing_load
+)