summaryrefslogtreecommitdiff
path: root/dev-python/userpath
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-07-18 13:00:52 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-07-18 13:00:52 +0100
commite0722f6145f1e8db6281ff135d83442091b31620 (patch)
treee12d701878d995460a24779bd4e1d7689acbeb78 /dev-python/userpath
parentdcb9c4187a31b8b770600503289d2ad39745e782 (diff)
gentoo auto-resync : 18:07:2023 - 13:00:52
Diffstat (limited to 'dev-python/userpath')
-rw-r--r--dev-python/userpath/Manifest2
-rw-r--r--dev-python/userpath/userpath-1.9.0.ebuild29
2 files changed, 31 insertions, 0 deletions
diff --git a/dev-python/userpath/Manifest b/dev-python/userpath/Manifest
index 3a5adb3d76eb..554198549461 100644
--- a/dev-python/userpath/Manifest
+++ b/dev-python/userpath/Manifest
@@ -1,3 +1,5 @@
DIST userpath-1.8.0.gh.tar.gz 11045 BLAKE2B ebf1077469210dfb66c63a859764becb5cac5734bc0060db691e50e3576241360b4644f141449f033f64f4dbdbf10d2b5a032493ce3c4745a2c981149105c7c9 SHA512 d2f082909fad22cf5b33f175afdeebe14a44ebd245c84506395f01a288eccf9c376ac28dcc4b618cc2464e1a23e740b41f4f4ad0e780a42e1185c5283ccc7330
+DIST userpath-1.9.0.gh.tar.gz 11090 BLAKE2B 70eac3d629c71604047d9dfa4eaf2eeb90011d0b943367aacc0e4e1efb7d45de0efb8075404510e791bd8da3609423d29503101943edc108aa012e8018e53b63 SHA512 a5683a7423465426debda02d58b2f5ef8d17d38d2fac2378cdf3075a2a6f0b7d75210bb1eac30966d323ec5f25073cc9286ae1b37acaa1bf7785da02a4c40805
EBUILD userpath-1.8.0.ebuild 569 BLAKE2B 08a9b36652591841c5c48102c66fdd13f1e4cf2177bb2db0537536d6f1dbe2b8a997800ca2110ab2a1ed70c739e4f3af2a4a07ad8140a63290612b2881721608 SHA512 795a316db4eb0c151cab5d707a5be0a32944bc384ddb467f628b238706f8c106899aa8bf81da4144bb06b1f7a9e82d09cb543930beab2aaa0bcee2bab422df9b
+EBUILD userpath-1.9.0.ebuild 569 BLAKE2B 08a9b36652591841c5c48102c66fdd13f1e4cf2177bb2db0537536d6f1dbe2b8a997800ca2110ab2a1ed70c739e4f3af2a4a07ad8140a63290612b2881721608 SHA512 795a316db4eb0c151cab5d707a5be0a32944bc384ddb467f628b238706f8c106899aa8bf81da4144bb06b1f7a9e82d09cb543930beab2aaa0bcee2bab422df9b
MISC metadata.xml 389 BLAKE2B d1956c245f6188560ce4e95dee67c0f3e7d41dc44c54cc0fb2eefa88156d4121384d7206ff4b7dd10be127ddd9c27d9e2b9baa04db225263457e1fa020bc6a6e SHA512 899f4930827a110dc03f5a9905e765342f7f619a39d4095297bfad4175b34326df6d1e33d08a2db9b051f72f94b24ac87b444fafa09bd15e386e472d1be1802a
diff --git a/dev-python/userpath/userpath-1.9.0.ebuild b/dev-python/userpath/userpath-1.9.0.ebuild
new file mode 100644
index 000000000000..e9cbe4cde968
--- /dev/null
+++ b/dev-python/userpath/userpath-1.9.0.ebuild
@@ -0,0 +1,29 @@
+# Copyright 2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=hatchling
+PYTHON_COMPAT=( pypy3 python3_{10..12} )
+
+inherit distutils-r1
+
+DESCRIPTION="Cross-platform tool for adding locations to the user PATH"
+HOMEPAGE="
+ https://github.com/ofek/userpath/
+ https://pypi.org/project/userpath/
+"
+SRC_URI="
+ https://github.com/ofek/userpath/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ dev-python/click[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest