summaryrefslogtreecommitdiff
path: root/dev-python/urllib3
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-05-31 20:59:14 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-05-31 20:59:14 +0100
commite748ba9741f6540f4675c23e3e37b73e822c13a4 (patch)
tree23dece8beabb3a3d7c6c0273b0eb40b21c62a889 /dev-python/urllib3
parent908778078736bd36f7a60a2d576d415cb8e000fa (diff)
gentoo resync : 31.05.2021
Diffstat (limited to 'dev-python/urllib3')
-rw-r--r--dev-python/urllib3/Manifest2
-rw-r--r--dev-python/urllib3/urllib3-1.26.5.ebuild66
2 files changed, 68 insertions, 0 deletions
diff --git a/dev-python/urllib3/Manifest b/dev-python/urllib3/Manifest
index 503a292529cf..6370b402b6ba 100644
--- a/dev-python/urllib3/Manifest
+++ b/dev-python/urllib3/Manifest
@@ -1,4 +1,6 @@
AUX urllib3-1.26.4-test-ssltransport.patch 1267 BLAKE2B e82ae435cfa8a2821f3f61d91a2e4f9011c5f68d37fddd1a40ae4658566db45717379c48d11299eb260c2f8816f416ac69b0379b3c7f925075ee9c1051aab1bd SHA512 bf5d2bb2b48444724ee1cfb87f4a84b3a63cd6ca598ba4d92a44bde71c66a35b815905de51fe027abb2eea63ae353dc0df2338ddd4f819f678f8a39b5c6d685b
DIST urllib3-1.26.4.tar.gz 293008 BLAKE2B 6ca88861baa87814d3856cd0f1fa0a6cb9e11ee745c782b598c4f5fe74b195ba47e8430b993ed8a5fb269153d700e4a803cd2ebc177e20e3186b3b26612262c7 SHA512 daf2ba432f2e4edaa6aa8c6bdaaea21fcb77cc5fdfd991f89b1f753b4f9901faab04120841e9fa8d93e2bd3d72cbdb647f1492d882266b4e0281c725e8d55a7a
+DIST urllib3-1.26.5.tar.gz 292865 BLAKE2B 0b22a485635f70f198c022c13d03af2b1a9b6907276e3bc3acaa2242e1c632447762f86e9588e735462e6479ff93a172f458691ea9bf28ceaebd5e1cfbc55501 SHA512 4a1899b223b00894d49f6dff5fc95d410e5b0ab28c11f7e3cd82d03e50438b0c5b0adf693a33fd80f1586312dc0012836713998674da15531bf82d52645881f6
EBUILD urllib3-1.26.4.ebuild 4265 BLAKE2B 17f981911cc9adf17b7fa989833a47554127d9bdc7c1f49605c0c949c0c82ca24e48e5e1bea38f8f549c5eb00e047cfddf03a967a0ea7bf1e83afa9901044f7f SHA512 f9d2190c141b4c4daa2d9e3d4fe577acb3d0787c8591ca46bce3ccf5e22872349fa459e63cd5cb96710f25a5910a2ce600d0003b7e72e5f9c4e0797c459d07f2
+EBUILD urllib3-1.26.5.ebuild 2000 BLAKE2B fa6e4541b33924bcb2fb67d9655125059c854de67d4b32dafd40a7feded31358828695c2b2cb93ef61a4d27fcb45f67471d304557e3bf18a0d9698cff7381586 SHA512 84848d38a91b530b985400f965684a5857fba8cd2a55f3526bb2bc860b31d46c1c1fa9d1fa7de58feaaca7aaa25a3f4edf24781ee0b3fd6070d400e310a08d74
MISC metadata.xml 530 BLAKE2B 148b6a1936566b905f38f00ec231a832e827bbdd4f6c2ceabe521779b08c1dbf60bdfa182234e8e67b6708efadd09d29e93c151f7c3d1d4fcd5ece3e3d9c0839 SHA512 9ab9fa9ecb34855be0f6e7914f70eadca67854fde865765b1257feec6c841bccd8276ad81f8d9bbfb544ca753c3d27681d6cc841cee008efca5ba72f5a236f3e
diff --git a/dev-python/urllib3/urllib3-1.26.5.ebuild b/dev-python/urllib3/urllib3-1.26.5.ebuild
new file mode 100644
index 000000000000..921dcd09ce48
--- /dev/null
+++ b/dev-python/urllib3/urllib3-1.26.5.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7..10} pypy3 )
+PYTHON_REQ_USE="ssl(+)"
+
+inherit distutils-r1
+
+DESCRIPTION="HTTP library with thread-safe connection pooling, file post, and more"
+HOMEPAGE="https://github.com/urllib3/urllib3"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-cygwin ~amd64-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="brotli test"
+RESTRICT="!test? ( test )"
+
+# dev-python/{pyopenssl,cryptography,idna,certifi} are optional runtime
+# dependencies. Do not add them to RDEPEND. They should be unnecessary with
+# modern versions of python (>= 3.2).
+RDEPEND="
+ >=dev-python/PySocks-1.5.8[${PYTHON_USEDEP}]
+ <dev-python/PySocks-2.0[${PYTHON_USEDEP}]
+ brotli? ( dev-python/brotlicffi[${PYTHON_USEDEP}] )
+"
+BDEPEND="
+ test? (
+ $(python_gen_cond_dep "
+ ${RDEPEND}
+ dev-python/brotlicffi[\${PYTHON_USEDEP}]
+ dev-python/mock[\${PYTHON_USEDEP}]
+ dev-python/pytest[\${PYTHON_USEDEP}]
+ dev-python/pytest-freezegun[\${PYTHON_USEDEP}]
+ >=dev-python/trustme-0.5.3[\${PYTHON_USEDEP}]
+ >=www-servers/tornado-4.2.1[\${PYTHON_USEDEP}]
+ " python3_{6,7,8,9})
+ )
+"
+
+python_prepare_all() {
+ # tests failing if 'localhost.' cannot be resolved
+ sed -e 's:test_dotted_fqdn:_&:' \
+ -i test/with_dummyserver/test_https.py || die
+ sed -e 's:test_request_host_header_ignores_fqdn_dot:_&:' \
+ -i test/with_dummyserver/test_socketlevel.py || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ local -x CI=1
+ # FIXME: get tornado ported
+ [[ ${EPYTHON} == python3* ]] || continue
+ # tests skipped for now
+ [[ ${EPYTHON} == python3.10 ]] && continue
+
+ local deselect=(
+ # TODO?
+ test/with_dummyserver/test_socketlevel.py::TestSocketClosing::test_timeout_errors_cause_retries
+ )
+
+ epytest ${deselect[@]/#/--deselect }
+}