summaryrefslogtreecommitdiff
path: root/dev-python/urllib3
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-05-24 09:01:51 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-05-24 09:01:51 +0100
commitbd2c7873be3178619accade4259ba907b6baca46 (patch)
treea2dd247d39fd3cd02086ae2248b0cd590397320c /dev-python/urllib3
parenta5d03e5440b3955446fba6d02de9f53ea4f6efc4 (diff)
gentoo auto-resync : 24:05:2023 - 09:01:50
Diffstat (limited to 'dev-python/urllib3')
-rw-r--r--dev-python/urllib3/Manifest2
-rw-r--r--dev-python/urllib3/urllib3-1.26.16.ebuild78
2 files changed, 80 insertions, 0 deletions
diff --git a/dev-python/urllib3/Manifest b/dev-python/urllib3/Manifest
index c648254952be..a9e76de324eb 100644
--- a/dev-python/urllib3/Manifest
+++ b/dev-python/urllib3/Manifest
@@ -1,5 +1,7 @@
DIST urllib3-1.26.15.tar.gz 301444 BLAKE2B 2681f0290a4f8b335dcdf384a0c0692cf51e88ea829f80c8c857be328b00c618978a84957da4e23826e4597fe90764eb36ab9acbbc33f9a6ec8df3e3ff3f4d48 SHA512 b6ddb29c15b2d729605a6acb7c602f18c75a937cdfe9649d35d790a59fbb1d96a8d68975ba0a4c073c9f1750e383c67b7566dbcd81b3e8611501e9f4153e9a2b
+DIST urllib3-1.26.16.tar.gz 303733 BLAKE2B 94c0cfb8696b15ff7aed25927ba584d0d67b150953586ca4d74ddc8f1d0a95ca447a482cf7d0f95728fad1e7e51a610e29c3e342ebe68e65a86789308544ea51 SHA512 caa58af5bf49644459a9074be659511b56c5d66802153c72ba2ba2eb9c0aafd56b4cd8f8588964ee7d2a9b16a5e114d62298ab1e128710260ed86f1e315b5571
DIST urllib3-2.0.2.tar.gz 277703 BLAKE2B 1c7935a6aca8e60ad212eb35ef76009b75a8d080b1a572fe229e94a200e75c352ab41d831dde3d4a4643ecbbe54c2128f9d9ca1850d978fd1730d6d730ce3ab0 SHA512 874674342259f2f9b77b4aac90bd525ea50d4b6134008c22eb0fe7a04e688797564c3ec8e556600f75416df2983c972867e8a569d5d85a8dda748948217af38e
EBUILD urllib3-1.26.15.ebuild 2315 BLAKE2B f66ea329585eea090f339bd996900c5073918b6efc38fbe1d6d2eaba835c426149ae274a33659d6e5cfeeda87c84048e210456c7013006f59e464dcd9a38ae25 SHA512 21bbd772075249cf7af1b2509374186af3fb37341a89098717dbc91caf407cd65ea700a0d205f30c12277f509bf966123719a014d496dba2175eda95ef26a123
+EBUILD urllib3-1.26.16.ebuild 2323 BLAKE2B 2d90d20776df48667ed29dac208add77f711700d008180f8f616eb033ff8cc1851361095f4c64b844331e44502526f1335fc90a25f6044d3064106d33c6a9556 SHA512 23dcc408f2e64e437b228ab86d4b09bb78adcd21c9c3403f9d9b4578ba318c27ddc74edccb18edb2142e70d744c1717f1ca466d8da52e73f1357c4a091a68fa0
EBUILD urllib3-2.0.2-r1.ebuild 1947 BLAKE2B 8de4b4e4e3cb744bf2eb43c9bbcee7bce1feb9bb92a540f4551d28ccfa69654d2ae9f1c6c0dba77725e1757e0e6561d120607f3f4b7eca1ef7cee78f0a1d8663 SHA512 a67410a45745c585c8306f733ddabfb238904426ffd032a1f05bea1dcb1f05ae208aa50a144779f61d503e7413191d704b1f16d0c6e26b186f7649e53feeb6e3
MISC metadata.xml 531 BLAKE2B 3ddfea4b8817c827437a79abae8cf4e9cda95addb1c6505ef13018587720bba0cf0788041c0b4cc8b25f319e7cb1c94117ae25b3cbb567f24373e8e89bedaa7b SHA512 7e7191f0338c4c47f01bdceb3d2c6ed94de2241e77fb3be6cbf3ecf8a0682730392a9ee5adf24304d9a322acc06bd84f4f90f1dddcb258cb2e9ba0de9952b693
diff --git a/dev-python/urllib3/urllib3-1.26.16.ebuild b/dev-python/urllib3/urllib3-1.26.16.ebuild
new file mode 100644
index 000000000000..cc75cabf45be
--- /dev/null
+++ b/dev-python/urllib3/urllib3-1.26.16.ebuild
@@ -0,0 +1,78 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+# please keep this ebuild at EAPI 8 -- sys-apps/portage dep
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_TESTED=( python3_{9..11} pypy3 )
+PYTHON_COMPAT=( "${PYTHON_TESTED[@]}" )
+PYTHON_REQ_USE="ssl(+)"
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="HTTP library with thread-safe connection pooling, file post, and more"
+HOMEPAGE="
+ https://github.com/urllib3/urllib3/
+ https://pypi.org/project/urllib3/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-cygwin ~amd64-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="brotli test"
+RESTRICT="!test? ( test )"
+
+# dev-python/{pyopenssl,cryptography,idna,certifi} are optional runtime
+# dependencies. Do not add them to RDEPEND. They should be unnecessary with
+# modern versions of python (>= 3.2).
+RDEPEND="
+ >=dev-python/PySocks-1.5.8[${PYTHON_USEDEP}]
+ <dev-python/PySocks-2.0[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+ brotli? ( dev-python/brotlicffi[${PYTHON_USEDEP}] )
+"
+BDEPEND="
+ test? (
+ $(python_gen_cond_dep "
+ ${RDEPEND}
+ dev-python/brotlicffi[\${PYTHON_USEDEP}]
+ dev-python/mock[\${PYTHON_USEDEP}]
+ dev-python/pytest[\${PYTHON_USEDEP}]
+ dev-python/pytest-freezegun[\${PYTHON_USEDEP}]
+ >=dev-python/tornado-4.2.1[\${PYTHON_USEDEP}]
+ >=dev-python/trustme-0.5.3[\${PYTHON_USEDEP}]
+ " "${PYTHON_TESTED[@]}")
+ )
+"
+
+src_prepare() {
+ distutils-r1_src_prepare
+
+ # unbundle urllib3
+ rm src/urllib3/packages/six.py || die
+ find -name '*.py' -exec sed -i \
+ -e 's:\([.]*\|urllib3\.\)\?packages\.six:six:g' \
+ -e 's:from \([.]*\|urllib3\.\)\?packages import six:import six:g' \
+ {} + || die
+}
+
+python_test() {
+ local -x CI=1
+ # FIXME: get tornado ported
+ # please keep in sync with BDEPEND!
+ if ! has "${EPYTHON}" "${PYTHON_TESTED[@]/_/.}"; then
+ einfo "Skipping tests on ${EPYTHON}"
+ return
+ fi
+
+ local EPYTEST_DESELECT=(
+ # unstable (relies on warning count)
+ test/with_dummyserver/test_proxy_poolmanager.py::TestHTTPProxyManager::test_proxy_verified_warning
+ )
+ has "${EPYTHON}" python3.{8..10} && EPYTEST_DESELECT+=(
+ test/contrib/test_pyopenssl.py::TestPyOpenSSLHelpers::test_get_subj_alt_name
+ )
+
+ epytest
+}