summaryrefslogtreecommitdiff
path: root/dev-python/urllib3
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-01-11 23:45:17 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-01-11 23:45:17 +0000
commit7051f2e58b6bbc371b2c94cead2715bf06310adb (patch)
treed8eb7cbcdfa3883fcdb1cb004774e17be52600b0 /dev-python/urllib3
parent3b4acc0bc0b77136b371d8a3119066f80f221efe (diff)
gentoo auto-resync : 11:01:2023 - 23:45:17
Diffstat (limited to 'dev-python/urllib3')
-rw-r--r--dev-python/urllib3/Manifest2
-rw-r--r--dev-python/urllib3/urllib3-1.26.14.ebuild78
2 files changed, 80 insertions, 0 deletions
diff --git a/dev-python/urllib3/Manifest b/dev-python/urllib3/Manifest
index a5752df802ca..f9301d3e376f 100644
--- a/dev-python/urllib3/Manifest
+++ b/dev-python/urllib3/Manifest
@@ -1,3 +1,5 @@
DIST urllib3-1.26.13.tar.gz 300476 BLAKE2B 495b6077d8a18347d731dcc69989688c2fed325a5ff89a7faa6eb1c17255d5748c54036292080e0e86842536f0d518da011a5bd64bd7f1064702d34985621af6 SHA512 022cbd10d91aa95d21293743dc1c36d4ed2dd3f95e60cab53b0aa3c1be489c7eafbc90c4cc7f6b67011ef4752fedb18c33d64a063542fdc525888b39e127b775
+DIST urllib3-1.26.14.tar.gz 300665 BLAKE2B d9373c6f88eae86bd74cbc1c20b352064135a5e3686cf594a3fc2375afa881696751a4e318970ce15adb8fadb60e334117e4d4e431eaa591ce7b13b7ce2ab606 SHA512 0a2dffcb4d3b199e1d82c2bb0d8f4e6b57466bdc43e31dbed62b392ef32e021f6d31cb53ebedef9e1a62b1113f7a370e9f0baa36e3fba942a2543473e4df0828
EBUILD urllib3-1.26.13.ebuild 2306 BLAKE2B 2398a3c08c5bd5885a62dfbc935b48e240d770da2ad11d0b42c10f36a107680a1b8c8b489334e59be87745d2b5f31f1c2cb53d8a5e34bc98359351d78d970cd2 SHA512 4f1a1c98fe418200996f92d07f2eec9a21cb1e81793ef159ac26eba661d5ceded27c2c11ba9931c7bd8fdb6495ef40f48325a561b7e9b27b774d15a099b24867
+EBUILD urllib3-1.26.14.ebuild 2314 BLAKE2B d1ed19df5648fa2631033084d95f2dc800d03021f843fba2f1d6a0393de9748652af18440edf5463291b2b589c32f85b84cc1f365e513e7c59eff32cf24bb833 SHA512 bb6b9727a407e702c05c08fad0505e6fa9457ff99e8e4e6d3e28054f0761c6f0ef7106a7e5c7a3db81fde7084f814946dff2bac8ae2dd4ba3eb836c02be7dd17
MISC metadata.xml 531 BLAKE2B 3ddfea4b8817c827437a79abae8cf4e9cda95addb1c6505ef13018587720bba0cf0788041c0b4cc8b25f319e7cb1c94117ae25b3cbb567f24373e8e89bedaa7b SHA512 7e7191f0338c4c47f01bdceb3d2c6ed94de2241e77fb3be6cbf3ecf8a0682730392a9ee5adf24304d9a322acc06bd84f4f90f1dddcb258cb2e9ba0de9952b693
diff --git a/dev-python/urllib3/urllib3-1.26.14.ebuild b/dev-python/urllib3/urllib3-1.26.14.ebuild
new file mode 100644
index 000000000000..0b77957e4251
--- /dev/null
+++ b/dev-python/urllib3/urllib3-1.26.14.ebuild
@@ -0,0 +1,78 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+# please keep this ebuild at EAPI 7 -- sys-apps/portage dep
+EAPI=7
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} pypy3 )
+PYTHON_REQ_USE="ssl(+)"
+
+inherit distutils-r1
+
+DESCRIPTION="HTTP library with thread-safe connection pooling, file post, and more"
+HOMEPAGE="
+ https://github.com/urllib3/urllib3/
+ https://pypi.org/project/urllib3/
+"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-cygwin ~amd64-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="brotli test"
+RESTRICT="!test? ( test )"
+
+# dev-python/{pyopenssl,cryptography,idna,certifi} are optional runtime
+# dependencies. Do not add them to RDEPEND. They should be unnecessary with
+# modern versions of python (>= 3.2).
+RDEPEND="
+ >=dev-python/PySocks-1.5.8[${PYTHON_USEDEP}]
+ <dev-python/PySocks-2.0[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+ brotli? ( dev-python/brotlicffi[${PYTHON_USEDEP}] )
+"
+BDEPEND="
+ test? (
+ $(python_gen_cond_dep "
+ ${RDEPEND}
+ dev-python/brotlicffi[\${PYTHON_USEDEP}]
+ dev-python/mock[\${PYTHON_USEDEP}]
+ dev-python/pytest[\${PYTHON_USEDEP}]
+ dev-python/pytest-freezegun[\${PYTHON_USEDEP}]
+ >=dev-python/tornado-4.2.1[\${PYTHON_USEDEP}]
+ >=dev-python/trustme-0.5.3[\${PYTHON_USEDEP}]
+ " python3_{8..11})
+ )
+"
+
+src_prepare() {
+ distutils-r1_src_prepare
+
+ # unbundle urllib3
+ rm src/urllib3/packages/six.py || die
+ find -name '*.py' -exec sed -i \
+ -e 's:\([.]*\|urllib3\.\)\?packages\.six:six:g' \
+ -e 's:from \([.]*\|urllib3\.\)\?packages import six:import six:g' \
+ {} + || die
+}
+
+python_test() {
+ local -x CI=1
+ # FIXME: get tornado ported
+ # please keep in sync with BDEPEND!
+ if ! has "${EPYTHON}" python3.{8..11}; then
+ einfo "Skipping tests on ${EPYTHON}"
+ return
+ fi
+
+ local EPYTEST_DESELECT=(
+ # unstable (relies on warning count)
+ test/with_dummyserver/test_proxy_poolmanager.py::TestHTTPProxyManager::test_proxy_verified_warning
+ )
+ has "${EPYTHON}" python3.{8..10} && EPYTEST_DESELECT+=(
+ test/contrib/test_pyopenssl.py::TestPyOpenSSLHelpers::test_get_subj_alt_name
+ )
+
+ epytest
+}