summaryrefslogtreecommitdiff
path: root/dev-python/urllib3
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-02-17 02:06:14 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-02-17 02:06:14 +0000
commit5987fa693ef880163ebde423615a177cb5bda20e (patch)
tree643ae0ed032ef417c538f8d04da516b9c2fa2a7d /dev-python/urllib3
parent41e056b08e4c5c8d6e78407a5586afa52867fd5f (diff)
gentoo auto-resync : 17:02:2023 - 02:06:14
Diffstat (limited to 'dev-python/urllib3')
-rw-r--r--dev-python/urllib3/Manifest2
-rw-r--r--dev-python/urllib3/urllib3-1.26.13.ebuild78
2 files changed, 0 insertions, 80 deletions
diff --git a/dev-python/urllib3/Manifest b/dev-python/urllib3/Manifest
index a525cfaf0746..e6ba9d10ba5c 100644
--- a/dev-python/urllib3/Manifest
+++ b/dev-python/urllib3/Manifest
@@ -1,5 +1,3 @@
-DIST urllib3-1.26.13.tar.gz 300476 BLAKE2B 495b6077d8a18347d731dcc69989688c2fed325a5ff89a7faa6eb1c17255d5748c54036292080e0e86842536f0d518da011a5bd64bd7f1064702d34985621af6 SHA512 022cbd10d91aa95d21293743dc1c36d4ed2dd3f95e60cab53b0aa3c1be489c7eafbc90c4cc7f6b67011ef4752fedb18c33d64a063542fdc525888b39e127b775
DIST urllib3-1.26.14.tar.gz 300665 BLAKE2B d9373c6f88eae86bd74cbc1c20b352064135a5e3686cf594a3fc2375afa881696751a4e318970ce15adb8fadb60e334117e4d4e431eaa591ce7b13b7ce2ab606 SHA512 0a2dffcb4d3b199e1d82c2bb0d8f4e6b57466bdc43e31dbed62b392ef32e021f6d31cb53ebedef9e1a62b1113f7a370e9f0baa36e3fba942a2543473e4df0828
-EBUILD urllib3-1.26.13.ebuild 2306 BLAKE2B cba511b14221ad58d48f3f9d4ae0548a6efa31e08d98ce93a0196b8045954c94052b8adbaff384035aa5646b2843285ae236c263f9520fa4d8d75df717c0875a SHA512 3cf38437f94495b182db0ed0f88095d7abb6b80ddec70ff2f99796d99ebd90c58131cafb64872c9c7ce8c4a76c458b37701d39b0f04d33db00c2eca963784444
EBUILD urllib3-1.26.14.ebuild 2306 BLAKE2B cba511b14221ad58d48f3f9d4ae0548a6efa31e08d98ce93a0196b8045954c94052b8adbaff384035aa5646b2843285ae236c263f9520fa4d8d75df717c0875a SHA512 3cf38437f94495b182db0ed0f88095d7abb6b80ddec70ff2f99796d99ebd90c58131cafb64872c9c7ce8c4a76c458b37701d39b0f04d33db00c2eca963784444
MISC metadata.xml 531 BLAKE2B 3ddfea4b8817c827437a79abae8cf4e9cda95addb1c6505ef13018587720bba0cf0788041c0b4cc8b25f319e7cb1c94117ae25b3cbb567f24373e8e89bedaa7b SHA512 7e7191f0338c4c47f01bdceb3d2c6ed94de2241e77fb3be6cbf3ecf8a0682730392a9ee5adf24304d9a322acc06bd84f4f90f1dddcb258cb2e9ba0de9952b693
diff --git a/dev-python/urllib3/urllib3-1.26.13.ebuild b/dev-python/urllib3/urllib3-1.26.13.ebuild
deleted file mode 100644
index 41161163613d..000000000000
--- a/dev-python/urllib3/urllib3-1.26.13.ebuild
+++ /dev/null
@@ -1,78 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-# please keep this ebuild at EAPI 7 -- sys-apps/portage dep
-EAPI=7
-
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{9..11} pypy3 )
-PYTHON_REQ_USE="ssl(+)"
-
-inherit distutils-r1
-
-DESCRIPTION="HTTP library with thread-safe connection pooling, file post, and more"
-HOMEPAGE="
- https://github.com/urllib3/urllib3/
- https://pypi.org/project/urllib3/
-"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~loong ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~x64-cygwin ~amd64-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
-IUSE="brotli test"
-RESTRICT="!test? ( test )"
-
-# dev-python/{pyopenssl,cryptography,idna,certifi} are optional runtime
-# dependencies. Do not add them to RDEPEND. They should be unnecessary with
-# modern versions of python (>= 3.2).
-RDEPEND="
- >=dev-python/PySocks-1.5.8[${PYTHON_USEDEP}]
- <dev-python/PySocks-2.0[${PYTHON_USEDEP}]
- dev-python/six[${PYTHON_USEDEP}]
- brotli? ( dev-python/brotlicffi[${PYTHON_USEDEP}] )
-"
-BDEPEND="
- test? (
- $(python_gen_cond_dep "
- ${RDEPEND}
- dev-python/brotlicffi[\${PYTHON_USEDEP}]
- dev-python/mock[\${PYTHON_USEDEP}]
- dev-python/pytest[\${PYTHON_USEDEP}]
- dev-python/pytest-freezegun[\${PYTHON_USEDEP}]
- >=dev-python/tornado-4.2.1[\${PYTHON_USEDEP}]
- >=dev-python/trustme-0.5.3[\${PYTHON_USEDEP}]
- " python3_{8..11})
- )
-"
-
-src_prepare() {
- distutils-r1_src_prepare
-
- # unbundle urllib3
- rm src/urllib3/packages/six.py || die
- find -name '*.py' -exec sed -i \
- -e 's:\([.]*\|urllib3\.\)\?packages\.six:six:g' \
- -e 's:from \([.]*\|urllib3\.\)\?packages import six:import six:g' \
- {} + || die
-}
-
-python_test() {
- local -x CI=1
- # FIXME: get tornado ported
- # please keep in sync with BDEPEND!
- if ! has "${EPYTHON}" python3.{8..11}; then
- einfo "Skipping tests on ${EPYTHON}"
- return
- fi
-
- local EPYTEST_DESELECT=(
- # unstable (relies on warning count)
- test/with_dummyserver/test_proxy_poolmanager.py::TestHTTPProxyManager::test_proxy_verified_warning
- )
- has "${EPYTHON}" python3.{8..10} && EPYTEST_DESELECT+=(
- test/contrib/test_pyopenssl.py::TestPyOpenSSLHelpers::test_get_subj_alt_name
- )
-
- epytest
-}