summaryrefslogtreecommitdiff
path: root/dev-python/urllib3
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-07-20 13:07:51 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-07-20 13:07:51 +0100
commit30114ae8ef07a32fea1e44a10b61f98c84142645 (patch)
tree1f5829906b913ee4637e04254cc50ffc1faab519 /dev-python/urllib3
parentaaa44376d7162304219748a3b6771d9a26fc80fe (diff)
gentoo auto-resync : 20:07:2023 - 13:07:51
Diffstat (limited to 'dev-python/urllib3')
-rw-r--r--dev-python/urllib3/Manifest2
-rw-r--r--dev-python/urllib3/urllib3-2.0.4.ebuild83
2 files changed, 85 insertions, 0 deletions
diff --git a/dev-python/urllib3/Manifest b/dev-python/urllib3/Manifest
index 804dc0491983..ee2d48d96c9d 100644
--- a/dev-python/urllib3/Manifest
+++ b/dev-python/urllib3/Manifest
@@ -1,5 +1,7 @@
DIST urllib3-1.26.16.tar.gz 303733 BLAKE2B 94c0cfb8696b15ff7aed25927ba584d0d67b150953586ca4d74ddc8f1d0a95ca447a482cf7d0f95728fad1e7e51a610e29c3e342ebe68e65a86789308544ea51 SHA512 caa58af5bf49644459a9074be659511b56c5d66802153c72ba2ba2eb9c0aafd56b4cd8f8588964ee7d2a9b16a5e114d62298ab1e128710260ed86f1e315b5571
DIST urllib3-2.0.3.tar.gz 280489 BLAKE2B 5cb68029b8ea2fc51c5abefe212ab4a58269e72f180d16e4c0bbef93284c3298195fa84e2f2d845663436c5397a73653a95d9970594dab6662077f77a11591a8 SHA512 fd586a12b25a30ea801cfd6e207854a0f762cefee54512d742b3fffcc772db9dd75f436f0b998edd32a60857a7bd818bd10f6984e26f2ea47f56b5c545ead45b
+DIST urllib3-2.0.4.tar.gz 281517 BLAKE2B 58635787069b6d8e83394ddacca2c70824c03190efb4e0838b9b80d8e8c1499fa0143e1d38ece4e2a7f9b34d6b50f9805050bf85707d98eb171307ff35f8b215 SHA512 64d55714d871716730af5a691fc222722cffc13b0603ecae597e5f4cfd82297beede2b08cedc030b2419bd446f51c4c6e54f466ad96c71dd0848abbf806b4db4
EBUILD urllib3-1.26.16.ebuild 2193 BLAKE2B 724c27ff2cd776ada5c8ddb43aab29e8a1a6c7b1a4b984a7b5c8050aa8036e908dc45c8a012fd83d3fe9a5a819578249b73b60d0cb573a47d133396813ecf96a SHA512 575c8e31fcacbe8542ac3067ae878ef0995cc4176d845e287edffc7223a8725af3940bba4b54f77d4f5a9125568076e45415176bdd4a2d470f8b7389129e68ec
EBUILD urllib3-2.0.3.ebuild 2494 BLAKE2B af18d795da61cf54139a7ee43a395ee3c17a5c184a8a75e57166267a68daa4aff9f7b000d893571c064d3e301cff5ac34961c11cdb06ae34556734ebefec271c SHA512 b6abf5492701b354e7e29ef6863b65cab62bc97e752b46bcf65bdcfdfb94c98b0180dc96bd98f10bf9f34d48a69834f01e01cf2c977ccd58c534ee48004e9d7f
+EBUILD urllib3-2.0.4.ebuild 3050 BLAKE2B a137223c90ba536be924e0f793059f9b5aae559aff7d1b670373625fa7d4731916db04d1573d12c213f9ee1c7ede962059a131e85804c640d7205e3f2b0ae287 SHA512 6bbe10465e3b6ff212efbde4dc56382878436d64872d8b6c636f92a1aa6e4ebe0e04c361c60c782622f571b9b9f0682cea04de5e62a66b7fcfc10833ca0598a4
MISC metadata.xml 531 BLAKE2B 3ddfea4b8817c827437a79abae8cf4e9cda95addb1c6505ef13018587720bba0cf0788041c0b4cc8b25f319e7cb1c94117ae25b3cbb567f24373e8e89bedaa7b SHA512 7e7191f0338c4c47f01bdceb3d2c6ed94de2241e77fb3be6cbf3ecf8a0682730392a9ee5adf24304d9a322acc06bd84f4f90f1dddcb258cb2e9ba0de9952b693
diff --git a/dev-python/urllib3/urllib3-2.0.4.ebuild b/dev-python/urllib3/urllib3-2.0.4.ebuild
new file mode 100644
index 000000000000..9a53866c278c
--- /dev/null
+++ b/dev-python/urllib3/urllib3-2.0.4.ebuild
@@ -0,0 +1,83 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+# please keep this ebuild at EAPI 8 -- sys-apps/portage dep
+EAPI=8
+
+DISTUTILS_USE_PEP517=hatchling
+PYTHON_TESTED=( python3_{10..12} pypy3 )
+PYTHON_COMPAT=( "${PYTHON_TESTED[@]}" )
+PYTHON_REQ_USE="ssl(+)"
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="HTTP library with thread-safe connection pooling, file post, and more"
+HOMEPAGE="
+ https://github.com/urllib3/urllib3/
+ https://pypi.org/project/urllib3/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~arm64-macos ~ppc-macos ~x64-macos ~x64-solaris"
+IUSE="brotli test zstd"
+RESTRICT="!test? ( test )"
+
+# [secure] extra is deprecated and slated for removal, we don't need it:
+# https://github.com/urllib3/urllib3/issues/2680
+RDEPEND="
+ >=dev-python/PySocks-1.5.8[${PYTHON_USEDEP}]
+ <dev-python/PySocks-2.0[${PYTHON_USEDEP}]
+ brotli? ( >=dev-python/brotlicffi-0.8.0[${PYTHON_USEDEP}] )
+ zstd? ( >=dev-python/zstandard-0.18.0[${PYTHON_USEDEP}] )
+"
+BDEPEND="
+ test? (
+ $(python_gen_cond_dep "
+ ${RDEPEND}
+ dev-python/brotlicffi[\${PYTHON_USEDEP}]
+ dev-python/freezegun[\${PYTHON_USEDEP}]
+ dev-python/pytest[\${PYTHON_USEDEP}]
+ >=dev-python/tornado-4.2.1[\${PYTHON_USEDEP}]
+ >=dev-python/trustme-0.5.3[\${PYTHON_USEDEP}]
+ >=dev-python/zstandard-0.18.0[\${PYTHON_USEDEP}]
+ " "${PYTHON_TESTED[@]}")
+ )
+"
+
+src_prepare() {
+ # upstream considers 0.5 s to be "long" for a timeout
+ # we get tons of test failures on *fast* systems because of that
+ sed -i -e '/LONG_TIMEOUT/s:0.5:5:' test/__init__.py || die
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ local -x CI=1
+ if ! has "${EPYTHON}" "${PYTHON_TESTED[@]/_/.}"; then
+ einfo "Skipping tests on ${EPYTHON}"
+ return
+ fi
+
+ local EPYTEST_DESELECT=(
+ # take forever
+ test/contrib/test_pyopenssl.py::TestSocketSSL::test_requesting_large_resources_via_ssl
+ test/with_dummyserver/test_socketlevel.py::TestSSL::test_requesting_large_resources_via_ssl
+ # stupid test, next bump please verify if they fixed it
+ test/test_poolmanager.py::TestPoolManager::test_deprecated_no_scheme
+ # fails with newer secure SSL configuration, which removes TLS 1.1
+ test/contrib/test_pyopenssl.py::TestHTTPS_TLSv1::test_verify_none_and_good_fingerprint
+ test/contrib/test_pyopenssl.py::TestHTTPS_TLSv1_1::test_verify_none_and_good_fingerprint
+ test/with_dummyserver/test_https.py::TestHTTPS_TLSv1::test_verify_none_and_good_fingerprint
+ test/with_dummyserver/test_https.py::TestHTTPS_TLSv1_1::test_verify_none_and_good_fingerprint
+ # TODO: timeouts
+ test/contrib/test_pyopenssl.py::TestSocketClosing::test_timeout_errors_cause_retries
+ test/with_dummyserver/test_socketlevel.py::TestSocketClosing::test_timeout_errors_cause_retries
+ # warnings, sigh
+ test/with_dummyserver/test_connectionpool.py::TestConnectionPool::test_request_chunked_is_deprecated
+ )
+
+ # plugins make tests slower, and more fragile
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest
+}