summaryrefslogtreecommitdiff
path: root/dev-python/urlgrabber
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-python/urlgrabber
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-python/urlgrabber')
-rw-r--r--dev-python/urlgrabber/Manifest6
-rw-r--r--dev-python/urlgrabber/files/urlgrabber-3.9.1.patch26
-rw-r--r--dev-python/urlgrabber/metadata.xml36
-rw-r--r--dev-python/urlgrabber/urlgrabber-3.10.1.ebuild21
-rw-r--r--dev-python/urlgrabber/urlgrabber-3.9.1-r2.ebuild27
5 files changed, 116 insertions, 0 deletions
diff --git a/dev-python/urlgrabber/Manifest b/dev-python/urlgrabber/Manifest
new file mode 100644
index 000000000000..f96bdc39cc9b
--- /dev/null
+++ b/dev-python/urlgrabber/Manifest
@@ -0,0 +1,6 @@
+AUX urlgrabber-3.9.1.patch 1057 BLAKE2B c285a0e3827c8c7f8e90e4869d67a92039b2d0fb1d7610cf89b05f598977b2d83859b81f7c03fd5f25fc4b27cd41a1c335124f9f17b2d5be0be1ab4fe844804a SHA512 0a02512f871f525f4b3a0126e92e92d1393876f477fe3ae4ff3b0780ba30c21349fb770da59f2af7acd008fcda6bb3c2193204f8334c9f5476bc4e0188bc60ec
+DIST urlgrabber-3.10.1.tar.gz 83735 BLAKE2B ea0b3c071f968b2632e89cf225906740685b0f1134d41cf8aaf7e6361110780f6c998b06e4d79527be7e7953c5c4a617d039477135135cc7fc13a0426f0d9ee0 SHA512 c44d32b17c5f8984d09ed46ae36b3e05dc69d041820cf979029bc325d8407bbd7e324f264be5886286cd99e123f51affec26638cab6e525f85e2a1c4247462d7
+DIST urlgrabber-3.9.1.tar.gz 72343 BLAKE2B 2c3d9e9a994e0a918bc364aae37664ad41ccb60a09c72c3862e7e79d44e50efedca362e321607ed2971822adc694a8a61b8a861625e830bbb897859e1c6888c9 SHA512 897f0bd09485c207d735a814fda7cf053c71262e31e87f358c473da770abaf7fd339ae6802df978091889c5d6fe123f74d5386d79c47f93b36cefbc22f44db47
+EBUILD urlgrabber-3.10.1.ebuild 527 BLAKE2B 7c568a36ecc331b448d6275c3c4131e8276e4f78e0a77583433aa462d036374f0023caee2e1cccbeb155f81ea670f3bc2e66db3fe66ec9b131636ddec2269adc SHA512 c99de32022bb0e7a023225240aa39dc88c7645b7f18e7480a65e51bd24c8ca0e80663a349d8d927aeadba7c1d5dce5772e061bac907189d4eee690eaffc2d0cf
+EBUILD urlgrabber-3.9.1-r2.ebuild 575 BLAKE2B afc2772f92f6a05bb415d5314beadcd2e3985d1809c9f7b489c2597116c767298f3d146c5eb4c8d33cd83a309cb58252af283b1a47e1619f862fb68e7977e10d SHA512 c0e0bafd6423c3a04d5ff538e35ee5e3386ed9784ec1f30439edcc9f9d479fae0e3bef6e30700da88cad4516c468b7d835eb7f94f1cbe609905f80cf6168749c
+MISC metadata.xml 1485 BLAKE2B a3ae1b3e600f302d2b5c32faae061fc44eb5924dbcacf1c9ea33b546bfb938b65f4541ab4a1427888f1233e3a19292275cdb2030b04f57f6aac1a36b2afe2444 SHA512 cb471d25797f7e39e9b27a6ad12131b2942e4f62128cdf02d53693b478c80a0cf3b48d0e562930149a98dcb2f71068e11475fe8c2bcddcbe010564beaa34df2b
diff --git a/dev-python/urlgrabber/files/urlgrabber-3.9.1.patch b/dev-python/urlgrabber/files/urlgrabber-3.9.1.patch
new file mode 100644
index 000000000000..bdcc9cb1d465
--- /dev/null
+++ b/dev-python/urlgrabber/files/urlgrabber-3.9.1.patch
@@ -0,0 +1,26 @@
+http://yum.baseurl.org/gitweb?p=urlgrabber.git;a=commitdiff;h=f4e57ece7ded0f7ad83c8a40fe8423fab7812264
+http://yum.baseurl.org/gitweb?p=urlgrabber.git;a=commitdiff;h=89cc380a2a251a1d2d8b91cf6df170fa546597aa
+
+diff --git a/urlgrabber/grabber.py b/urlgrabber/grabber.py
+index f98f423..7b7f979 100644
+--- a/urlgrabber/grabber.py
++++ b/urlgrabber/grabber.py
+@@ -1532,11 +1589,14 @@
+ def _over_max_size(self, cur, max_size=None):
+
+ if not max_size:
+- max_size = self.size
+- if self.opts.size: # if we set an opts size use that, no matter what
+- max_size = self.opts.size
++ if not self.opts.size:
++ max_size = self.size
++ else:
++ max_size = self.opts.size
++
+ if not max_size: return False # if we have None for all of the Max then this is dumb
+- if cur > max_size + max_size*.10:
++
++ if cur > int(float(max_size) * 1.10):
+
+ msg = _("Downloaded more than max size for %s: %s > %s") \
+ % (self.url, cur, max_size)
diff --git a/dev-python/urlgrabber/metadata.xml b/dev-python/urlgrabber/metadata.xml
new file mode 100644
index 000000000000..a1f005301924
--- /dev/null
+++ b/dev-python/urlgrabber/metadata.xml
@@ -0,0 +1,36 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+ </maintainer>
+ <longdescription>
+ A high-level cross-protocol url-grabber.
+
+ Using urlgrabber, data can be fetched in three basic ways:
+
+ urlgrab(url) copy the file to the local filesystem
+ urlopen(url) open the remote file and return a file object (like urllib2.urlopen)
+ urlread(url) return the contents of the file as a string
+
+
+ When using these functions (or methods), urlgrabber supports the following
+ features:
+
+ * identical behavior for http://, ftp://, and file:// urls
+ * http keepalive - faster downloads of many files by using only a single
+ connection
+ * byte ranges - fetch only a portion of the file
+ * reget - for a urlgrab, resume a partial download
+ * progress meters - the ability to report download progress automatically,
+ even when using urlopen!
+ * throttling - restrict bandwidth usage
+ * retries - automatically retry a download if it fails. The number of retries
+ and failure types are configurable.
+ * authenticated server access for http and ftp
+ * proxy support - support for authenticated http and ftp proxies
+ * mirror groups - treat a list of mirrors as a single source, automatically
+ switching mirrors if there is a failure.
+ </longdescription>
+</pkgmetadata>
diff --git a/dev-python/urlgrabber/urlgrabber-3.10.1.ebuild b/dev-python/urlgrabber/urlgrabber-3.10.1.ebuild
new file mode 100644
index 000000000000..a1f631b0b9a6
--- /dev/null
+++ b/dev-python/urlgrabber/urlgrabber-3.10.1.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+DESCRIPTION="Python module for downloading files"
+HOMEPAGE="http://urlgrabber.baseurl.org"
+SRC_URI="http://urlgrabber.baseurl.org/download/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="amd64 ~arm ~ia64 ppc ppc64 x86 ~x86-fbsd"
+IUSE=""
+
+DEPEND="dev-python/pycurl[${PYTHON_USEDEP}]"
+RDEPEND="${DEPEND}"
+# Entire testsuite relies on connecting to the i'net
diff --git a/dev-python/urlgrabber/urlgrabber-3.9.1-r2.ebuild b/dev-python/urlgrabber/urlgrabber-3.9.1-r2.ebuild
new file mode 100644
index 000000000000..a6b4f900325a
--- /dev/null
+++ b/dev-python/urlgrabber/urlgrabber-3.9.1-r2.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+DESCRIPTION="Python module for downloading files"
+HOMEPAGE="http://urlgrabber.baseurl.org"
+SRC_URI="http://urlgrabber.baseurl.org/download/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="amd64 ~ia64 ppc ppc64 x86 ~x86-fbsd"
+IUSE=""
+
+DEPEND="dev-python/pycurl[${PYTHON_USEDEP}]"
+RDEPEND="${DEPEND}"
+
+python_prepare_all() {
+ local PATCHES=(
+ "${FILESDIR}"/${P}.patch
+ )
+ distutils-r1_python_prepare_all
+}