summaryrefslogtreecommitdiff
path: root/dev-python/url-normalize
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-02-02 01:39:05 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-02-02 01:39:05 +0000
commitfcc5224904648a8e6eb528d7603154160a20022f (patch)
tree3bfce096b38a9cea8eed13fc70c1526c456e9abd /dev-python/url-normalize
parent2fd57282f0262ca084e05b0f2c63fbada395d02b (diff)
gentoo resync : 02.02.2022
Diffstat (limited to 'dev-python/url-normalize')
-rw-r--r--dev-python/url-normalize/Manifest1
-rw-r--r--dev-python/url-normalize/url-normalize-1.4.3-r1.ebuild33
2 files changed, 34 insertions, 0 deletions
diff --git a/dev-python/url-normalize/Manifest b/dev-python/url-normalize/Manifest
index f46c35b1c376..99feda68fc28 100644
--- a/dev-python/url-normalize/Manifest
+++ b/dev-python/url-normalize/Manifest
@@ -1,3 +1,4 @@
DIST url-normalize-1.4.3.gh.tar.gz 8478 BLAKE2B 2f15a597642626653c96f378b67794819645918473d17faad18187abe35bf7892b11c0bc78451e78f1146389beb3a6470fb3ea1610e60157fee7fbadd9863614 SHA512 46eaa1753b37e89d56cb19818144a7cf5b38653811720eb506732c35bb3732ef0c556420b22a9ee2c08e70e5b408aab7f44cea5e15d1ebe3d717c0c77706bfb8
+EBUILD url-normalize-1.4.3-r1.ebuild 754 BLAKE2B 2352db368f0b1fb635dd4e1058eeab5a66951f2b5a3f3060b1b58b214a389b670cf414e7b88b891014abd10ffbe9ca747b0cb265ee681f1e61cdfc8253d80a93 SHA512 fbf5db6f95ab72eed079c5364f05f106132984d21519faf12069726cd84322b4430807f34e37682345054586ec338d419c3c4588eed20a4907668f1675e06d3d
EBUILD url-normalize-1.4.3.ebuild 658 BLAKE2B af9ec3f71ea33e51725dc2bee122d213608899f7ce2a2592728bffaf99df8dc23724292b2ee62c2cc4c82728ee1dba52aab7ce0c1f0347ed368f4c111e0a0f04 SHA512 64671521df72857b45e150b013e6a28449d51b07377f95f9be32853e9137798605dbf9022f0bec795a6b370d7801081b54d2dddded7ef37feb4fd064ce58367a
MISC metadata.xml 380 BLAKE2B 946417a87cb302150d2cae0224f977f73614783006c53b6731844b43ad5ea3aaf006e617a3d8599d3bdfe33ebc69a490dfdb490b7a0b9443c5a162adbbd6e914 SHA512 16d3480c32f65fde3a9eca563e791136a7f8a70ce9c2506e00f6948f3f25ed535fe1cf82fcf49f8e22d9e0b99d9c5bc4f49fce21d4e755817db7ff0a53d15f73
diff --git a/dev-python/url-normalize/url-normalize-1.4.3-r1.ebuild b/dev-python/url-normalize/url-normalize-1.4.3-r1.ebuild
new file mode 100644
index 000000000000..8ede2a4e84e6
--- /dev/null
+++ b/dev-python/url-normalize/url-normalize-1.4.3-r1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 2021-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=poetry
+PYTHON_COMPAT=( python3_{8..10} )
+inherit distutils-r1
+
+DESCRIPTION="URL normalization for Python"
+HOMEPAGE="
+ https://github.com/niksite/url-normalize/
+ https://pypi.org/project/url-normalize/"
+SRC_URI="
+ https://github.com/niksite/url-normalize/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="dev-python/six[${PYTHON_USEDEP}]"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ # remove problematic pytest options
+ rm tox.ini || die
+ sed -e '/requires/s:poetry:&-core:' \
+ -e '/backend/s:poetry:&.core:' \
+ -i pyproject.toml || die
+ distutils-r1_src_prepare
+}