summaryrefslogtreecommitdiff
path: root/dev-python/uritemplate
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-05-14 11:09:11 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-05-14 11:09:11 +0100
commitdeba8115d2c2af26df42966b91ef04ff4dd79cde (patch)
tree9a48f42594e1a9e6b2020d5535a784314434d7a7 /dev-python/uritemplate
parent38423c67c8a23f6a1bc42038193182e2da3116eb (diff)
gentoo resync : 14.05.2020
Diffstat (limited to 'dev-python/uritemplate')
-rw-r--r--dev-python/uritemplate/Manifest1
-rw-r--r--dev-python/uritemplate/uritemplate-3.0.1-r1.ebuild30
2 files changed, 31 insertions, 0 deletions
diff --git a/dev-python/uritemplate/Manifest b/dev-python/uritemplate/Manifest
index 51723b48c199..80f10dea1868 100644
--- a/dev-python/uritemplate/Manifest
+++ b/dev-python/uritemplate/Manifest
@@ -1,3 +1,4 @@
DIST uritemplate-3.0.1.tar.gz 32806 BLAKE2B 71fb7ef9fbdd61f3a3f67c5615cfb65ab261b5f9ce1c5a534e155a9723990599bf50e9ee0934d870161f7f26fc3d0fbcc07fefa558fc55bca29e96259bba767a SHA512 260da5901d28ca2354d972e00ed468c9bcf2901f948cb7759ff3e9d3a7b67da90ba754e555d6695c5095801b106ffd422459f0860b901a75e01575e159eb8f48
+EBUILD uritemplate-3.0.1-r1.ebuild 667 BLAKE2B 176a989cbf0c051b9f4a411d9c302338de66479fa411abe6da8bffc318b1a9b07984003b6e9d66fd3ee3785622ae9e688fbf1fac9faf154dc6beeb63738d6c27 SHA512 c87224ccf2e815bbe1d2c76093ef2800dbff804b8850ebccb00a2970b35eeeff62d7f4163c136731dd1b3cac8e2a35a56267a976378b91f3123d941ee39eec25
EBUILD uritemplate-3.0.1.ebuild 548 BLAKE2B 70c9b5bd863dcd1427231cb798715a06d3d00014661d01ae3b39aeb1602722385862b59576606e1622d1a17e1bcbc1defc566288664f0addb37157801f1cd3cc SHA512 5d92b7d79ec2b0bacf65d6cbac85e44d604094f684185e350b81b325e272980ad7ee56867f7548fdfad67655625f22620c4a0c35735a51d96f60bdeacd9228ca
MISC metadata.xml 324 BLAKE2B 2279bd09d0632113a7f87be6510c579d6fb0ab9feadf54b1196b68591c3ce0343e26d862cf045261b52ef9b9a535de1416d26a57ec88f82189bd7a9dc3df285d SHA512 ea995ed18707c72981d9174d1a35a30b0c86eb9035acd9b229766d0c0e5e2baf25ccd2bdd1c5091e58b2dae799643c1af81a3fa18b66ad5795ff50595d27a51e
diff --git a/dev-python/uritemplate/uritemplate-3.0.1-r1.ebuild b/dev-python/uritemplate/uritemplate-3.0.1-r1.ebuild
new file mode 100644
index 000000000000..250a5e8d801c
--- /dev/null
+++ b/dev-python/uritemplate/uritemplate-3.0.1-r1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7,8} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Python implementation of RFC6570, URI Template"
+HOMEPAGE="https://pypi.org/project/uritemplate/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="Apache-2.0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ dev-python/simplejson[${PYTHON_USEDEP}]
+ !<=dev-python/google-api-python-client-1.3
+"
+BDEPEND="${RDEPEND}
+ test? (
+ dev-python/wheel[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest