summaryrefslogtreecommitdiff
path: root/dev-python/uritemplate
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-python/uritemplate
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-python/uritemplate')
-rw-r--r--dev-python/uritemplate/Manifest5
-rw-r--r--dev-python/uritemplate/metadata.xml11
-rw-r--r--dev-python/uritemplate/uritemplate-0.6.ebuild22
-rw-r--r--dev-python/uritemplate/uritemplate-3.0.0.ebuild22
4 files changed, 60 insertions, 0 deletions
diff --git a/dev-python/uritemplate/Manifest b/dev-python/uritemplate/Manifest
new file mode 100644
index 000000000000..ed5d22217000
--- /dev/null
+++ b/dev-python/uritemplate/Manifest
@@ -0,0 +1,5 @@
+DIST uritemplate-0.6.tar.gz 3508 BLAKE2B 41abd9a347a6ab0fae668a63c185d64e857cb88431a3b8ecaa673076a1fb700869c1679313ed772c2aade5952cbad7f0ce898f4be4ea280fe8d867cf1c280911 SHA512 19e9d2f7cb6275c1a3bc6e287d9d3bdbed4391541f29765130a8e33825321e33fe3220adc349794d179354bcb9d77571ae20ba7836034962f3713994c7cdbfbd
+DIST uritemplate-3.0.0.tar.gz 30038 BLAKE2B eac4deaa980a9a4618a245bfdc8b3df2180a4285b9197488e7556e3cbce88c4a52ee8bdfecc5f500d80d14a59f8ff0e1ecbcb3aedff422fa9853cb2d40e25df4 SHA512 9988ae6db1d0234a2dfb393ab0205dd7902c814b8a85e06a666b8fec44cacec90fc8852b64da068242cb57cbb2ed63478567224fcb6751df82605d1f0881ad6e
+EBUILD uritemplate-0.6.ebuild 561 BLAKE2B ad7764652c3f248e661b69b26bb93849578cc3624e203b1a2c3232af96bcfbb3d43c23264ea1b113ccb0d4c2baff817ac53712983920fa427913fb9937907fcd SHA512 bf76684f7d2863a326a86382063d4487f4b67050cacf044514aa319661967519e56ef0219448e3bb68743fe911b821d22c6bbbbbca2159f35b07ad3fcf95af04
+EBUILD uritemplate-3.0.0.ebuild 568 BLAKE2B 0489b5881fc6336f2fe383267eae6c6c36878facd4e7914bc6fde62cd54b5e7f4c796ed8b82edb3925d647641b2b370f29e986ff274e3d548a407b6729b734ee SHA512 3c848f8539beefa1f6c2a3a5c3e6cd3aa439fc7a86cc553de31e15c88d75e2e9913929fabe231a6db353609960347e47b08d8d7e1e2954cab62e1c7f802953f0
+MISC metadata.xml 324 BLAKE2B 2279bd09d0632113a7f87be6510c579d6fb0ab9feadf54b1196b68591c3ce0343e26d862cf045261b52ef9b9a535de1416d26a57ec88f82189bd7a9dc3df285d SHA512 ea995ed18707c72981d9174d1a35a30b0c86eb9035acd9b229766d0c0e5e2baf25ccd2bdd1c5091e58b2dae799643c1af81a3fa18b66ad5795ff50595d27a51e
diff --git a/dev-python/uritemplate/metadata.xml b/dev-python/uritemplate/metadata.xml
new file mode 100644
index 000000000000..6b42f668702c
--- /dev/null
+++ b/dev-python/uritemplate/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="pypi">uritemplate</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/uritemplate/uritemplate-0.6.ebuild b/dev-python/uritemplate/uritemplate-0.6.ebuild
new file mode 100644
index 000000000000..2dc4ec8d8c14
--- /dev/null
+++ b/dev-python/uritemplate/uritemplate-0.6.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} pypy pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Python implementation of RFC6570, URI Template"
+HOMEPAGE="https://pypi.org/project/uritemplate/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="Apache-2.0"
+KEYWORDS="amd64 arm x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+RDEPEND="
+ dev-python/simplejson[${PYTHON_USEDEP}]
+ !<=dev-python/google-api-python-client-1.3"
+DEPEND="${RDEPEND}"
diff --git a/dev-python/uritemplate/uritemplate-3.0.0.ebuild b/dev-python/uritemplate/uritemplate-3.0.0.ebuild
new file mode 100644
index 000000000000..52c980c86e9e
--- /dev/null
+++ b/dev-python/uritemplate/uritemplate-3.0.0.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} pypy pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Python implementation of RFC6570, URI Template"
+HOMEPAGE="https://pypi.org/project/uritemplate/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="Apache-2.0"
+KEYWORDS="amd64 arm ~arm64 x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+RDEPEND="
+ dev-python/simplejson[${PYTHON_USEDEP}]
+ !<=dev-python/google-api-python-client-1.3"
+DEPEND="${RDEPEND}"