summaryrefslogtreecommitdiff
path: root/dev-python/uri_template
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-04-16 13:07:24 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-04-16 13:07:24 +0100
commit0c100b7dd2b30e75b799d806df4ef899fd98e1ea (patch)
tree464c922e949c7e4d5d891fb2cdda5daee5612537 /dev-python/uri_template
parente68d405c5d712af4387159df07e226217bdda049 (diff)
gentoo resync : 16.04.2022
Diffstat (limited to 'dev-python/uri_template')
-rw-r--r--dev-python/uri_template/Manifest4
-rw-r--r--dev-python/uri_template/uri_template-1.1.0.ebuild2
-rw-r--r--dev-python/uri_template/uri_template-1.2.0.ebuild23
3 files changed, 27 insertions, 2 deletions
diff --git a/dev-python/uri_template/Manifest b/dev-python/uri_template/Manifest
index 22420c876d9b..13e2a2f7537a 100644
--- a/dev-python/uri_template/Manifest
+++ b/dev-python/uri_template/Manifest
@@ -1,3 +1,5 @@
DIST uri_template-v1.1.0.tar.gz 18014 BLAKE2B 01ac4439b6661d0d1e7adb5b5ebcc594497cdaeef24b33cbfc8a26f607e779a72ae20838dbbcce28278886c87df475adfd53c73287a4768d848f65b95ba2ce58 SHA512 b6d34931e750acc6c160e7157fc000984acc099023e9794163777679cbe706b8a646bab89e82171c0318827b7a7b9cfcfb997768120cabcf36e7982214321665
-EBUILD uri_template-1.1.0.ebuild 633 BLAKE2B 03e897c036d01e568d282cf88af4cf6aa3581f7c1ac050ef1ad0d216372df807d7f89f1bb0d784fa570af7195b0b1230dd3af9a43670c1d57c8ddcbeb352829e SHA512 471769f23935ba3194dce78436b59deb845dcab374ba80daa6edf07eeab66e5496d7bab699ea05476105db024e3e30eb695ffcc55ad86f8c354c21b4104d1ea8
+DIST uri_template-v1.2.0.tar.gz 18284 BLAKE2B cf857ccd8496111f61fb95af020514f1c484e5c3ff19829f28bc2dc112887fe276dac68aa21e0d092d42a22319e8d6ac8aff95c734aadd8417c56f57b0076256 SHA512 81b046bbc2dc4d5c0b40a76f13713c10e69d803e3d9da13ab69cc6d40569ef0a39c786a6637a66651a5c3d3e68807f923ad48a7feaf898ae3ca6fd03c0e68c37
+EBUILD uri_template-1.1.0.ebuild 658 BLAKE2B 7f4c44c92a22390f610a16ee6f067973040706c2d468ac2fcd5c65a64771e5e97584ce761dd5b12423ddb64d18b85343556424ebab74083c47590d63e4280d14 SHA512 67841fd510d2703a616d47a80544d43a917524ad997872fcf81729a0aba268a7ea30ca5fda04c43df802146ab14487b5f57960fa48a71f78ce86eb87c001c7c5
+EBUILD uri_template-1.2.0.ebuild 658 BLAKE2B 7f4c44c92a22390f610a16ee6f067973040706c2d468ac2fcd5c65a64771e5e97584ce761dd5b12423ddb64d18b85343556424ebab74083c47590d63e4280d14 SHA512 67841fd510d2703a616d47a80544d43a917524ad997872fcf81729a0aba268a7ea30ca5fda04c43df802146ab14487b5f57960fa48a71f78ce86eb87c001c7c5
MISC metadata.xml 595 BLAKE2B 06f55493da74b24bd7ee6266accaa73b33e3f48a1d7d0f176a6278231e281fe269e6825f34ad1fa122b6d11ac1f66b21696410ae51d0917868f02d2ea57814ec SHA512 148737f47b030bb76659503ca70582385c005ffa5168e46ccdcfc8f7729299c38bd3b6b20a875e69690ff1bbf117da61d92f0f4657b97cf172ac358241fd4709
diff --git a/dev-python/uri_template/uri_template-1.1.0.ebuild b/dev-python/uri_template/uri_template-1.1.0.ebuild
index d8cf7ad1ea00..2aa659f49c57 100644
--- a/dev-python/uri_template/uri_template-1.1.0.ebuild
+++ b/dev-python/uri_template/uri_template-1.1.0.ebuild
@@ -16,7 +16,7 @@ S="${WORKDIR}/${MY_P}"
LICENSE="MIT"
SLOT="0"
-KEYWORDS="~amd64 ~arm ~arm64 ~m68k ~ppc ~ppc64 ~riscv ~sparc ~x86"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
python_test() {
"${EPYTHON}" "test.py" || die "Tests fail with ${EPYTHON}."
diff --git a/dev-python/uri_template/uri_template-1.2.0.ebuild b/dev-python/uri_template/uri_template-1.2.0.ebuild
new file mode 100644
index 000000000000..2aa659f49c57
--- /dev/null
+++ b/dev-python/uri_template/uri_template-1.2.0.ebuild
@@ -0,0 +1,23 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( pypy3 python3_{8..10} )
+
+inherit distutils-r1
+
+MY_P="${PN}-v${PV}"
+DESCRIPTION="URI Template expansion in strict adherence to RFC 6570"
+HOMEPAGE="https://gitlab.linss.com/open-source/uri_template/"
+SRC_URI="https://gitlab.linss.com/open-source/${PN}/-/archive/v${PV}/${MY_P}.tar.gz"
+S="${WORKDIR}/${MY_P}"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+python_test() {
+ "${EPYTHON}" "test.py" || die "Tests fail with ${EPYTHON}."
+}