summaryrefslogtreecommitdiff
path: root/dev-python/uri_template/uri_template-1.2.0-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-06-29 12:04:12 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-06-29 12:04:12 +0100
commit0f558761aa2dee1017b4751e4017205e015a9560 (patch)
tree037df795519468a25d9362b4e95cdaeb84eb1cf9 /dev-python/uri_template/uri_template-1.2.0-r1.ebuild
parent752d6256e5204b958b0ef7905675a940b5e9172f (diff)
gentoo resync : 29.12.2022
Diffstat (limited to 'dev-python/uri_template/uri_template-1.2.0-r1.ebuild')
-rw-r--r--dev-python/uri_template/uri_template-1.2.0-r1.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/dev-python/uri_template/uri_template-1.2.0-r1.ebuild b/dev-python/uri_template/uri_template-1.2.0-r1.ebuild
new file mode 100644
index 000000000000..6338f0309acd
--- /dev/null
+++ b/dev-python/uri_template/uri_template-1.2.0-r1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( pypy3 python3_{8..11} )
+
+inherit distutils-r1
+
+MY_P="${PN}-v${PV}"
+DESCRIPTION="URI Template expansion in strict adherence to RFC 6570"
+HOMEPAGE="
+ https://gitlab.linss.com/open-source/uri_template/
+ https://pypi.org/project/uri-template/
+"
+SRC_URI="
+ https://gitlab.linss.com/open-source/${PN}/-/archive/v${PV}/${MY_P}.tar.gz
+"
+S="${WORKDIR}/${MY_P}"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~loong ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86"
+
+src_prepare() {
+ distutils-r1_src_prepare
+ # fix the version number
+ sed -i -e "/version/s:0\.0\.0:${PV}:" setup.py || die
+}
+
+python_test() {
+ "${EPYTHON}" "test.py" || die "Tests fail with ${EPYTHON}."
+}