summaryrefslogtreecommitdiff
path: root/dev-python/uri-template
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-08-11 21:35:53 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-08-11 21:35:53 +0100
commit26ed1f5a5b7138ff40e6ac14e66f198c40831424 (patch)
tree41b0c986a258b43e68bb831a7c2a384d882e0d59 /dev-python/uri-template
parent75949673f38270397841d9c2322dbb774ac41554 (diff)
gentoo auto-resync : 11:08:2023 - 21:35:53
Diffstat (limited to 'dev-python/uri-template')
-rw-r--r--dev-python/uri-template/Manifest3
-rw-r--r--dev-python/uri-template/metadata.xml12
-rw-r--r--dev-python/uri-template/uri-template-1.3.0.ebuild34
3 files changed, 49 insertions, 0 deletions
diff --git a/dev-python/uri-template/Manifest b/dev-python/uri-template/Manifest
new file mode 100644
index 000000000000..c4cdd9b92e31
--- /dev/null
+++ b/dev-python/uri-template/Manifest
@@ -0,0 +1,3 @@
+DIST uri-template-v1.3.0.tar.bz2 17076 BLAKE2B e8d6c1c35190beab4b2b51cf82dacd6e7bf51397abb142f89f975ce4e7c3067dd9c59895127446deafd84420b63ef62c1484c29037dd9e3833e0d0d55950dcc4 SHA512 654eb700de68a5b992b910e1ff0a038ed699453f021d1eb844d71ddebb32e3ffb77851b5704879bf3eb894eaca33477a0173223a5d9df6a06e33fdc27f6b0f5c
+EBUILD uri-template-1.3.0.ebuild 868 BLAKE2B 59e44dd96a11205e4da7c344ca305aae9cfd9e95fcb05685d7fefdce90cb58af14c9ed1f7c307766fb614d89172f4f17a2ea810881b57822a53017f72217a650 SHA512 cd23f745ee31b32a5ae9e7a15fec20cb1d919c74135832e47596e57d1ced13403d830cddb38b4702d354b7b4ac4615eebd376d8f13f41b4f324a405e01cf13b7
+MISC metadata.xml 340 BLAKE2B fa3cfe1b2c6ef81f0ac969adda1ef8acc343c72f401c558a85450c992d38f22dca596aecd65de5328a855763379876c55f9d4bd0d2c69c771521e8fe11f43f85 SHA512 8c740d7dd56ecb9fc6a0a06a478878028058c67de06a68ad49f181b08982793874ae571ba5c1ba8f519f988c41588275e5ebbf6c0ea8de992ac1ee82d9effd5d
diff --git a/dev-python/uri-template/metadata.xml b/dev-python/uri-template/metadata.xml
new file mode 100644
index 000000000000..c8c34f38db6f
--- /dev/null
+++ b/dev-python/uri-template/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="pypi">uri-template</remote-id>
+ </upstream>
+ <stabilize-allarches/>
+</pkgmetadata>
diff --git a/dev-python/uri-template/uri-template-1.3.0.ebuild b/dev-python/uri-template/uri-template-1.3.0.ebuild
new file mode 100644
index 000000000000..ffb87a11b0c2
--- /dev/null
+++ b/dev-python/uri-template/uri-template-1.3.0.ebuild
@@ -0,0 +1,34 @@
+# Copyright 2022-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( pypy3 python3_{10..12} )
+
+inherit distutils-r1
+
+MY_P="uri-template-v${PV}"
+DESCRIPTION="URI Template expansion in strict adherence to RFC 6570"
+HOMEPAGE="
+ https://gitlab.linss.com/open-source/python/uri-template/
+ https://pypi.org/project/uri-template/
+"
+SRC_URI="
+ https://gitlab.linss.com/open-source/python/uri-template/-/archive/v${PV}/${MY_P}.tar.bz2
+"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~loong ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~arm64-macos ~x64-macos"
+
+BDEPEND="
+ dev-python/setuptools-scm[${PYTHON_USEDEP}]
+"
+
+export SETUPTOOLS_SCM_PRETEND_VERSION=${PV}
+
+python_test() {
+ "${EPYTHON}" "test.py" || die "Tests fail with ${EPYTHON}"
+}