summaryrefslogtreecommitdiff
path: root/dev-python/uranium
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-05-04 12:02:00 +0100
committerV3n3RiX <venerix@redcorelinux.org>2019-05-04 12:02:00 +0100
commiteab5731cdf11d4ae8cdf111461d46fd96c5bdd37 (patch)
treece35c6d01b5ff5de95c3a20fef853b9a6518ad2e /dev-python/uranium
parentb7ebc951da8800f711142f69d9d958bde67a112d (diff)
gentoo resync : 04.05.2019
Diffstat (limited to 'dev-python/uranium')
-rw-r--r--dev-python/uranium/Manifest2
-rw-r--r--dev-python/uranium/uranium-3.4.1.ebuild62
2 files changed, 0 insertions, 64 deletions
diff --git a/dev-python/uranium/Manifest b/dev-python/uranium/Manifest
index 274b5196a66e..c7c619295536 100644
--- a/dev-python/uranium/Manifest
+++ b/dev-python/uranium/Manifest
@@ -1,6 +1,4 @@
AUX uranium-3.3.0-fix-install-paths.patch 1716 BLAKE2B 13ea6150f1cfb1a07ac1886be8281110bbca5abd39b78807fe67317052579efa0498bc8a321d09fc953c9358dfb963ed210451549d14d6f58ac4a94cc3e9a5d1 SHA512 a7007c74a2e46e281dc0db6fcc45475e36f3a261445c2162fe0a548e577cd7cc344957e3284c52fffdd21cf223e91ab5b4fc1936b6893de614c4143cd1b40419
-DIST uranium-3.4.1.tar.gz 646742 BLAKE2B eb65d5a35b3c63cfb069f6c1077a91b7aa10517dd7fe6938b639f1229e61c5c6aa892447cd9d5851df46808f01f237820811b4358a235c50a89f2333df3418ef SHA512 59e0a605f3d898765bb670104cabb7fb1471061934900e63b54c1a07219970e07414a3983e96a577f5986302779b7acedc8e0ef0da3756dceefc0170ec80645b
DIST uranium-3.6.0.tar.gz 668552 BLAKE2B 84ab1eed5474bf14aec5b7782b332e9846d14f589c0dfa7366c74ad682fdc0a8e5ef94a0b9576f0e80cf792b49132d3abb3f17341a2e8570d08bf898231deca6 SHA512 41779e9cf76dff8f74252f668d1cf909c93f4f1416f75d2ed263f89fcfccfbcebce5580d8202d8d1697491139db448bbfa76e2dbc761dd24cb98030b3241e80d
-EBUILD uranium-3.4.1.ebuild 1386 BLAKE2B edfd604861aadc381f2b921a80b73a637c619e951aea9002ab5e8cf42a3aa1e0ebc239cd697992ecc2f575484e5fd0ca2b2bae7848b791a93606fbc415f8d068 SHA512 1107c60e0eee9920beafe186f6a745b104fb0968c0dc80939901e5fcb51fe0487228c5f3b7b0e08491e5b75c6d1356381ad949889d961c906e1cad656c6f812a
EBUILD uranium-3.6.0-r1.ebuild 1416 BLAKE2B 3ea73653aa36adc305b81759ded97af57a2a5bd901a73815a8d0372ebc8fd5d1565626016f5b4a9d7556817e376ff696cfc84049201a570cf58b6dffe383bf6b SHA512 2716709771e66c3d2de8912c5fe4c5ad8f5bcc453575a1045c9e44225e5cb52fdb06240457ef8bf1c193f5b141f76c8ed912393e7fbfb555c5a48c64f0970979
MISC metadata.xml 975 BLAKE2B 42ea7df7c2ee42408ada0328335319d95edc41c92d8ae74d77fb178629e48c7ab7886e4ea07f058b9be9b67f04d29b795eb353e47de60370b7949158cb7798ca SHA512 6074599c0b62f2f527041621550ec183bfa26400eee212c3e9cd0ab9742917ddf762ef668a6bba4628cee8063a0f40104f21d25e260de1d164b61389c9544824
diff --git a/dev-python/uranium/uranium-3.4.1.ebuild b/dev-python/uranium/uranium-3.4.1.ebuild
deleted file mode 100644
index cd83c93f844d..000000000000
--- a/dev-python/uranium/uranium-3.4.1.ebuild
+++ /dev/null
@@ -1,62 +0,0 @@
-# Copyright 1999-2018 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-PYTHON_COMPAT=( python3_{5,6} )
-
-inherit cmake-utils python-single-r1
-
-MY_PN="Uranium"
-
-DESCRIPTION="A Python framework for building 3D printing related applications"
-HOMEPAGE="https://github.com/Ultimaker/Uranium"
-SRC_URI="https://github.com/Ultimaker/${MY_PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="LGPL-3"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="doc test"
-REQUIRED_USE="${PYTHON_REQUIRED_USE}"
-
-RDEPEND="${PYTHON_DEPS}
- ~dev-libs/libarcus-${PV}:=[python,${PYTHON_USEDEP}]
- <dev-python/PyQt5-5.10[${PYTHON_USEDEP},declarative,network,svg]
- dev-python/numpy[${PYTHON_USEDEP}]
- >=sci-libs/scipy-1.1[${PYTHON_USEDEP}]
- dev-qt/qtquickcontrols:5
- dev-qt/qtquickcontrols2:5"
-
-DEPEND="${RDEPEND}
- sys-devel/gettext
- doc? ( app-doc/doxygen )
- test? ( dev-python/pytest[${PYTHON_USEDEP}] )"
-
-DOCS=( README.md )
-
-PATCHES=( "${FILESDIR}/${PN}-3.3.0-fix-install-paths.patch" )
-
-S="${WORKDIR}/${MY_PN}-${PV}"
-
-src_configure() {
- local mycmakeargs=(
- -DPYTHON_SITE_PACKAGES_DIR="$(python_get_sitedir)" )
- cmake-utils_src_configure
-}
-
-src_compile() {
- cmake-utils_src_compile
- if use doc; then
- cmake-utils_src_compile doc
- DOCS+=( html )
- fi
-}
-
-src_test() {
- emake -C "${BUILD_DIR}" tests
-}
-
-src_install() {
- cmake-utils_src_install
- python_optimize "${D}usr/$(get_libdir)"
-}