summaryrefslogtreecommitdiff
path: root/dev-python/unittest-or-fail/unittest-or-fail-2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-10-20 21:54:06 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-10-20 21:54:06 +0100
commit62058fa8f1b95418543f8ae008b247d44cc8b09c (patch)
tree48811edf87b513f58aff374c669cdfd5b1827e15 /dev-python/unittest-or-fail/unittest-or-fail-2.ebuild
parentb3830a745865c7d85daf3317603ad23dac6434da (diff)
gentoo auto-resync : 20:10:2023 - 21:54:06
Diffstat (limited to 'dev-python/unittest-or-fail/unittest-or-fail-2.ebuild')
-rw-r--r--dev-python/unittest-or-fail/unittest-or-fail-2.ebuild9
1 files changed, 8 insertions, 1 deletions
diff --git a/dev-python/unittest-or-fail/unittest-or-fail-2.ebuild b/dev-python/unittest-or-fail/unittest-or-fail-2.ebuild
index 58339b522c59..e71959e95147 100644
--- a/dev-python/unittest-or-fail/unittest-or-fail-2.ebuild
+++ b/dev-python/unittest-or-fail/unittest-or-fail-2.ebuild
@@ -4,7 +4,7 @@
EAPI=8
DISTUTILS_USE_PEP517=flit
-PYTHON_COMPAT=( python3_{9..11} pypy3 )
+PYTHON_COMPAT=( python3_{10..12} pypy3 )
inherit distutils-r1
@@ -22,6 +22,13 @@ KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~loong ~m68k ~mips ppc ppc64 ~riscv
# Warning: do not use distutils_enable_tests to avoid a circular
# dependency on itself!
python_test() {
+ # unittest fails in python3.12 by default, and it is more strict
+ # than the behavior expected from unittest-or-fail. We only add
+ # 3.12 compat to workaround a pkgcheck limitation, so no point
+ # in fixing the tests.
+ # https://github.com/pkgcore/pkgcheck/issues/584
+ [[ ${EPYTHON} == python3.12 ]] && return
+
"${EPYTHON}" -m unittest -v test/test_unittest_or_fail.py ||
die "Tests failed with ${EPYTHON}"
}