summaryrefslogtreecommitdiff
path: root/dev-python/unittest-or-fail/unittest-or-fail-1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-03-20 00:40:44 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-03-20 00:40:44 +0000
commit4cbcc855382a06088e2f016f62cafdbcb7e40665 (patch)
tree356496503d52354aa6d9f2d36126302fed5f3a73 /dev-python/unittest-or-fail/unittest-or-fail-1.ebuild
parentfcc5224904648a8e6eb528d7603154160a20022f (diff)
gentoo resync : 20.03.2022
Diffstat (limited to 'dev-python/unittest-or-fail/unittest-or-fail-1.ebuild')
-rw-r--r--dev-python/unittest-or-fail/unittest-or-fail-1.ebuild25
1 files changed, 0 insertions, 25 deletions
diff --git a/dev-python/unittest-or-fail/unittest-or-fail-1.ebuild b/dev-python/unittest-or-fail/unittest-or-fail-1.ebuild
deleted file mode 100644
index b77f5a5cfc0a..000000000000
--- a/dev-python/unittest-or-fail/unittest-or-fail-1.ebuild
+++ /dev/null
@@ -1,25 +0,0 @@
-# Copyright 2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-DISTUTILS_USE_SETUPTOOLS=no
-PYTHON_COMPAT=( python3_{7..10} pypy3 )
-inherit distutils-r1
-
-DESCRIPTION="Run unittests or fail if no tests were found"
-HOMEPAGE="https://github.com/mgorny/unittest-or-fail/"
-SRC_URI="
- https://github.com/mgorny/unittest-or-fail/archive/v${PV}.tar.gz
- -> ${P}.tar.gz"
-
-LICENSE="BSD-2"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
-
-# Warning: do not use distutils_enable_tests to avoid a circular
-# dependency on itself!
-python_test() {
- "${EPYTHON}" -m unittest -v test/test_unittest_or_fail.py ||
- die "Tests failed with ${EPYTHON}"
-}