summaryrefslogtreecommitdiff
path: root/dev-python/unidiff/unidiff-0.7.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-08-17 11:36:49 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-08-17 11:36:49 +0100
commite2db47eaae00ec33f8971db44b68645c5d3b9590 (patch)
tree3ec0cf16ddb5854017e134fabebe14bf8cb94a34 /dev-python/unidiff/unidiff-0.7.0.ebuild
parent616579b5d773c50af31ee56f00105d96ce641ca2 (diff)
gentoo resync : 17.08.2021
Diffstat (limited to 'dev-python/unidiff/unidiff-0.7.0.ebuild')
-rw-r--r--dev-python/unidiff/unidiff-0.7.0.ebuild17
1 files changed, 17 insertions, 0 deletions
diff --git a/dev-python/unidiff/unidiff-0.7.0.ebuild b/dev-python/unidiff/unidiff-0.7.0.ebuild
new file mode 100644
index 000000000000..43ecf5b9b6db
--- /dev/null
+++ b/dev-python/unidiff/unidiff-0.7.0.ebuild
@@ -0,0 +1,17 @@
+# Copyright 2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+inherit distutils-r1
+
+DESCRIPTION="Unified diff parsing/metadata extraction library"
+HOMEPAGE="https://github.com/matiasb/python-unidiff https://pypi.org/project/unidiff/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+distutils_enable_tests unittest