summaryrefslogtreecommitdiff
path: root/dev-python/unidecode/unidecode-1.3.8.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-01-11 19:06:53 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-01-11 19:06:53 +0000
commit427aed27427f356a75db3288d7b96ce7e2a044b2 (patch)
tree259ea4d9db267c160cbae0bdd575dcd349d23d8b /dev-python/unidecode/unidecode-1.3.8.ebuild
parenteb72a69c0109ff53b8c18b2f6c3b160489376e2e (diff)
gentoo auto-resync : 11:01:2024 - 19:06:52
Diffstat (limited to 'dev-python/unidecode/unidecode-1.3.8.ebuild')
-rw-r--r--dev-python/unidecode/unidecode-1.3.8.ebuild20
1 files changed, 20 insertions, 0 deletions
diff --git a/dev-python/unidecode/unidecode-1.3.8.ebuild b/dev-python/unidecode/unidecode-1.3.8.ebuild
new file mode 100644
index 000000000000..658a3b8a24ba
--- /dev/null
+++ b/dev-python/unidecode/unidecode-1.3.8.ebuild
@@ -0,0 +1,20 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYPI_NO_NORMALIZE=1
+PYPI_PN=${PN^}
+PYTHON_COMPAT=( pypy3 python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Module providing ASCII transliterations of Unicode text"
+HOMEPAGE="https://pypi.org/project/Unidecode/"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~riscv ~sparc ~x86"
+
+distutils_enable_tests unittest