summaryrefslogtreecommitdiff
path: root/dev-python/unidecode/unidecode-1.3.6.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-10-01 13:10:51 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-10-01 13:10:51 +0100
commit8598ab9ad325d12d0f2901ecc0973e430dacd2b3 (patch)
tree593f226746c1f850f57bc10ffc81f7398d5a34f0 /dev-python/unidecode/unidecode-1.3.6.ebuild
parent42ff81a7480d9bba317b42fcca03b46da2a622ce (diff)
gentoo auto-resync : 01:10:2022 - 13:10:50
Diffstat (limited to 'dev-python/unidecode/unidecode-1.3.6.ebuild')
-rw-r--r--dev-python/unidecode/unidecode-1.3.6.ebuild21
1 files changed, 21 insertions, 0 deletions
diff --git a/dev-python/unidecode/unidecode-1.3.6.ebuild b/dev-python/unidecode/unidecode-1.3.6.ebuild
new file mode 100644
index 000000000000..737ca84c1ba9
--- /dev/null
+++ b/dev-python/unidecode/unidecode-1.3.6.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( pypy3 python3_{8..11} )
+
+inherit distutils-r1
+
+MY_P=Unidecode-${PV}
+DESCRIPTION="Module providing ASCII transliterations of Unicode text"
+HOMEPAGE="https://pypi.org/project/Unidecode/"
+SRC_URI="mirror://pypi/${MY_P:0:1}/${PN^}/${MY_P}.tar.gz"
+S="${WORKDIR}/${MY_P}"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~riscv ~sparc ~x86"
+
+distutils_enable_tests unittest