summaryrefslogtreecommitdiff
path: root/dev-python/unidecode/unidecode-1.3.5.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-09-28 21:15:05 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-09-28 21:15:05 +0100
commitbd7d7f7f69423122e08209eefb1a8fa1d363e35e (patch)
tree0e400772206f4eb6774b2790628119c0f89ffd49 /dev-python/unidecode/unidecode-1.3.5.ebuild
parente4faa07b4eb2f5e4f9756d33924b318b1349956a (diff)
gentoo auto-resync : 28:09:2022 - 21:15:04
Diffstat (limited to 'dev-python/unidecode/unidecode-1.3.5.ebuild')
-rw-r--r--dev-python/unidecode/unidecode-1.3.5.ebuild21
1 files changed, 21 insertions, 0 deletions
diff --git a/dev-python/unidecode/unidecode-1.3.5.ebuild b/dev-python/unidecode/unidecode-1.3.5.ebuild
new file mode 100644
index 000000000000..737ca84c1ba9
--- /dev/null
+++ b/dev-python/unidecode/unidecode-1.3.5.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( pypy3 python3_{8..11} )
+
+inherit distutils-r1
+
+MY_P=Unidecode-${PV}
+DESCRIPTION="Module providing ASCII transliterations of Unicode text"
+HOMEPAGE="https://pypi.org/project/Unidecode/"
+SRC_URI="mirror://pypi/${MY_P:0:1}/${PN^}/${MY_P}.tar.gz"
+S="${WORKDIR}/${MY_P}"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~riscv ~sparc ~x86"
+
+distutils_enable_tests unittest