summaryrefslogtreecommitdiff
path: root/dev-python/unearth
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-10-18 10:02:49 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-10-18 10:02:49 +0100
commit8aed242683822c23f5ed6a295d3464161e2d0880 (patch)
treecb1e15198402ba7e5f401a02469a6e7219a2e9b3 /dev-python/unearth
parentd0678ca0b0a7eefe3151a0b6c78f5ec2dd1c0ad8 (diff)
gentoo auto-resync : 18:10:2023 - 10:02:48
Diffstat (limited to 'dev-python/unearth')
-rw-r--r--dev-python/unearth/Manifest2
-rw-r--r--dev-python/unearth/unearth-0.11.2.ebuild39
2 files changed, 41 insertions, 0 deletions
diff --git a/dev-python/unearth/Manifest b/dev-python/unearth/Manifest
index a4284cabcc66..93caf09b8195 100644
--- a/dev-python/unearth/Manifest
+++ b/dev-python/unearth/Manifest
@@ -1,5 +1,7 @@
DIST unearth-0.10.0.tar.gz 270997 BLAKE2B 8b18df4616fc72025492aa187101bc1f338967b1738ef9ec33d16cbd906c1cf91c1b84e391538521b4a9d6ea40301eb0b7ed0926aa4e6c4d6ffc57401f9d78d9 SHA512 98799202939e1206b6fdd46eb61947c9f9f8068a6857f76aace8dd2c67a3fad9dd3b7a5232d7812b0dcd214c39a9e2a6fafbd18cbfeb9aa4c216571b88b3f131
DIST unearth-0.11.0.tar.gz 271154 BLAKE2B 405c97ef152afb241cb70d9b309fd1ac454be932c96f95b606bb6038ffb2369fbc55c6afabd86f6a15949182de276dcda035fdb17d4810933286a0fa0b567e42 SHA512 70a06a32f6f2ca74c16a55f9613b543d807e437bd99c0ebb02c0d721144cf45208df78940ee41911a8168c9181ec733b9aec2176038b2556d0e2ad5e8c2cc0d4
+DIST unearth-0.11.2.tar.gz 271479 BLAKE2B c3c3f6bfb3f207eb9a7d7667d966efb84e316579ebffc833e94664c089f0c92bc4915f62a07b53b79aa9f43098080231a3644808bf35172df407cd80a7be9096 SHA512 6ec961456640fe3ca8922e0ee83ecadb6b6fa3dd7b5977a228111ad3ad2d79782eb75d76d4a7066c29f53ce023471c2a38d9f587c35f8d04bb0704bdd6406f71
EBUILD unearth-0.10.0.ebuild 687 BLAKE2B 593b2a0c003808785c03b1a543564f7c403beb98e858f8991ee075271b4fd579c5141b9c3cfb94d8be9a6399afd177dfa23017a72bd2d70d2847cf98c590c04d SHA512 dd05341700e9788aa76664fed91afd2264f99d6bd8ce0c4b9ef21054e50dba42a642e6abb9706770207164a5eafa316abdfa6c3af8673afe655c1d3de06ceaab
EBUILD unearth-0.11.0.ebuild 818 BLAKE2B e2e8ce3d6e258627d32fe1e4a2f7cda8af19d2755def4d14715c61bdbd0d959f5659cb2fe9747df32268e20d5be9aa64e625aee17a02953f3ebee65667dc7b01 SHA512 7b965932ece6ab01a9d333fe33901d831336ede0cb14a4a273ff1a597d5ecf70f92d12dc92cdbcd0914b7170e60f9fbdf96c8a54cacccb43ccaa8a6087d6ea7b
+EBUILD unearth-0.11.2.ebuild 818 BLAKE2B e2e8ce3d6e258627d32fe1e4a2f7cda8af19d2755def4d14715c61bdbd0d959f5659cb2fe9747df32268e20d5be9aa64e625aee17a02953f3ebee65667dc7b01 SHA512 7b965932ece6ab01a9d333fe33901d831336ede0cb14a4a273ff1a597d5ecf70f92d12dc92cdbcd0914b7170e60f9fbdf96c8a54cacccb43ccaa8a6087d6ea7b
MISC metadata.xml 480 BLAKE2B 489aab9c338887392b943b48593bd9d752083d82fcf89a419e3677f2d24939af51cabe16641c3a16942f9658fe79f804af61cffc807cdeb909d44a6cff5ced5b SHA512 9fe2154826a2399f5570fa150445220f7490e10741275f77791b1d29522336912812e3f8905c026cb748845d2f2a005196185db6576708b47f1cdf582216182f
diff --git a/dev-python/unearth/unearth-0.11.2.ebuild b/dev-python/unearth/unearth-0.11.2.ebuild
new file mode 100644
index 000000000000..9c0635d2317b
--- /dev/null
+++ b/dev-python/unearth/unearth-0.11.2.ebuild
@@ -0,0 +1,39 @@
+# Copyright 2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=pdm-backend
+PYTHON_COMPAT=( pypy3 python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="A utility to fetch and download python packages"
+HOMEPAGE="
+ https://pypi.org/project/unearth/
+ https://github.com/frostming/unearth/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ dev-python/packaging[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/pytest-httpserver[${PYTHON_USEDEP}]
+ dev-python/flask[${PYTHON_USEDEP}]
+ dev-python/requests-wsgi-adapter[${PYTHON_USEDEP}]
+ dev-python/trustme[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest -p pytest_httpserver
+}