summaryrefslogtreecommitdiff
path: root/dev-python/unearth
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-07-22 02:49:03 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-07-22 02:49:03 +0100
commit293b7d4c34fb5285799bb5149595e29dae34cac9 (patch)
treeea6bb71bb2bbdb570695963f3127e5299e1ce1ba /dev-python/unearth
parent1e3cb587fdf303df9aeb0b00a1a45585e18f6134 (diff)
gentoo auto-resync : 22:07:2023 - 02:49:03
Diffstat (limited to 'dev-python/unearth')
-rw-r--r--dev-python/unearth/Manifest3
-rw-r--r--dev-python/unearth/metadata.xml15
-rw-r--r--dev-python/unearth/unearth-0.10.0.ebuild33
3 files changed, 51 insertions, 0 deletions
diff --git a/dev-python/unearth/Manifest b/dev-python/unearth/Manifest
new file mode 100644
index 000000000000..a69d7caf2148
--- /dev/null
+++ b/dev-python/unearth/Manifest
@@ -0,0 +1,3 @@
+DIST unearth-0.10.0.tar.gz 270997 BLAKE2B 8b18df4616fc72025492aa187101bc1f338967b1738ef9ec33d16cbd906c1cf91c1b84e391538521b4a9d6ea40301eb0b7ed0926aa4e6c4d6ffc57401f9d78d9 SHA512 98799202939e1206b6fdd46eb61947c9f9f8068a6857f76aace8dd2c67a3fad9dd3b7a5232d7812b0dcd214c39a9e2a6fafbd18cbfeb9aa4c216571b88b3f131
+EBUILD unearth-0.10.0.ebuild 687 BLAKE2B 593b2a0c003808785c03b1a543564f7c403beb98e858f8991ee075271b4fd579c5141b9c3cfb94d8be9a6399afd177dfa23017a72bd2d70d2847cf98c590c04d SHA512 dd05341700e9788aa76664fed91afd2264f99d6bd8ce0c4b9ef21054e50dba42a642e6abb9706770207164a5eafa316abdfa6c3af8673afe655c1d3de06ceaab
+MISC metadata.xml 423 BLAKE2B 168ef799c8ac77adfe8937a5693054ab763e158e23c94e604fe0edcde350b9f8ea4020ef04289cb59f91f293f22677ecca4a993fa526af8923264ac3a48368ec SHA512 47a9e79481d2774b496f785ca62b71890d2bab7900fca9d4be32ae12d53f78240ebea0ed30b15f10525f71af6298bde1eb13b9518fde04507d0d036bfd067231
diff --git a/dev-python/unearth/metadata.xml b/dev-python/unearth/metadata.xml
new file mode 100644
index 000000000000..112da0f56f24
--- /dev/null
+++ b/dev-python/unearth/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ </maintainer>
+ <maintainer type="person">
+ <email>chutzpah@gentoo.org</email>
+ <name>Patrick McLean</name>
+ </maintainer>
+ <stabilize-allarches/>
+ <upstream>
+ <remote-id type="pypi">unearth</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/unearth/unearth-0.10.0.ebuild b/dev-python/unearth/unearth-0.10.0.ebuild
new file mode 100644
index 000000000000..313a864aa056
--- /dev/null
+++ b/dev-python/unearth/unearth-0.10.0.ebuild
@@ -0,0 +1,33 @@
+# Copyright 2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=pdm-backend
+PYTHON_COMPAT=( pypy3 python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="A utility to fetch and download python packages"
+HOMEPAGE="
+ https://pypi.org/project/unearth/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ dev-python/packaging[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/pytest-httpserver[${PYTHON_USEDEP}]
+ dev-python/flask[${PYTHON_USEDEP}]
+ dev-python/requests-wsgi-adapter[${PYTHON_USEDEP}]
+ dev-python/trustme[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest