summaryrefslogtreecommitdiff
path: root/dev-python/unearth/unearth-0.12.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-10-25 14:40:37 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-10-25 14:40:37 +0100
commit2000f81da4dc9971f6e1e5d00b315816d4188f4c (patch)
tree479704e6bf1eeba3c58172680d8bc26b87c71e68 /dev-python/unearth/unearth-0.12.1.ebuild
parent6d57946e8f20a2294b96eca2e379d3e8e1c93384 (diff)
gentoo auto-resync : 25:10:2023 - 14:40:37
Diffstat (limited to 'dev-python/unearth/unearth-0.12.1.ebuild')
-rw-r--r--dev-python/unearth/unearth-0.12.1.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/dev-python/unearth/unearth-0.12.1.ebuild b/dev-python/unearth/unearth-0.12.1.ebuild
new file mode 100644
index 000000000000..9c0635d2317b
--- /dev/null
+++ b/dev-python/unearth/unearth-0.12.1.ebuild
@@ -0,0 +1,39 @@
+# Copyright 2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=pdm-backend
+PYTHON_COMPAT=( pypy3 python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="A utility to fetch and download python packages"
+HOMEPAGE="
+ https://pypi.org/project/unearth/
+ https://github.com/frostming/unearth/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ dev-python/packaging[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/pytest-httpserver[${PYTHON_USEDEP}]
+ dev-python/flask[${PYTHON_USEDEP}]
+ dev-python/requests-wsgi-adapter[${PYTHON_USEDEP}]
+ dev-python/trustme[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest -p pytest_httpserver
+}