summaryrefslogtreecommitdiff
path: root/dev-python/uncertainties
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-11-25 22:39:15 +0000
committerV3n3RiX <venerix@redcorelinux.org>2020-11-25 22:39:15 +0000
commitd934827bf44b7cfcf6711964418148fa60877668 (patch)
tree0625f358789b5e015e49db139cc1dbc9be00428f /dev-python/uncertainties
parent2e34d110f164bf74d55fced27fe0000201b3eec5 (diff)
gentoo resync : 25.11.2020
Diffstat (limited to 'dev-python/uncertainties')
-rw-r--r--dev-python/uncertainties/Manifest2
-rw-r--r--dev-python/uncertainties/uncertainties-3.1.4-r1.ebuild (renamed from dev-python/uncertainties/uncertainties-3.1.4.ebuild)17
2 files changed, 8 insertions, 11 deletions
diff --git a/dev-python/uncertainties/Manifest b/dev-python/uncertainties/Manifest
index a31a6d8a5ae8..d57897387a17 100644
--- a/dev-python/uncertainties/Manifest
+++ b/dev-python/uncertainties/Manifest
@@ -1,3 +1,3 @@
DIST uncertainties-3.1.4.tar.gz 148897 BLAKE2B 3e94b61ff6aac42a7910cafebee5b440541a020c58bc2ce402d0a056b5d278205f4a6556bf49073f5ded305cfa73ba7e9095e71d3963fd9b73e2e9e19ec360b5 SHA512 209ebbed1f9cf99e3263f6470b04fc737c6d34d878f7eb1d2a7df7e63d4d42b0460391a08f99d8fe09df8f7f0e1de8a8e6c2cbecaedc7f0373ab06d05fbeb955
-EBUILD uncertainties-3.1.4.ebuild 888 BLAKE2B d596855768d480ec5cfde978c737ed5d945603fdf011ad766c246f6acff8118f133c0775c808d479bfdc456871d1eab87a13a17048e05d87fbac49580d901a07 SHA512 023e083079fd873c91282baeba2abbb65a4ebf23cde330285d9e730630a68a1b34425838217fb161e77afd46febce0c8276ae6ed91480e50ae7f3ef8718a4c63
+EBUILD uncertainties-3.1.4-r1.ebuild 794 BLAKE2B 53807b3add853cf58144f80e822de94da0df2053263d7501c0b5e95786b16634be86f9e94713b2fd9210e0164d52aa53e13bceb07931c1f3f6bcbf9d742758f2 SHA512 a8a67f4fd6e3768b8413a6b0cb133d7aed0b728932152b15c2eaced64d9193f41a5912a39a3b7122d8db74671ccf5adb8f4e91d4644ea60abb32499350b701a4
MISC metadata.xml 859 BLAKE2B 54ae46c343fada9aabb973c5297eccb0abe7299a2a1f0009df1d083698c91ce25339cf63d77857febee0798b27a84ba83dde95e19255f45f8cb0141c6a009954 SHA512 833af2fd16f097d61942c7f9323d8e38688eead6d5d10ae8e7f2547c950cd53ab6ce28f434d2c1bb2f15b71ec55bfc30b8bd53a94a0c5f02e824e3ecb08ecc89
diff --git a/dev-python/uncertainties/uncertainties-3.1.4.ebuild b/dev-python/uncertainties/uncertainties-3.1.4-r1.ebuild
index f1decac029b5..0aff696ff8dd 100644
--- a/dev-python/uncertainties/uncertainties-3.1.4.ebuild
+++ b/dev-python/uncertainties/uncertainties-3.1.4-r1.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
PYTHON_COMPAT=( python3_{6..9} )
@@ -16,20 +16,17 @@ SLOT="0"
KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
IUSE="doc"
-RDEPEND="dev-python/numpy[${PYTHON_USEDEP}]"
-DEPEND="${RDEPEND}
- dev-python/setuptools[${PYTHON_USEDEP}]
+RDEPEND="
+ dev-python/numpy[${PYTHON_USEDEP}]
+ dev-python/future[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
"
distutils_enable_tests nose
-ppython_compile_all() {
- if use doc; then
- PYTHONPATH="${BUILD_DIR}"/lib esetup.py build_sphinx
- fi
-}
-
python_compile_all() {
use doc && "${PYTHON}" setup.py build_sphinx
}