summaryrefslogtreecommitdiff
path: root/dev-python/ukkonen
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2021-12-22 14:08:05 +0000
committerV3n3RiX <venerix@koprulu.sector>2021-12-22 14:08:05 +0000
commit93a93e9a3b53c1a73142a305ea1f8136846942ee (patch)
treeb9791a06ab3284e27b568412c59316c66240c682 /dev-python/ukkonen
parent2771f79232c273bc2a57d23bf335dd81ccf6af28 (diff)
gentoo resync : 22.12.2021
Diffstat (limited to 'dev-python/ukkonen')
-rw-r--r--dev-python/ukkonen/Manifest3
-rw-r--r--dev-python/ukkonen/files/ukkonen-1.0.1-musl-include.patch15
-rw-r--r--dev-python/ukkonen/ukkonen-1.0.1.ebuild31
3 files changed, 49 insertions, 0 deletions
diff --git a/dev-python/ukkonen/Manifest b/dev-python/ukkonen/Manifest
index 593ac2ad20a3..74598ebabcdb 100644
--- a/dev-python/ukkonen/Manifest
+++ b/dev-python/ukkonen/Manifest
@@ -1,3 +1,6 @@
+AUX ukkonen-1.0.1-musl-include.patch 427 BLAKE2B 23170cd4a78ddd157d1230c2a072180a472394a06ce7afa702c1ed0bdafccea726405387dc65bd963cb8a6e7ea21cc7179fc4b9d36622f28952ea6c0aa003760 SHA512 4146508c56ecbe4edc3f77a92536098f93152e8cd68a0c710a2af7a6ded357795a5cc015b31cc198f66939e9cf0a258cc9db41a0458209ec0458bd19332b1494
DIST ukkonen-1.0.0.gh.tar.gz 4541 BLAKE2B c93623523fc57b27bb68a2bb41fca51a967910c4936140bee628b4270e343e7902b9e7a6fb85bc89c197e2b0c6897c2d3f788886541bc8b6b7758a6f158a5c6c SHA512 87e3078e8cd4807af3f91c1be7766454705b077cb093eadac34d1af4d56b458813c1062eb086232bffa43b5ca7aa07ed88192e56dacce96c6781f16129111d79
+DIST ukkonen-1.0.1.gh.tar.gz 4547 BLAKE2B e574f21c0e26751e48d16409747b1979ae903c0cd812d52b1715eaa2025cf21c9d24aa3963de61c6ef4126eb4ace8fe974966e768d05c5db8372e0ae96941123 SHA512 23978b8e22454155e7d8a0d2dbb963f4aa5a6be6cdd75a74e8ec5e06fe32a96b6fc14f0f6d03089726bf761ad6d833dc68ea3fb6cad1ad2ee5b259043072875a
EBUILD ukkonen-1.0.0.ebuild 625 BLAKE2B a8dadfe11d9d1a4eb8e927629c579f7512664f366c3cc4f2d4f2d60668f582205aeab77eeea2ad526a9319545fda87536ee38cf6186fbd1fa63efb75d7958f5d SHA512 139930ed1b1e9c748a0c4a6cf4e702e1556768d3ad82495dba99eb6e8f76994829c2b7a864da7fcd0dab25f88e1e2e132943d90fac8c715de36743ced3a0e86f
+EBUILD ukkonen-1.0.1.ebuild 677 BLAKE2B 5e54f75ff39a2843230d107950f9e11416709a1cbc4164a4a4fb278c78d40be4dc3158b01612f2fc625b38e427322686a4f04b518cb36decb2be4515d954004c SHA512 5eedec0bb864ce87bfaa444d61e74bc340dfa0058b664c68172fd58bca7817b0a68123d4f3a9dc7ee9576cdccbcc0b556b5531fd81c838032638abb04cbc32b8
MISC metadata.xml 345 BLAKE2B 316467291e5dee76baeaaed62a17e6c5e6216dc8eec5ffbd0fe7465e8c70cd47a2b1ec0c15f082c4bc17a1794ebfec01ab65d6260b0bb6d7af9830e0233e379b SHA512 891214a8416169a7cffc49b0682d1e2e471da4683a7dd528da6d75045d11d16c18fe4bc9ad0c883fbe4a877878e7a0434af1244353910ccc3aa1c193fc2d7a16
diff --git a/dev-python/ukkonen/files/ukkonen-1.0.1-musl-include.patch b/dev-python/ukkonen/files/ukkonen-1.0.1-musl-include.patch
new file mode 100644
index 000000000000..0be1be4adefd
--- /dev/null
+++ b/dev-python/ukkonen/files/ukkonen-1.0.1-musl-include.patch
@@ -0,0 +1,15 @@
+https://bugs.gentoo.org/828871
+https://github.com/asottile/ukkonen/commit/1b2aa2833b08e00279ff77612e82dad152eb3c14.patch
+
+From: Joonas Niilola <juippis@gentoo.org>
+Date: Sat, 11 Dec 2021 10:39:16 +0200
+Subject: [PATCH] _ukkonen.cpp: add #include <cstdint>
+
+--- a/_ukkonen.cpp
++++ b/_ukkonen.cpp
+@@ -1,4 +1,5 @@
+ #include <algorithm>
++#include <cstdint>
+ #include <vector>
+
+ template <typename T> int64_t edit_distance_k_impl(
diff --git a/dev-python/ukkonen/ukkonen-1.0.1.ebuild b/dev-python/ukkonen/ukkonen-1.0.1.ebuild
new file mode 100644
index 000000000000..1fbfd7a8edd0
--- /dev/null
+++ b/dev-python/ukkonen/ukkonen-1.0.1.ebuild
@@ -0,0 +1,31 @@
+# Copyright 2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} pypy3 )
+inherit distutils-r1
+
+DESCRIPTION="Implementation of bounded Levenshtein distance (Ukkonen)"
+HOMEPAGE="
+ https://pypi.org/project/ukkonen/
+ https://github.com/asottile/ukkonen/"
+SRC_URI="
+ https://github.com/asottile/ukkonen/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="amd64 ~hppa ~ppc ~ppc64 ~riscv x86"
+
+RDEPEND="
+ $(python_gen_cond_dep '
+ dev-python/cffi[${PYTHON_USEDEP}]
+ ' 'python*')"
+BDEPEND="${RDEPEND}"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-musl-include.patch
+)
+
+distutils_enable_tests pytest