summaryrefslogtreecommitdiff
path: root/dev-python/ubelt/ubelt-0.10.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-08-26 00:09:36 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-08-26 00:09:36 +0100
commitb1c81de4fadbd00897700a7321f03b390d952b2e (patch)
treee6cc812351d4f105c110cfc363ebb497e996f47a /dev-python/ubelt/ubelt-0.10.0.ebuild
parent7c59acba5699c9c58090a7a738669669a7307023 (diff)
gentoo resync : 26.08.2021
Diffstat (limited to 'dev-python/ubelt/ubelt-0.10.0.ebuild')
-rw-r--r--dev-python/ubelt/ubelt-0.10.0.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/dev-python/ubelt/ubelt-0.10.0.ebuild b/dev-python/ubelt/ubelt-0.10.0.ebuild
new file mode 100644
index 000000000000..aad8e9f06c5c
--- /dev/null
+++ b/dev-python/ubelt/ubelt-0.10.0.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+inherit distutils-r1
+
+DESCRIPTION="A stdlib like feel, and extra batteries. Hashing, Caching, Timing, Progress"
+HOMEPAGE="https://github.com/Erotemic/ubelt"
+SRC_URI="https://github.com/Erotemic/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+SLOT="0"
+LICENSE="Apache-2.0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="dev-python/six[${PYTHON_USEDEP}]
+ dev-python/ordered-set[${PYTHON_USEDEP}]"
+
+DEPEND="test? ( dev-python/xdoctest[${PYTHON_USEDEP}] )"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local deselect=(
+ # relies on passwd being equal to ${HOME}
+ ubelt/util_path.py::userhome:0
+ )
+
+ epytest ${deselect[@]/#/--deselect } tests
+}