summaryrefslogtreecommitdiff
path: root/dev-python/u-msgpack-python
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-11-08 15:24:16 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-11-08 15:24:16 +0000
commit867ef65cd897014478ed65034b1ac3f139289a77 (patch)
tree3af9d9e893bca02bb644786f42dfaf2678d6908d /dev-python/u-msgpack-python
parentf077c725ef746943ec7902350b30ff569f5995ba (diff)
gentoo auto-resync : 08:11:2022 - 15:24:16
Diffstat (limited to 'dev-python/u-msgpack-python')
-rw-r--r--dev-python/u-msgpack-python/Manifest2
-rw-r--r--dev-python/u-msgpack-python/u-msgpack-python-2.7.2.ebuild22
2 files changed, 24 insertions, 0 deletions
diff --git a/dev-python/u-msgpack-python/Manifest b/dev-python/u-msgpack-python/Manifest
index 5bf1c01d93dd..78da4e818121 100644
--- a/dev-python/u-msgpack-python/Manifest
+++ b/dev-python/u-msgpack-python/Manifest
@@ -1,3 +1,5 @@
DIST u-msgpack-python-2.7.1.tar.gz 20631 BLAKE2B 10008f0653f969f1f5655c894be5b2497d692bf7ebf6d50de221695cab9c3a973c0870a8162efe6b61f2d9d4fb062c4130c07cddff8d64d6258d7d832efe4021 SHA512 0825b9edee28db2c954c9c0d64987a4640f11af52570c1ad834882a5fcd2e3a76eab3524cc3bb639cacfaf9eef27bf0a75656b4d02bca42b2d35b708348691d6
+DIST u-msgpack-python-2.7.2.tar.gz 20654 BLAKE2B 0365e4e778c9979d9154d8a267ba3bdaad9b2ef808723d2ae89e078fc0c8d76aebab234f1723985cf3b288274123e49571607599d6087ea234e3e8dc11e3a302 SHA512 e5d35bc03e5c23cfbaf9cc7f6459576e89b5dd19661ddff2a4ab5de2751e0b73c17e4685c6fead15ce2bf100b2250a3ba7cb10a7fa3f23debfa2141f4370b623
EBUILD u-msgpack-python-2.7.1-r1.ebuild 617 BLAKE2B a1f2c314652b07fad55cc7351e29b50bb35bb8715aa3f74213cfa7e5bfc69923cdbaf05c824d60c9e2846125af69d5186e56e878e5a25e2c8e37451c0edaa3c4 SHA512 f8a9802f2bdc4c6f46265ce4439f2999b8de6141467fa4898f58b7c9e9add44dbf2fa4ca1084ae0dcfb790b555bf3738adc94c04f854f5457ef2eefd89768dcc
+EBUILD u-msgpack-python-2.7.2.ebuild 625 BLAKE2B 9f1ba57688d8538a1a001fbf113483c04935e574ed0ba242722b0b7fcfc13261b3966ac7604283fc5069de85a7fa080a586e1f4b992a04c6b6080e9c89f08fa9 SHA512 5572f6b22ac7e9e3ad1a70234f6e98fc3aeb4ffb3f2436ea2add4d85b045646a646b52fa53457ed0a330745eb9f5024c1264ca4641537d2f668fa8cf0fa01fb0
MISC metadata.xml 932 BLAKE2B 6c35c0276d1f132074198ec85c5b80967dda5eceef914b3e8c444c50926a83638a97754a483fbadd6246931af2eaf5de86c97d48ce6346da55dce1e577ea47eb SHA512 cdc35e790e2c454af8e82456fa438bfbe0c9e569001bd94d416b48d37f6ca8e78540fb76ad37c72c1cd632eff2f66d782e28265c5825f94f989786cebba59e67
diff --git a/dev-python/u-msgpack-python/u-msgpack-python-2.7.2.ebuild b/dev-python/u-msgpack-python/u-msgpack-python-2.7.2.ebuild
new file mode 100644
index 000000000000..71f7b6947b7c
--- /dev/null
+++ b/dev-python/u-msgpack-python/u-msgpack-python-2.7.2.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="A portable, lightweight MessagePack serializer and deserializer"
+HOMEPAGE="
+ https://github.com/vsergeev/u-msgpack-python/
+ https://pypi.org/project/u-msgpack-python/
+"
+SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+distutils_enable_tests pytest