summaryrefslogtreecommitdiff
path: root/dev-python/u-msgpack-python/u-msgpack-python-2.7.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-08-21 23:14:26 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-08-21 23:14:26 +0100
commit7c59acba5699c9c58090a7a738669669a7307023 (patch)
treed51d27d020895a6b7a3298d9d1b9846c1fcb59a0 /dev-python/u-msgpack-python/u-msgpack-python-2.7.1.ebuild
parente2db47eaae00ec33f8971db44b68645c5d3b9590 (diff)
gentoo resync : 21.08.2021
Diffstat (limited to 'dev-python/u-msgpack-python/u-msgpack-python-2.7.1.ebuild')
-rw-r--r--dev-python/u-msgpack-python/u-msgpack-python-2.7.1.ebuild17
1 files changed, 17 insertions, 0 deletions
diff --git a/dev-python/u-msgpack-python/u-msgpack-python-2.7.1.ebuild b/dev-python/u-msgpack-python/u-msgpack-python-2.7.1.ebuild
new file mode 100644
index 000000000000..fbfbaed0935d
--- /dev/null
+++ b/dev-python/u-msgpack-python/u-msgpack-python-2.7.1.ebuild
@@ -0,0 +1,17 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{8..10} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="A portable, lightweight MessagePack serializer and deserializer"
+HOMEPAGE="https://github.com/vsergeev/u-msgpack-python https://pypi.org/project/u-msgpack-python/"
+SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~amd64-linux ~x86-linux"
+
+distutils_enable_tests pytest