summaryrefslogtreecommitdiff
path: root/dev-python/typeguard
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2021-12-05 02:47:11 +0000
committerV3n3RiX <venerix@koprulu.sector>2021-12-05 02:47:11 +0000
commit2771f79232c273bc2a57d23bf335dd81ccf6af28 (patch)
treec8af0fd04194aed03cf067d44e53c7edd3e9ab84 /dev-python/typeguard
parente9d044d4b9b71200a96adfa280848858c0f468c9 (diff)
gentoo resync : 05.12.2021
Diffstat (limited to 'dev-python/typeguard')
-rw-r--r--dev-python/typeguard/Manifest2
-rw-r--r--dev-python/typeguard/typeguard-2.13.2.ebuild39
2 files changed, 41 insertions, 0 deletions
diff --git a/dev-python/typeguard/Manifest b/dev-python/typeguard/Manifest
index 1864f0aaa55a..7372c2ab06ce 100644
--- a/dev-python/typeguard/Manifest
+++ b/dev-python/typeguard/Manifest
@@ -1,3 +1,5 @@
DIST typeguard-2.13.0.gh.tar.gz 36849 BLAKE2B ef9b724bdd5ef127b6ede4ff4cb1d4f4794b0e921512d2cbf474145bf64de0cae85b7f5283dfc7f0b750e79e1c44c03ce6b4c0f24a33ae961c428aa57f3b6ae5 SHA512 48df7a9d6ee2cc11b5118432afcda5e0939712ff66d67f3945e26047c0880a05c133b505869ebcef59ce438260b9f6d1806121d0d4828853bc3b9c3468769f39
+DIST typeguard-2.13.2.gh.tar.gz 37142 BLAKE2B 0aa3f53bc0d1aa485d071cd52d2458ab83c4d5eba88708240c100a3205a2714f39465cb48d82118eb6bcf1e30579e50bb5dffb31b3f2b673573481772d650a23 SHA512 a11c1b9ee417a99a8bd09f4b5b05c7cdf319748b8221a49d1ff76854e2f432768224437f82a41c0166e5b148a550b58afbabfa1935cdc2a049cda3010edd052a
EBUILD typeguard-2.13.0.ebuild 787 BLAKE2B 24994432b4544aa4a498917ab12f641451b99ba673714e437b3b203176345c0e557546c55de4bcb223e42a63cfa836cff510a2a9979d24e2c62aa578d5a139fd SHA512 44fad13c13e574b9ee8225400e58b1512828980650ed877d9497b20a07ea73d48cd8bd8e4cbd30ff8fcb6b1e10ba75c296b197c63c8f54226917ee4333963ba2
+EBUILD typeguard-2.13.2.ebuild 787 BLAKE2B 24994432b4544aa4a498917ab12f641451b99ba673714e437b3b203176345c0e557546c55de4bcb223e42a63cfa836cff510a2a9979d24e2c62aa578d5a139fd SHA512 44fad13c13e574b9ee8225400e58b1512828980650ed877d9497b20a07ea73d48cd8bd8e4cbd30ff8fcb6b1e10ba75c296b197c63c8f54226917ee4333963ba2
MISC metadata.xml 350 BLAKE2B 78dc7293e08dae7974b38d84ce457ceddc5888a7278c1b149b8ba3057f07130b2e002dd78a9df91fd09d85b7ebc26272b4c78dd96c6cdd3938cff67b9c451366 SHA512 1fe4c4164b0732bd294815dacdd46a70ace6e8886343491232fb59b6b3697316c3eac5dd72e2e4758d87fd093d845f4453b8f278009be640ca1555413f47e869
diff --git a/dev-python/typeguard/typeguard-2.13.2.ebuild b/dev-python/typeguard/typeguard-2.13.2.ebuild
new file mode 100644
index 000000000000..9ea46fa44506
--- /dev/null
+++ b/dev-python/typeguard/typeguard-2.13.2.ebuild
@@ -0,0 +1,39 @@
+# Copyright 2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+inherit distutils-r1
+
+DESCRIPTION="Run-time type checker for Python"
+HOMEPAGE="
+ https://pypi.org/project/typeguard/
+ https://github.com/agronholm/typeguard/"
+SRC_URI="
+ https://github.com/agronholm/typeguard/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+BDEPEND="
+ dev-python/setuptools_scm[${PYTHON_USEDEP}]
+ test? (
+ dev-python/typing-extensions[${PYTHON_USEDEP}]
+ )"
+
+distutils_enable_tests pytest
+
+export SETUPTOOLS_SCM_PRETEND_VERSION=${PV}
+
+python_test() {
+ local EPYTEST_IGNORE=(
+ # mypy changes results from version to version
+ tests/mypy
+ )
+
+ local -x PYTHONDONTWRITEBYTECODE=
+ epytest
+}