summaryrefslogtreecommitdiff
path: root/dev-python/typeguard/typeguard-2.12.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-08-07 00:16:33 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-08-07 00:16:33 +0100
commitd162ba1860a88062f4cd61f8b52fc303ba0b2991 (patch)
tree24cd2cf57f3932a24b96e4a0f6666489447e43ba /dev-python/typeguard/typeguard-2.12.1.ebuild
parent590b9b7b03bf4651e099949e318755af7cfa81b8 (diff)
gentoo resync : 07.08.2021
Diffstat (limited to 'dev-python/typeguard/typeguard-2.12.1.ebuild')
-rw-r--r--dev-python/typeguard/typeguard-2.12.1.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/dev-python/typeguard/typeguard-2.12.1.ebuild b/dev-python/typeguard/typeguard-2.12.1.ebuild
new file mode 100644
index 000000000000..92dfba2742ea
--- /dev/null
+++ b/dev-python/typeguard/typeguard-2.12.1.ebuild
@@ -0,0 +1,40 @@
+# Copyright 2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+inherit distutils-r1
+
+DESCRIPTION="Run-time type checker for Python"
+HOMEPAGE="
+ https://pypi.org/project/typeguard/
+ https://github.com/agronholm/typeguard/"
+SRC_URI="
+ https://github.com/agronholm/typeguard/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+BDEPEND="
+ dev-python/setuptools_scm[${PYTHON_USEDEP}]
+ test? (
+ dev-python/typing-extensions[${PYTHON_USEDEP}]
+ )"
+
+distutils_enable_tests pytest
+
+export SETUPTOOLS_SCM_PRETEND_VERSION=${PV}
+
+python_test() {
+ local -x PYTHONDONTWRITEBYTECODE=
+ local deselect=()
+ [[ ${EPYTHON} == python3.10 ]] && deselect+=(
+ # https://github.com/agronholm/typeguard/issues/199
+ tests/test_typeguard.py::TestCheckArgumentTypes::test_newtype
+ )
+ # mypy changes results from version to version
+ epytest --ignore tests/mypy ${deselect[@]/#/--deselect }
+}