summaryrefslogtreecommitdiff
path: root/dev-python/typeguard/typeguard-2.12.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2021-10-20 10:22:14 +0100
committerV3n3RiX <venerix@koprulu.sector>2021-10-20 10:22:14 +0100
commit46eedbedafdb0040c37884982d4c775ce277fb7b (patch)
treedb33a91259730be84999e13a8d8168c799f50ac0 /dev-python/typeguard/typeguard-2.12.1.ebuild
parente23a08d0c97a0cc415aaa165da840b056f93c997 (diff)
gentoo resync : 20.10.2021
Diffstat (limited to 'dev-python/typeguard/typeguard-2.12.1.ebuild')
-rw-r--r--dev-python/typeguard/typeguard-2.12.1.ebuild40
1 files changed, 0 insertions, 40 deletions
diff --git a/dev-python/typeguard/typeguard-2.12.1.ebuild b/dev-python/typeguard/typeguard-2.12.1.ebuild
deleted file mode 100644
index 92dfba2742ea..000000000000
--- a/dev-python/typeguard/typeguard-2.12.1.ebuild
+++ /dev/null
@@ -1,40 +0,0 @@
-# Copyright 2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-PYTHON_COMPAT=( python3_{8..10} )
-inherit distutils-r1
-
-DESCRIPTION="Run-time type checker for Python"
-HOMEPAGE="
- https://pypi.org/project/typeguard/
- https://github.com/agronholm/typeguard/"
-SRC_URI="
- https://github.com/agronholm/typeguard/archive/${PV}.tar.gz
- -> ${P}.gh.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-
-BDEPEND="
- dev-python/setuptools_scm[${PYTHON_USEDEP}]
- test? (
- dev-python/typing-extensions[${PYTHON_USEDEP}]
- )"
-
-distutils_enable_tests pytest
-
-export SETUPTOOLS_SCM_PRETEND_VERSION=${PV}
-
-python_test() {
- local -x PYTHONDONTWRITEBYTECODE=
- local deselect=()
- [[ ${EPYTHON} == python3.10 ]] && deselect+=(
- # https://github.com/agronholm/typeguard/issues/199
- tests/test_typeguard.py::TestCheckArgumentTypes::test_newtype
- )
- # mypy changes results from version to version
- epytest --ignore tests/mypy ${deselect[@]/#/--deselect }
-}