summaryrefslogtreecommitdiff
path: root/dev-python/txtorcon
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-05-25 03:04:18 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-05-25 03:04:18 +0100
commit4bc145ba9c79d57abcafc9b97c72bd5addd3e833 (patch)
tree6d3232c40367527f41a16208e51be62072e72efc /dev-python/txtorcon
parentcc6fb501ef0f4c443ce79d017dbfbd95072b14f4 (diff)
gentoo auto-resync : 25:05:2023 - 03:04:17
Diffstat (limited to 'dev-python/txtorcon')
-rw-r--r--dev-python/txtorcon/Manifest3
-rw-r--r--dev-python/txtorcon/metadata.xml13
-rw-r--r--dev-python/txtorcon/txtorcon-23.5.0.ebuild21
3 files changed, 37 insertions, 0 deletions
diff --git a/dev-python/txtorcon/Manifest b/dev-python/txtorcon/Manifest
new file mode 100644
index 000000000000..e42c5c39dd1a
--- /dev/null
+++ b/dev-python/txtorcon/Manifest
@@ -0,0 +1,3 @@
+DIST txtorcon-23.5.0.gh.tar.gz 394188 BLAKE2B ee63d2815a9b697aa37d27697ef6085dc91e750ba0cad854c8610eed7afcfec9b50cf5aead24f75676e2b0ee39167c50fbebc43a51911a3ebe17eb784b18d31e SHA512 33610c043084273f5dc06b797fff11bb0fccaae14229dbd07286e13e40ebc199594f6e52c64b87e4060e37bcb44bd90ccf7ff7217d923fdb33a581fb95144d56
+EBUILD txtorcon-23.5.0.ebuild 593 BLAKE2B c8bbbaaba1936e9b6621dd194078ea0eb309e3ba074ee5aba58a24e74c3ba5399d2cc80b2ffc0856b559529d2a90db1354997113c5f83ffda1c3919167830b4e SHA512 52a4043023eb9f1f69307d8b17efcc6b2578101c944ba0127c0404f31b79ffa605d828949221e71760f2ef9bbb3a3bfcea8e6ea26bbf26c8665eee46c1416be1
+MISC metadata.xml 398 BLAKE2B 5cff75ef9af25e3c3d1ef95de2d272d6f79c06a0e1101062d06bbc463010dcbf54d0ab2a94eaa049ba5050d53a703039fcf64de9ebc4c704bdc1bb25f909a3c8 SHA512 8c638e5e0e762bd5f2129f0a2696d50c91c304efecc627b4bc15e5f3e4fe811ca7bdfb20ca67546b2d9056cee80e7adbf1489c061df4dd85c94a08005b5acbbc
diff --git a/dev-python/txtorcon/metadata.xml b/dev-python/txtorcon/metadata.xml
new file mode 100644
index 000000000000..41f36acb77d0
--- /dev/null
+++ b/dev-python/txtorcon/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>tamiko@gentoo.org</email>
+ <name>Matthias Maier</name>
+ </maintainer>
+ <stabilize-allarches/>
+ <upstream>
+ <remote-id type="pypi">txtorcon</remote-id>
+ <remote-id type="github">meejah/txtorcon</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/txtorcon/txtorcon-23.5.0.ebuild b/dev-python/txtorcon/txtorcon-23.5.0.ebuild
new file mode 100644
index 000000000000..5222bc094733
--- /dev/null
+++ b/dev-python/txtorcon/txtorcon-23.5.0.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10..11} )
+DISTUTILS_USE_PEP517=setuptools
+
+inherit distutils-r1
+
+DESCRIPTION="Twisted-based Tor controller client, with state-tracking abstractions"
+HOMEPAGE="https://txtorcon.readthedocs.org https://pypi.org/project/txtorcon/"
+SRC_URI="https://github.com/meejah/${PN}/archive/refs/tags/v${PV}.tar.gz -> ${P}.gh.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ dev-python/automat[${PYTHON_USEDEP}]
+ dev-python/twisted[${PYTHON_USEDEP}]"