summaryrefslogtreecommitdiff
path: root/dev-python/txredisapi
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-07-21 10:04:00 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-07-21 10:04:00 +0100
commit7c334a9594ae315e537bf98259b95bafc60d479c (patch)
treefc41ac024e70df2bad3160b2d02fd5a01adde46b /dev-python/txredisapi
parentd1849ceeb9c09150c11cc0d112883cfba503af27 (diff)
gentoo auto-resync : 21:07:2023 - 10:04:00
Diffstat (limited to 'dev-python/txredisapi')
-rw-r--r--dev-python/txredisapi/Manifest2
-rw-r--r--dev-python/txredisapi/txredisapi-1.4.10.ebuild84
2 files changed, 86 insertions, 0 deletions
diff --git a/dev-python/txredisapi/Manifest b/dev-python/txredisapi/Manifest
index ed234d400170..523876c1a929 100644
--- a/dev-python/txredisapi/Manifest
+++ b/dev-python/txredisapi/Manifest
@@ -1,3 +1,5 @@
+DIST txredisapi-1.4.10.gh.tar.gz 54536 BLAKE2B d1224a95516323bfe3cf57b66612cea6b5fe7a4bd9aba0d2202f19575e1607209dc018ad6f754530ba07f09e89f38238f7ae3213898a33f317dc347722e055d7 SHA512 f0ba61c48807de90ec1dde5100b735f7fe0fb8168895d99ee77cbbfe741bae77e0495bf60f719d6cda65d6403c011c9bb15e6057e717afc4051cfdd7e514ddf9
DIST txredisapi-1.4.9.gh.tar.gz 54484 BLAKE2B faf66eecd51f007dae03d34a6fab8c204b01b44d4967281dbf52fce1d3dd0dbf261e0901902cd3484c8edb951d7b318266f7a72e04eee9c55ca1684e12bc2a7f SHA512 b471bd6cbb7c01f5e1a87e1fc45cc6daf7ed08e0e4168e641e4b1b16a92481d0643eafed22efa9d0dbd807dab46359b570176d97a03673987f4a04930e231fdd
+EBUILD txredisapi-1.4.10.ebuild 1880 BLAKE2B 1b99af78b6e30e1ad91c6b2e6f4d7dfc0f0fd40b81582ad29f796394a266cf2886c2f1f9cb191e3b13d72133fab890b61fd8411fe8b2f58e1810beb1f7674ded SHA512 d908c94f2fdcaca9a1db04d39e3d94c96a0a94d8d8e2b53d6823d3673a6c6eba387c99164f269123f91242e8a4fd0081666baf38592a5059b333e35284c218f7
EBUILD txredisapi-1.4.9.ebuild 1878 BLAKE2B b4e5f78168eaf081c5874bb11b71ac679d7bbfce9bf1fe6dcbc95965ae2018957e41a6baa71550fd87514ee2b2f9fd1ea9bf65b8aa9a31714f2ec3c50b2a584d SHA512 53ce9c2b0e1fc51d5001d882cf8443319c46fd9445cc3a0c31432a1648567baf3e5113bd3f640596dbb4f25f4f78000aff35a71e4602781346288776a4983f80
MISC metadata.xml 540 BLAKE2B 5d6aaf37b2dc2c74562fcf2d038617b12cbd6d27dfbfcb3eb91a9f1d9ba608f7ab32dc4efbf0712068877921d938b263623ffef7a5cbaee02c1da99166baf965 SHA512 9bf78049d4ef687b204f3b3392dc4ef17416c8de796013cbe59ae8b7dbc37ddaae62722e734fde192c0e7922fafc6c2f0a68a858087d8812128e93f4116df819
diff --git a/dev-python/txredisapi/txredisapi-1.4.10.ebuild b/dev-python/txredisapi/txredisapi-1.4.10.ebuild
new file mode 100644
index 000000000000..0f42671db075
--- /dev/null
+++ b/dev-python/txredisapi/txredisapi-1.4.10.ebuild
@@ -0,0 +1,84 @@
+# Copyright 2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+inherit distutils-r1 optfeature
+
+DESCRIPTION="Non-blocking redis client for python"
+HOMEPAGE="
+ https://github.com/IlyaSkriblovsky/txredisapi/
+ https://pypi.org/project/txredisapi/
+"
+# Github is used because PyPI archive does not contain tests,
+# see https://github.com/IlyaSkriblovsky/txredisapi/issues/149
+SRC_URI="
+ https://github.com/IlyaSkriblovsky/${PN}/archive/refs/tags/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc64"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ dev-python/six[${PYTHON_USEDEP}]
+ dev-python/twisted[${PYTHON_USEDEP},ssl(-)]
+"
+BDEPEND="
+ test? (
+ dev-db/redis
+ dev-python/hiredis[${PYTHON_USEDEP}]
+ dev-python/mock[${PYTHON_USEDEP}]
+ )
+"
+
+src_prepare() {
+ sed -i "/redis_sock =/s:/tmp:${T}:" tests/test_unix_connection.py || die
+
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ # paralellized tests with -j parameter fail
+ "${EPYTHON}" -m twisted.trial tests || die "tests failed with ${EPYTHON}"
+}
+
+src_test() {
+ local redis_pid="${T}"/redis.pid
+ local redis_port=6379
+
+ if has_version ">=dev-db/redis-7"; then
+ local extra_conf="
+ enable-debug-command yes
+ enable-module-command yes
+ "
+ fi
+
+ # Spawn Redis itself for testing purposes
+ einfo "Spawning Redis"
+ einfo "NOTE: Port ${redis_port} must be free"
+ "${EPREFIX}"/usr/sbin/redis-server - <<- EOF || die "Unable to start redis server"
+ daemonize yes
+ pidfile ${redis_pid}
+ port ${redis_port}
+ bind 127.0.0.1 ::1
+ unixsocket ${T}/redis.sock
+ unixsocketperm 700
+ ${extra_conf}
+ EOF
+
+ # Run the tests
+ distutils-r1_src_test
+
+ # Clean up afterwards
+ kill "$(<"${redis_pid}")" || die
+}
+
+pkg_postinst() {
+ optfeature "Use hiredis protocol parser" dev-python/hiredis
+}