summaryrefslogtreecommitdiff
path: root/dev-python/txAMQP/txAMQP-0.7.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 20:57:42 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 20:57:42 +0100
commit1798c4aeca70ac8d0a243684d6a798fbc65735f8 (patch)
treee48e19cb6fa03de18e1c63e1a93371b7ebc4eb56 /dev-python/txAMQP/txAMQP-0.7.0.ebuild
parentd87262dd706fec50cd150aab3e93883b6337466d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-python/txAMQP/txAMQP-0.7.0.ebuild')
-rw-r--r--dev-python/txAMQP/txAMQP-0.7.0.ebuild57
1 files changed, 0 insertions, 57 deletions
diff --git a/dev-python/txAMQP/txAMQP-0.7.0.ebuild b/dev-python/txAMQP/txAMQP-0.7.0.ebuild
deleted file mode 100644
index 7220086d7f04..000000000000
--- a/dev-python/txAMQP/txAMQP-0.7.0.ebuild
+++ /dev/null
@@ -1,57 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-PYTHON_COMPAT=( python2_7 )
-inherit distutils-r1
-
-MY_P=${PN,,}-${PV}
-DESCRIPTION="Python library for communicating with AMQP peers using Twisted"
-HOMEPAGE="https://github.com/txamqp/txamqp"
-# pypi tarball misses necessary test files
-SRC_URI="https://github.com/txamqp/txamqp/archive/${PV}.tar.gz -> ${MY_P}.tar.gz"
-
-LICENSE="Apache-2.0"
-KEYWORDS="~amd64 ~x86 ~x64-solaris"
-SLOT="0"
-IUSE="test"
-
-# TODO: split twisted-core gives minor test failure, get rid of it
-# when we port revdeps
-RDEPEND="
- || (
- dev-python/twisted[${PYTHON_USEDEP}]
- dev-python/twisted-core[${PYTHON_USEDEP}]
- )"
-DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
- test? (
- ${RDEPEND}
- net-misc/rabbitmq-server
- )"
-
-S=${WORKDIR}/${MY_P}
-
-# Tests connect to the system rabbitmq server
-# TODO: figure out how to start an isolated instance
-RESTRICT="test"
-
-python_test() {
- cd src || die
- # tests look for those files relatively to modules
- cp -r specs "${BUILD_DIR}"/lib || die
-
- TXAMQP_BROKER=RABBITMQ trial txamqp
- local ret=${?}
-
- # avoid installing spec files
- rm -r "${BUILD_DIR}"/lib/specs || die
-
- [[ ${ret} == 0 ]] || die "Tests failed with ${EPYTHON}"
-}
-
-python_install_all() {
- local DOCS=( doc/* )
-
- distutils-r1_python_install_all
-}