summaryrefslogtreecommitdiff
path: root/dev-python/twython
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-python/twython
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-python/twython')
-rw-r--r--dev-python/twython/Manifest5
-rw-r--r--dev-python/twython/metadata.xml12
-rw-r--r--dev-python/twython/twython-3.3.0.ebuild21
-rw-r--r--dev-python/twython/twython-3.6.0.ebuild21
4 files changed, 59 insertions, 0 deletions
diff --git a/dev-python/twython/Manifest b/dev-python/twython/Manifest
new file mode 100644
index 000000000000..72dafa8f36ba
--- /dev/null
+++ b/dev-python/twython/Manifest
@@ -0,0 +1,5 @@
+DIST twython-3.3.0.tar.gz 34164 BLAKE2B 82320b4fc787c97a3b1f773fdd3d5c0c636e6062eb630cc7d78625f45fb8478789e4acc3c9a7ebf600d7abb591bb6113e167a11eaa7b6afebb419652f1d9833f SHA512 888f37c37f39c603b08605d2e209afc329e079c405adbe3a03fde4dab2b76b07d2badf1956d255d4b7ff0bf2a4c308b20f2a3333a7ccd0e7b9c046e9172b1d5f
+DIST twython-3.6.0.tar.gz 36268 BLAKE2B 24305d2221cf7856f5e51bc3ec0fb4c342a8ce19c248ccc680bb1847e20a262f15399b4fe904852a159fc83a85d5617bd57c3ea9de064a5a25069175ae02178d SHA512 b99ecb244598a489578e63cec8a470daca7efe019f6a5277a0fda70b3c61ba25b56688b0a383337ed1c46576e551c244da82cd808710c4b9bb8ba91c6bc29be1
+EBUILD twython-3.3.0.ebuild 529 BLAKE2B 9e8c21a9a9e52e9df19ebeaee51c8604176c9e4f79b4925a73f4f19400fe76b444ec261719412d8f2d9577bfd094a637be02c3fbd4dd512d522251f28434960f SHA512 92dad9a9488ffa1429ecff35995c6c0ad7663f33553808a20fde698854c0b726a76c0029a2f2e8f6cd2398aaa1b3ff498d2069bed1cab82fc45f17ae995ae513
+EBUILD twython-3.6.0.ebuild 531 BLAKE2B 7f638f3a31a55ddfc49209ee8a0ff87e126a65e132999c3931645ba954d24d2176b8be50f8f54741b2019c4e574fd69d97ca969ce2365c3184b139de90322743 SHA512 362f7df075d4b5505c2060d558f14c5b2736ef095b0b53593e92471855af0af74a61c4d3613481f4a2fc56de4dd7872465b4d405ae60c9e7d50d4e7bd823393f
+MISC metadata.xml 381 BLAKE2B 8c4300189076c3f5cb8498a4aae6ce79751ccc3b51295ac6c75b8b290f71cc9f0aea946a7d7c4e75434372459aedcf7d0286c31039221c06e48b945904e35814 SHA512 6ba06a2be42b96f85609cc2a10637ff911228a8f0a5b5fa1debc3d4c6ba6d9e57462f09cdcb96e12f75544fd3a161d5e3ecb5a89e8f50fa152dc7ccc795048f6
diff --git a/dev-python/twython/metadata.xml b/dev-python/twython/metadata.xml
new file mode 100644
index 000000000000..2c06c1edaa41
--- /dev/null
+++ b/dev-python/twython/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">ryanmcgrath/twython</remote-id>
+ <remote-id type="pypi">twython</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/twython/twython-3.3.0.ebuild b/dev-python/twython/twython-3.3.0.ebuild
new file mode 100644
index 000000000000..811a837599ab
--- /dev/null
+++ b/dev-python/twython/twython-3.3.0.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} )
+
+inherit distutils-r1
+
+DESCRIPTION="An easy (and up to date) way to access Twitter data with Python"
+HOMEPAGE="https://github.com/ryanmcgrath/twython"
+SRC_URI="mirror://pypi/t/${PN}/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="MIT"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+DEPEND=""
+RDEPEND=">=dev-python/requests-2.1.0[${PYTHON_USEDEP}]
+ >=dev-python/requests-oauthlib-0.4.0[${PYTHON_USEDEP}]"
diff --git a/dev-python/twython/twython-3.6.0.ebuild b/dev-python/twython/twython-3.6.0.ebuild
new file mode 100644
index 000000000000..54482359fa6d
--- /dev/null
+++ b/dev-python/twython/twython-3.6.0.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} )
+
+inherit distutils-r1
+
+DESCRIPTION="An easy (and up to date) way to access Twitter data with Python"
+HOMEPAGE="https://github.com/ryanmcgrath/twython"
+SRC_URI="mirror://pypi/t/${PN}/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="MIT"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND=""
+RDEPEND=">=dev-python/requests-2.1.0[${PYTHON_USEDEP}]
+ >=dev-python/requests-oauthlib-0.4.0[${PYTHON_USEDEP}]"