summaryrefslogtreecommitdiff
path: root/dev-python/twython
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-03-20 00:40:44 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-03-20 00:40:44 +0000
commit4cbcc855382a06088e2f016f62cafdbcb7e40665 (patch)
tree356496503d52354aa6d9f2d36126302fed5f3a73 /dev-python/twython
parentfcc5224904648a8e6eb528d7603154160a20022f (diff)
gentoo resync : 20.03.2022
Diffstat (limited to 'dev-python/twython')
-rw-r--r--dev-python/twython/Manifest1
-rw-r--r--dev-python/twython/twython-3.9.1-r1.ebuild41
2 files changed, 42 insertions, 0 deletions
diff --git a/dev-python/twython/Manifest b/dev-python/twython/Manifest
index 9f6267eee48b..664ec9e01784 100644
--- a/dev-python/twython/Manifest
+++ b/dev-python/twython/Manifest
@@ -1,3 +1,4 @@
DIST twython-3.9.1.gh.tar.gz 372933 BLAKE2B 3db7f37e284ec83546e4f93a23e34c21ce9853e6206b62353e36b738ba591acadc55fd3dbbdf8cf7d74e63ab9966b9cdc7f49c5caa06e165bb7107b350509835 SHA512 e64d623dfa7ba2e81e09f9d8e784851b44201493d128ec576c4b5a9abc88debf1ca78f8a12933e0cd0a6b495012fa951bb62ea5d92db11186b37747b8576174f
+EBUILD twython-3.9.1-r1.ebuild 1250 BLAKE2B 6b8f9f8b6e09469c079ca557b31b689a98f83659241cbbccfd57bb801c8a193f6dc0906ef0cda134a4138860169434e21c246afa4f220edeac96b587c4530f85 SHA512 5808274521ae80615a439cded11351fa2707610d5d5c454549d42a0627751a57d9aa5b4794049909a77c76f9d01055e383cf15e63d090e1dfd48b27e57982c54
EBUILD twython-3.9.1.ebuild 1189 BLAKE2B 1e71e613cf822bfd6ddf7f323398f147a6084b4f77e8ff319235a6e87480b5529437252945c3dd7e8153f59436a9b3b00b4946fd51993fc1efc989685d52b7db SHA512 008d484c8d4f93ac9d4a9ae8b2536b0215887e65217293678df20ee848449fab6a4711920cc727932653ee81c2347247d19943af624c3ba0a02fd89bb7ee037b
MISC metadata.xml 407 BLAKE2B b4aac660a7929463899fafba57aab22c8175ae0f72587bb28fb765a8b0ec326085730bf3931562c27666917fe4d6d1ffa44462cb0856f46997f72d917201b7dd SHA512 cb71d9c30b5639d240bbb046479415d6520d42e3cff07fc30f8fc35366bcb188bf12f3a1088e8447964c824f264f98df29384f0ddc3fac7e11d1da0279df6414
diff --git a/dev-python/twython/twython-3.9.1-r1.ebuild b/dev-python/twython/twython-3.9.1-r1.ebuild
new file mode 100644
index 000000000000..6e483bc423d5
--- /dev/null
+++ b/dev-python/twython/twython-3.9.1-r1.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="An easy way to access Twitter data with Python"
+HOMEPAGE="https://github.com/ryanmcgrath/twython"
+SRC_URI="
+ https://github.com/ryanmcgrath/twython/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz"
+
+SLOT="0"
+LICENSE="MIT"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ >=dev-python/requests-2.1.0[${PYTHON_USEDEP}]
+ >=dev-python/requests-oauthlib-0.4.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/responses[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+EPYTEST_DESELECT=(
+ # tests are largely unmaintained and outdated
+ tests/test_core.py::TwythonAPITestCase::test_get_lastfunction_header_should_return_header
+ tests/test_core.py::TwythonAPITestCase::test_request_should_handle_400_for_missing_auth_data
+ tests/test_core.py::TwythonAPITestCase::test_request_should_handle_400_that_is_not_auth_related
+ tests/test_core.py::TwythonAPITestCase::test_request_should_handle_401
+ tests/test_core.py::TwythonAPITestCase::test_request_should_handle_rate_limit
+ tests/test_core.py::TwythonAPITestCase::test_sends_correct_accept_encoding_header
+)