summaryrefslogtreecommitdiff
path: root/dev-python/twisted-web
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-python/twisted-web
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-python/twisted-web')
-rw-r--r--dev-python/twisted-web/Manifest5
-rw-r--r--dev-python/twisted-web/metadata.xml8
-rw-r--r--dev-python/twisted-web/twisted-web-13.2.0.ebuild33
-rw-r--r--dev-python/twisted-web/twisted-web-15.2.1.ebuild33
4 files changed, 79 insertions, 0 deletions
diff --git a/dev-python/twisted-web/Manifest b/dev-python/twisted-web/Manifest
new file mode 100644
index 000000000000..aa5c728a3b0f
--- /dev/null
+++ b/dev-python/twisted-web/Manifest
@@ -0,0 +1,5 @@
+DIST TwistedWeb-13.2.0.tar.bz2 403931 BLAKE2B b003889c566b9063ffbef9eeb3f98af22eff4ba1b10cf2db1eb76ff3da08ac45d3892790943348c0d1cf4a28d8e66050aca9281409b47e48df42ec036a25e1af SHA512 69e721ec456214d000f88268340b7cf21186073af11e7f906bf95c9a1bfaf49fdc5832b4e39586ebdddd3f1378bf823ab147de58d7aa9e8491a2561a54389a1f
+DIST TwistedWeb-15.2.1.tar.bz2 231092 BLAKE2B 2bd561f973f0ce8ac67c1ee947f07b9b4fb82f7cff6e543ad324d8ef3e60d3be28b6290abd173362d49d824d4d4c23223361d30d94702176c385f5b9a7c048f3 SHA512 e2b155deed9b240f92f173e0fb188c1538ef2275cc6564b838dac8a5ac4c460e664791623cd3e3cde996b63f1619eff8d62636c2813e8b81da5054b8eea365e1
+EBUILD twisted-web-13.2.0.ebuild 1127 BLAKE2B 2206089f97d40c46130bad092e1a4618137abfc3fde48fc839e106ee7d394a574024c5d767550a24c7024a664e8062ac82e83571d6572df51e7d1acd121ecb84 SHA512 20d2f5bb58c1e9974d2606f7eac40639d99a1c446095b14d89e4b905442349c4573b59e26bdf33f2cbcabcc1800cd30a99562ce9f06d9a391c8e90f327ceb617
+EBUILD twisted-web-15.2.1.ebuild 1124 BLAKE2B efb3d72f351e6f27a2a3984e6cd4510662acba62f00edf59a8c66bf4832d66d7b16009f2e961cfc79854225af55097f24a03e4a7659e2853ee12f6fe68368233 SHA512 79716ae8b4e2710e84eddd7214e8fe788d6737e931898af37a4919d8c47d7f67fb6d6918dc6a66d32a33928eb79680ae0eefe9e13ece470021f26fb85c074cf3
+MISC metadata.xml 240 BLAKE2B 41e6a4d9da33dab2decc5ff419924f382a8f64d27a81fdb97576db8c6cf125be95911747946ec8be1b453f56617fef1084f5947f84b50a8db419d46df2ae8a0f SHA512 9c23321eaa853f851bf00195ea64ac2ba093e516f9b57855ee5aa58fbb1988130c9f0c17c2a9ce9fae4ee033e0a28a70c868e0f5acdfa1dd316ab533c5279d59
diff --git a/dev-python/twisted-web/metadata.xml b/dev-python/twisted-web/metadata.xml
new file mode 100644
index 000000000000..7f4f33c6dbc9
--- /dev/null
+++ b/dev-python/twisted-web/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+ </maintainer>
+</pkgmetadata>
diff --git a/dev-python/twisted-web/twisted-web-13.2.0.ebuild b/dev-python/twisted-web/twisted-web-13.2.0.ebuild
new file mode 100644
index 000000000000..cf18e709ba5e
--- /dev/null
+++ b/dev-python/twisted-web/twisted-web-13.2.0.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="5"
+PYTHON_COMPAT=( python2_7 )
+
+inherit twisted-r1
+
+MY_PN="TwistedWeb"
+DESCRIPTION="Twisted web server, programmable in Python"
+
+KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ppc64 ~s390 ~sh sparc x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="soap"
+
+DEPEND="
+ =dev-python/twisted-core-${TWISTED_RELEASE}*[${PYTHON_USEDEP}]
+ dev-python/pyopenssl[${PYTHON_USEDEP}]
+ soap? ( dev-python/soappy[${PYTHON_USEDEP}] )"
+RDEPEND="${DEPEND}
+ !dev-python/twisted
+"
+
+python_prepare_all() {
+ if [[ "${EUID}" -eq 0 ]]; then
+ # Disable tests failing with root permissions.
+ sed -e "s/test_forbiddenResource/_&/" -i twisted/web/test/test_static.py
+ sed -e "s/testDownloadPageError3/_&/" -i twisted/web/test/test_webclient.py
+ fi
+
+ distutils-r1_python_prepare_all
+}
+# testsuite has a PYTHONPATH oddity, currently appears to require a system install to effectively import,
+# putting in question as to whether it is a testsuite
diff --git a/dev-python/twisted-web/twisted-web-15.2.1.ebuild b/dev-python/twisted-web/twisted-web-15.2.1.ebuild
new file mode 100644
index 000000000000..b17a342f70b3
--- /dev/null
+++ b/dev-python/twisted-web/twisted-web-15.2.1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="5"
+PYTHON_COMPAT=( python2_7 )
+
+inherit twisted-r1
+
+MY_PN="TwistedWeb"
+DESCRIPTION="Twisted web server, programmable in Python"
+
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="soap"
+
+DEPEND="
+ =dev-python/twisted-core-${TWISTED_RELEASE}*[${PYTHON_USEDEP}]
+ dev-python/pyopenssl[${PYTHON_USEDEP}]
+ soap? ( dev-python/soappy[${PYTHON_USEDEP}] )"
+RDEPEND="${DEPEND}
+ !dev-python/twisted
+"
+
+python_prepare_all() {
+ if [[ "${EUID}" -eq 0 ]]; then
+ # Disable tests failing with root permissions.
+ sed -e "s/test_forbiddenResource/_&/" -i twisted/web/test/test_static.py
+ sed -e "s/testDownloadPageError3/_&/" -i twisted/web/test/test_webclient.py
+ fi
+
+ distutils-r1_python_prepare_all
+}
+# testsuite has a PYTHONPATH oddity, currently appears to require a system install to effectively import,
+# putting in question as to whether it is a testsuite