summaryrefslogtreecommitdiff
path: root/dev-python/twine
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-02-02 01:39:05 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-02-02 01:39:05 +0000
commitfcc5224904648a8e6eb528d7603154160a20022f (patch)
tree3bfce096b38a9cea8eed13fc70c1526c456e9abd /dev-python/twine
parent2fd57282f0262ca084e05b0f2c63fbada395d02b (diff)
gentoo resync : 02.02.2022
Diffstat (limited to 'dev-python/twine')
-rw-r--r--dev-python/twine/Manifest1
-rw-r--r--dev-python/twine/twine-3.7.0-r1.ebuild54
2 files changed, 55 insertions, 0 deletions
diff --git a/dev-python/twine/Manifest b/dev-python/twine/Manifest
index 8a2c2b692398..acca178a4169 100644
--- a/dev-python/twine/Manifest
+++ b/dev-python/twine/Manifest
@@ -1,3 +1,4 @@
DIST twine-3.7.0.tar.gz 212591 BLAKE2B 116d96a058cb53e0626747aaeae40c63fd6ece4ed8ef537c3890f99226f34827b65e5e894f5f04a24999d5ca2bcf182505e08075c4ff8b979d7be71e05f645ef SHA512 d7ddfdfcbaa7a5e3eba3657a06da090eeecbf373646e64d659f420fae4ba10c16c2c02e85bdf9c1f050b86177f19c85aa20183ad9d546cb053a11d60db0851f3
+EBUILD twine-3.7.0-r1.ebuild 1757 BLAKE2B f8f8ebb82a318a659a80b2a339584b8e751d356fff59e3cfeeeabd2ef9d95595bd74e643bccab19bbbdb7d465d5659ff6b25d4313261a557d6220ea9084f15f5 SHA512 8223ed4b19c29d80cf4cfbecc76666381da37ad8fbb5274e17e1f8c866e88bd4f4ccfd1db7f626564ff64ddf6b4823c48e337990d1232e3d6d473e7b6fef5e3e
EBUILD twine-3.7.0.ebuild 1767 BLAKE2B 87db4d515683515ad17ca978683b5956b090d2d85969250e5d613d14ff0e22bd1cb9970a48e62b30357d992c9d8056a8e73e6a15097e4b82eb9eb55ffe659c3e SHA512 15dc16ae73ce5a205c4e678d249a8dd8767672fe4d558bdc0269b39221dbe8efa876237c8d962e2f50d7ebe7c078a4bd465c5cbee6401dc1af7cee57981a95a8
MISC metadata.xml 383 BLAKE2B e2a596604a2f3e40ddd0196ea79105e318f8a04d9e5a2c7e458d403d215af1371f2a526fa7d8cbc430f20747f7b65ed6c8546263fb8a54ddd8a6db487c358634 SHA512 cd5c1f1ed89dc5c314975fc5b503108d6828db37826ebba98d6edd580b72cd41867e19e65a9a022f8c07babadecd810f21febeb8a015c51eecec412b9df4f0d5
diff --git a/dev-python/twine/twine-3.7.0-r1.ebuild b/dev-python/twine/twine-3.7.0-r1.ebuild
new file mode 100644
index 000000000000..8566ac09bad8
--- /dev/null
+++ b/dev-python/twine/twine-3.7.0-r1.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} pypy3 )
+inherit distutils-r1
+
+DESCRIPTION="Collection of utilities for publishing packages on PyPI"
+HOMEPAGE="https://twine.readthedocs.io/ https://github.com/pypa/twine https://pypi.org/project/twine/"
+SRC_URI="https://github.com/pypa/twine/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~riscv ~sparc ~x86 ~x64-macos"
+
+RDEPEND="
+ >=dev-python/colorama-0.4.3[${PYTHON_USEDEP}]
+ >=dev-python/importlib_metadata-3.6[${PYTHON_USEDEP}]
+ >=dev-python/keyring-15.1[${PYTHON_USEDEP}]
+ >=dev-python/pkginfo-1.8.1[${PYTHON_USEDEP}]
+ >=dev-python/readme_renderer-21.0[${PYTHON_USEDEP}]
+ >=dev-python/requests-2.20.0[${PYTHON_USEDEP}]
+ >=dev-python/requests-toolbelt-0.8.0[${PYTHON_USEDEP}]
+ >=dev-python/rfc3986-1.4.0[${PYTHON_USEDEP}]
+ >=dev-python/tqdm-4.14[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ dev-python/setuptools_scm[${PYTHON_USEDEP}]
+ test? (
+ dev-python/jaraco-envs[${PYTHON_USEDEP}]
+ dev-python/jaraco-functools[${PYTHON_USEDEP}]
+ dev-python/munch[${PYTHON_USEDEP}]
+ dev-python/portend[${PYTHON_USEDEP}]
+ dev-python/pretend[${PYTHON_USEDEP}]
+ dev-python/pypiserver[${PYTHON_USEDEP}]
+ dev-python/pytest[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ # requires internet
+ rm -f tests/test_integration.py || die
+ # pytest-socket dep relevant only to test_integration, and upstream
+ # disables it anyway
+ sed -i -e '/--disable-socket/d' pytest.ini || die
+ sed -i -e '/--cov/d' pytest.ini || die
+
+ distutils-r1_python_prepare_all
+ export SETUPTOOLS_SCM_PRETEND_VERSION=${PV}
+}