summaryrefslogtreecommitdiff
path: root/dev-python/twine
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-02-12 05:35:22 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-02-12 05:35:22 +0000
commitc1b4edfc987ed3d2b1f39cdf70d1b9a19e725616 (patch)
tree8bcb81da4787d5fa0f49486bd34de95aa0db76a4 /dev-python/twine
parenta3c403d854118e8ef0e2d661383445eb2d7ec732 (diff)
gentoo auto-resync : 12:02:2024 - 05:35:22
Diffstat (limited to 'dev-python/twine')
-rw-r--r--dev-python/twine/Manifest2
-rw-r--r--dev-python/twine/twine-5.0.0.ebuild78
2 files changed, 80 insertions, 0 deletions
diff --git a/dev-python/twine/Manifest b/dev-python/twine/Manifest
index 42adb3d392b7..1b41fcccd3c7 100644
--- a/dev-python/twine/Manifest
+++ b/dev-python/twine/Manifest
@@ -1,3 +1,5 @@
DIST twine-4.0.2.gh.tar.gz 214528 BLAKE2B c088329a86139eb01d325ec623504c0dfee1231ca8bbbf9ed73d46d4ed9dd79aaac6aaad225cacd64942eb7a3ead19bcb5e224ad9735d9760bd8c9c8e5e69043 SHA512 94dec0b08ea8f4cc5900d743b750f02a668c738d402632a80faef24220f87b4b14824966d6d902e9ddaab741e4091d6a370a7660d02ca27fd6fd0d251a473ab5
+DIST twine-5.0.0.gh.tar.gz 218873 BLAKE2B 0f4f92d3ee9ae0f154c68cbc165ce014cbd5c34d88f8067c5f9ab4b6cfd3fc9d435f9c1ada6911af2f711bef3c5607fdfd969ad454c06e3a9bbce4f23ebc2a07 SHA512 a1701844df03f0ca0e4b15eeae97e1a1a5788f13f04bbd5b084a9dc6637c2404aefc354705c974edd53b2f09517e088f5857cb211ed45ed7dbcedecb0f6392d5
EBUILD twine-4.0.2.ebuild 2089 BLAKE2B 34beb72614a45b6fb1051390955311f6cc24f297193b31d0496708b6092aec3553e999b7e098cbe1a09c16e1b5a2032744b89f1babb5287a15106bc39c7abf56 SHA512 689d07ca5a135783a7086a911f5a1c3bfb73284254b134f15b437597dc4c1e5af1931a490024b53abdc9b61300cc542fbac401ec9d4a840420d9df4d87ccec9c
+EBUILD twine-5.0.0.ebuild 2101 BLAKE2B 546f83dbb157e0721d6047abe54809f8170f9e84f970e3592ec56ee659a6ca23209f64a93dcebf7793c4366bc72acb946969f9d93cae69ccc88daa07692e18e2 SHA512 d7bbdc528ee7a2cc0a3a465dbb00826e3078b24f409bb9d9a0d0aa56dfb415dc94bff59db20680858b0af9088d14ed25cadf1115ca77d8f0b6e8ee1f2eb3b8e2
MISC metadata.xml 383 BLAKE2B e2a596604a2f3e40ddd0196ea79105e318f8a04d9e5a2c7e458d403d215af1371f2a526fa7d8cbc430f20747f7b65ed6c8546263fb8a54ddd8a6db487c358634 SHA512 cd5c1f1ed89dc5c314975fc5b503108d6828db37826ebba98d6edd580b72cd41867e19e65a9a022f8c07babadecd810f21febeb8a015c51eecec412b9df4f0d5
diff --git a/dev-python/twine/twine-5.0.0.ebuild b/dev-python/twine/twine-5.0.0.ebuild
new file mode 100644
index 000000000000..970c1576f1a5
--- /dev/null
+++ b/dev-python/twine/twine-5.0.0.ebuild
@@ -0,0 +1,78 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Collection of utilities for publishing packages on PyPI"
+HOMEPAGE="
+ https://twine.readthedocs.io/
+ https://github.com/pypa/twine/
+ https://pypi.org/project/twine/
+"
+SRC_URI="
+ https://github.com/pypa/twine/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~loong ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+ >=dev-python/colorama-0.4.3[${PYTHON_USEDEP}]
+ >=dev-python/importlib-metadata-3.6[${PYTHON_USEDEP}]
+ >=dev-python/keyring-15.1[${PYTHON_USEDEP}]
+ >=dev-python/pkginfo-1.8.1[${PYTHON_USEDEP}]
+ >=dev-python/readme-renderer-35.0[${PYTHON_USEDEP}]
+ >=dev-python/requests-2.20.0[${PYTHON_USEDEP}]
+ >=dev-python/requests-toolbelt-0.8.0[${PYTHON_USEDEP}]
+ >=dev-python/rfc3986-1.4.0[${PYTHON_USEDEP}]
+ >=dev-python/rich-12.0.0[${PYTHON_USEDEP}]
+ >=dev-python/urllib3-1.26.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ dev-python/setuptools-scm[${PYTHON_USEDEP}]
+ test? (
+ dev-python/build[${PYTHON_USEDEP}]
+ dev-python/jaraco-envs[${PYTHON_USEDEP}]
+ dev-python/jaraco-functools[${PYTHON_USEDEP}]
+ dev-python/munch[${PYTHON_USEDEP}]
+ dev-python/portend[${PYTHON_USEDEP}]
+ dev-python/pretend[${PYTHON_USEDEP}]
+ dev-python/pypiserver[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ # pytest-socket dep relevant only to test_integration, and upstream
+ # disables it anyway
+ sed -i -e '/--disable-socket/d' pytest.ini || die
+ sed -i -e '/--cov/d' pytest.ini || die
+
+ distutils-r1_python_prepare_all
+ export SETUPTOOLS_SCM_PRETEND_VERSION=${PV}
+}
+
+python_test() {
+ local EPYTEST_IGNORE=(
+ # Internet
+ tests/test_integration.py
+ )
+ local EPYTEST_DESELECT=(
+ # Regression due to deps?
+ tests/test_check.py::test_fails_rst_no_content
+ # Avoid needing heavy virtualx
+ tests/test_auth.py::test_warns_for_empty_password
+ )
+
+ local -x COLUMNS=80
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest
+}