summaryrefslogtreecommitdiff
path: root/dev-python/twine
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-07-24 02:11:45 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-07-24 02:11:45 +0100
commitb49088575eb777ced2551f484da86317332d6087 (patch)
treebf9a151cf2d61956340d555659ffc098ee1da466 /dev-python/twine
parent514d1bbe260df2521fe60f1a3ec87cfcfde1a829 (diff)
gentoo resync : 24.07.2021
Diffstat (limited to 'dev-python/twine')
-rw-r--r--dev-python/twine/Manifest2
-rw-r--r--dev-python/twine/twine-3.4.2.ebuild54
2 files changed, 56 insertions, 0 deletions
diff --git a/dev-python/twine/Manifest b/dev-python/twine/Manifest
index 3d5f8b50f69b..23f3948fed89 100644
--- a/dev-python/twine/Manifest
+++ b/dev-python/twine/Manifest
@@ -1,3 +1,5 @@
DIST twine-3.4.1.tar.gz 211775 BLAKE2B 0fdc6a8f5a37ee9695c8db2080987b631dfe6f8ed718e3912c94d77b46d35682d27bef07715c1fe7c0d8b6ab1449a771e18d8ffa5c6044dde1536b56b3e7885e SHA512 eca2a7b6b1386868f67dec1182599a8331981585e1cc0b7eef762aa0e99b87b0c6725a2c776330a8b392254501880a68e01ed8569a169857e8079abb8da43b79
+DIST twine-3.4.2.tar.gz 212266 BLAKE2B 602bb72f4be1c0d28341fb3378a5d55737c14555495640ae3414a1c8e7ca0c06b2c2ce3c358130251c02f0a51b61eb362a1e999c3945d4d1d7afd7bcd4d17807 SHA512 3f6d8992294a35e2a26be64f56c88d31af63b05f3f477d545bc82d928ca1b9939d23fa489eca5232502a49def77d489eaf6a29663d150f78b5cdb99749ff9b50
EBUILD twine-3.4.1.ebuild 1726 BLAKE2B 5d2749084f74af80645d6232369ecb693a89a8b309b7618f2de647e13ab1df8e791eae950dfe551c23e0efecd7f311bd76cd10bf51a2c423eb6e30008a82e304 SHA512 72e689f1436fa6ba57035074c4c60bc43ba61cb6ecc03db4b45b4c0539b41fd735e4e183aedb28ae146a7f7067e7761f181ecbb7e952538d7bbd1e9cd0d2e6a0
+EBUILD twine-3.4.2.ebuild 1774 BLAKE2B f21412daf87832f0a107b99438928a94abe1c06011c57ad0350d18b1d9d20b8ade9f1d03e8878e01f1e7db3761ceb9ef66b73a6bb63d2c5d25afc6a46fd61f8c SHA512 c172f89b737e69f0ac75ac055127b65c378971182b13e0aa01bab89244948e9ae138e6c983d1e3f1932e2099a63a73ccd2e3e40310b04f6c7b7740be7c113f3a
MISC metadata.xml 382 BLAKE2B 7b1f58005d26a36c877707986c59a6ae3549b9e8118f01fc87aa05a1f7dfa4271ea2100663d49b7b5b8f278409e96b2dabcdb0d9a74809bba75d440fd42d88bd SHA512 c4ce9e0c6029c9efb8be9b36720281ed4ebf0d829e3d936d0a7a864d8f42b1f7c71dc8b605717547ac004bd94c7baebd5b2d2a224899fad0efa0747124ba5bfb
diff --git a/dev-python/twine/twine-3.4.2.ebuild b/dev-python/twine/twine-3.4.2.ebuild
new file mode 100644
index 000000000000..72a1dedc5390
--- /dev/null
+++ b/dev-python/twine/twine-3.4.2.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_SETUPTOOLS=pyproject.toml
+PYTHON_COMPAT=( python3_{8..10} pypy3 )
+inherit distutils-r1
+
+DESCRIPTION="Collection of utilities for publishing packages on PyPI"
+HOMEPAGE="https://twine.readthedocs.io/ https://github.com/pypa/twine https://pypi.org/project/twine/"
+SRC_URI="https://github.com/pypa/twine/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x64-macos"
+
+RDEPEND="
+ >=dev-python/colorama-0.4.3[${PYTHON_USEDEP}]
+ >=dev-python/importlib_metadata-3.6[${PYTHON_USEDEP}]
+ >=dev-python/keyring-15.1[${PYTHON_USEDEP}]
+ >=dev-python/pkginfo-1.4.2[${PYTHON_USEDEP}]
+ >=dev-python/readme_renderer-21.0[${PYTHON_USEDEP}]
+ >=dev-python/requests-2.20.0[${PYTHON_USEDEP}]
+ >=dev-python/requests-toolbelt-0.8.0[${PYTHON_USEDEP}]
+ >=dev-python/rfc3986-1.4.0[${PYTHON_USEDEP}]
+ >=dev-python/tqdm-4.14[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ dev-python/setuptools_scm[${PYTHON_USEDEP}]
+ test? (
+ dev-python/jaraco-envs[${PYTHON_USEDEP}]
+ dev-python/jaraco-functools[${PYTHON_USEDEP}]
+ dev-python/munch[${PYTHON_USEDEP}]
+ dev-python/portend[${PYTHON_USEDEP}]
+ dev-python/pretend[${PYTHON_USEDEP}]
+ dev-python/pypiserver[${PYTHON_USEDEP}]
+ dev-python/pytest[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests --install pytest
+
+python_prepare_all() {
+ # requires internet
+ rm -f tests/test_integration.py || die
+ # pytest-socket dep relevant only to test_integration, and upstream
+ # disables it anyway
+ sed -i -e '/--disable-socket/d' pytest.ini || die
+ sed -i -e '/--cov/d' pytest.ini || die
+
+ distutils-r1_python_prepare_all
+ export SETUPTOOLS_SCM_PRETEND_VERSION=${PV}
+}