summaryrefslogtreecommitdiff
path: root/dev-python/twine
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-06-29 12:04:12 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-06-29 12:04:12 +0100
commit0f558761aa2dee1017b4751e4017205e015a9560 (patch)
tree037df795519468a25d9362b4e95cdaeb84eb1cf9 /dev-python/twine
parent752d6256e5204b958b0ef7905675a940b5e9172f (diff)
gentoo resync : 29.12.2022
Diffstat (limited to 'dev-python/twine')
-rw-r--r--dev-python/twine/Manifest4
-rw-r--r--dev-python/twine/twine-4.0.0.ebuild18
-rw-r--r--dev-python/twine/twine-4.0.1.ebuild80
3 files changed, 98 insertions, 4 deletions
diff --git a/dev-python/twine/Manifest b/dev-python/twine/Manifest
index ac172e2e6e4c..6bff53ba22e1 100644
--- a/dev-python/twine/Manifest
+++ b/dev-python/twine/Manifest
@@ -1,3 +1,5 @@
DIST twine-4.0.0.tar.gz 214420 BLAKE2B 0a1dc91ed9308252d5db3825c8b642e015720bfe7a95dd9a92ba347cbf1eedede85b18b9c310fe20322928db8e44f988bffb3845748ce9817ecbd5b521fb25c8 SHA512 c97a4315bd2a923979aa3a6cebf826ef022a9e510383f7f1debf941b6eedc47642c999702bdc3377a9740f381ed4dc442a542f02a44e521040cb67fb342e9b7e
-EBUILD twine-4.0.0.ebuild 1898 BLAKE2B 51f3004c20742bdd889d30e09f4fcf814f886401169cce2a0474d00c02d1f5306db01c185339acc00b2d621673283996a4cc3530de45ba65b9c9ad3b22d05e99 SHA512 9508def7777185c777af9fb1c37a4ad2a577fc43f21cbb81b0c9553df0d7f658a1355d73da5bef0b4b10f29f1b3e30a23d4de9d7f5b79f794dba4676f934d5fe
+DIST twine-4.0.1.gh.tar.gz 214569 BLAKE2B 82c1793718cfd7d81d9745d16dfe21f59fdfd8b157840ff29629f8b7b86c1e36281f1ed9ba613ec0048c8eef8a2c80d2b9b160893ed953b06c9bfb027f5299e0 SHA512 0b5d24c56731239400b6713e0e52d1cfdb399a84e886b02ea4b59e7af69cc1578e03bf442cca4b2ea5f400995955d27c8d9d3cc17a6ea59013bdaaf6ac63a567
+EBUILD twine-4.0.0.ebuild 2182 BLAKE2B 813ecbfd27340c05b50d1feeae61ae25fced3af9d192b5b5ee223c02b7e79b5e87cc15a77fafe83af34612f68f6c3da10f42e1757ff623cc6560df52b52e2cf8 SHA512 4a445e832be4ca6e626f02a2a76a0ce005fe38eb4c9d54097f92b99c537de800b14dd7a7bfb2cba334a22c88f449a38f02ecc7d5b33dea411466745e564a4e6f
+EBUILD twine-4.0.1.ebuild 2198 BLAKE2B 69fb063735521e9c5e25de4ca207c91317b1c4474792dce45287cdb346f33a910cbdcd57352782b28d94cce0b586acacdfae6749e8a419a38dd6682962db1439 SHA512 d9a45130c98bbf8016137de28825269ec18c0248b4a71c95656c63c0b418d0349030fbf0cd828094b2aec44a54ba96ea7b2b0889501ec83bf78e52455106e8e0
MISC metadata.xml 383 BLAKE2B e2a596604a2f3e40ddd0196ea79105e318f8a04d9e5a2c7e458d403d215af1371f2a526fa7d8cbc430f20747f7b65ed6c8546263fb8a54ddd8a6db487c358634 SHA512 cd5c1f1ed89dc5c314975fc5b503108d6828db37826ebba98d6edd580b72cd41867e19e65a9a022f8c07babadecd810f21febeb8a015c51eecec412b9df4f0d5
diff --git a/dev-python/twine/twine-4.0.0.ebuild b/dev-python/twine/twine-4.0.0.ebuild
index 61e10a8a17e5..da2cc7fbd587 100644
--- a/dev-python/twine/twine-4.0.0.ebuild
+++ b/dev-python/twine/twine-4.0.0.ebuild
@@ -4,7 +4,8 @@
EAPI=8
DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{8..10} pypy3 )
+PYTHON_COMPAT=( python3_{8..11} pypy3 )
+
inherit distutils-r1
DESCRIPTION="Collection of utilities for publishing packages on PyPI"
@@ -48,8 +49,6 @@ BDEPEND="
distutils_enable_tests pytest
python_prepare_all() {
- # requires internet
- rm -f tests/test_integration.py || die
# pytest-socket dep relevant only to test_integration, and upstream
# disables it anyway
sed -i -e '/--disable-socket/d' pytest.ini || die
@@ -60,6 +59,19 @@ python_prepare_all() {
}
python_test() {
+ local EPYTEST_IGNORE=(
+ # Internet
+ tests/test_integration.py
+ )
+ local EPYTEST_DESELECT=(
+ # regression due to deps?
+ tests/test_check.py::test_fails_rst_no_content
+ )
+ [[ ${EPYTHON} == python3.11 ]] && EPYTEST_DESELECT+=(
+ # confused by extra log entries that don't seem relevant
+ tests/test_auth.py::test_warns_for_empty_password
+ )
+
local -x COLUMNS=80
epytest
}
diff --git a/dev-python/twine/twine-4.0.1.ebuild b/dev-python/twine/twine-4.0.1.ebuild
new file mode 100644
index 000000000000..7f4803fc0f57
--- /dev/null
+++ b/dev-python/twine/twine-4.0.1.ebuild
@@ -0,0 +1,80 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Collection of utilities for publishing packages on PyPI"
+HOMEPAGE="
+ https://twine.readthedocs.io/
+ https://github.com/pypa/twine/
+ https://pypi.org/project/twine/
+"
+SRC_URI="
+ https://github.com/pypa/twine/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+ >=dev-python/colorama-0.4.3[${PYTHON_USEDEP}]
+ >=dev-python/importlib_metadata-3.6[${PYTHON_USEDEP}]
+ >=dev-python/keyring-15.1[${PYTHON_USEDEP}]
+ >=dev-python/pkginfo-1.8.1[${PYTHON_USEDEP}]
+ >=dev-python/readme_renderer-35.0[${PYTHON_USEDEP}]
+ >=dev-python/requests-2.20.0[${PYTHON_USEDEP}]
+ >=dev-python/requests-toolbelt-0.8.0[${PYTHON_USEDEP}]
+ >=dev-python/rfc3986-1.4.0[${PYTHON_USEDEP}]
+ >=dev-python/rich-12.0.0[${PYTHON_USEDEP}]
+ >=dev-python/urllib3-1.26.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ dev-python/setuptools_scm[${PYTHON_USEDEP}]
+ test? (
+ dev-python/build[${PYTHON_USEDEP}]
+ dev-python/jaraco-envs[${PYTHON_USEDEP}]
+ dev-python/jaraco-functools[${PYTHON_USEDEP}]
+ dev-python/munch[${PYTHON_USEDEP}]
+ dev-python/portend[${PYTHON_USEDEP}]
+ dev-python/pretend[${PYTHON_USEDEP}]
+ dev-python/pypiserver[${PYTHON_USEDEP}]
+ dev-python/pytest[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ # pytest-socket dep relevant only to test_integration, and upstream
+ # disables it anyway
+ sed -i -e '/--disable-socket/d' pytest.ini || die
+ sed -i -e '/--cov/d' pytest.ini || die
+
+ distutils-r1_python_prepare_all
+ export SETUPTOOLS_SCM_PRETEND_VERSION=${PV}
+}
+
+python_test() {
+ local EPYTEST_IGNORE=(
+ # Internet
+ tests/test_integration.py
+ )
+ local EPYTEST_DESELECT=(
+ # regression due to deps?
+ tests/test_check.py::test_fails_rst_no_content
+ )
+ [[ ${EPYTHON} == python3.11 ]] && EPYTEST_DESELECT+=(
+ # confused by extra log entries that don't seem relevant
+ tests/test_auth.py::test_warns_for_empty_password
+ )
+
+ local -x COLUMNS=80
+ epytest
+}