summaryrefslogtreecommitdiff
path: root/dev-python/twill
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-11-18 09:38:27 +0000
committerV3n3RiX <venerix@redcorelinux.org>2018-11-18 09:38:27 +0000
commit536c3711867ec947c1738f2c4b96f22e4863322d (patch)
tree697733f5cb713908dcf378e13fd15a798a906a91 /dev-python/twill
parentf65628136faa35d0c4d3b5e7332275c7b35fcd96 (diff)
gentoo resync : 18.11.2018
Diffstat (limited to 'dev-python/twill')
-rw-r--r--dev-python/twill/Manifest3
-rw-r--r--dev-python/twill/metadata.xml11
-rw-r--r--dev-python/twill/twill-0.9-r1.ebuild51
3 files changed, 0 insertions, 65 deletions
diff --git a/dev-python/twill/Manifest b/dev-python/twill/Manifest
deleted file mode 100644
index 607fb88e7f84..000000000000
--- a/dev-python/twill/Manifest
+++ /dev/null
@@ -1,3 +0,0 @@
-DIST twill-0.9.tar.gz 242291 BLAKE2B 7ba3b9c6156b5c10ec988c9d1f1c6b444b1168b90ff0980e9e0fcdc23bed765a5dc36568acb0fe174ea57182a55caf98cb6913cff9774da6dee56f9712c3ca8b SHA512 ea47400e236c4f5a4d38671bbc5690d004c4dbd20b6152c54c2fa64bae3e3ec68d16a5305d42e8631595cac25f5b2a08e0eb287b7e1ed7b90a8368d6063b1f1e
-EBUILD twill-0.9-r1.ebuild 1195 BLAKE2B 71b704ea38fb81ac78aaacbdbb21f66f306444c231550f55a9d80ecabccbe03d2031e62350befda33aa88ee8fdd4d778c1a5e8c0802ec1d5f9048042f62080e5 SHA512 56704686ef6c315d9acd351d5bdb40b01c16953a775d24e10f62946fadc882fee51cbae045aa609f4a22e9aaa540924903af90499084ebc80da14a81afe20fa0
-MISC metadata.xml 630 BLAKE2B 708005bf0296433cbe5d3377b74e8558b4f90abe1133205b96e6f5912dd96533382f474c1ea9e74322a6bbb57e77ad182c1af8d2f3c3b100b49742ef2cff8749 SHA512 9d08bb18d5ff85f2301d2b1f2aff814cb63257c3fdd1b19d4fe72ce5060d9cbedd0c26a5f3fd55cc972f3c41861bea7df92584945b381b7e8f8caa3d7d97f39f
diff --git a/dev-python/twill/metadata.xml b/dev-python/twill/metadata.xml
deleted file mode 100644
index 99a143d0daf5..000000000000
--- a/dev-python/twill/metadata.xml
+++ /dev/null
@@ -1,11 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
- <maintainer type="project">
- <email>python@gentoo.org</email>
- <name>Python</name>
- </maintainer>
- <longdescription lang="en">
- twill is a simple language that allows users to browse the Web from a command-line interface. With twill, you can navigate through Web sites that use forms, cookies, and most standard Web features. twill supports automated Web testing and has a simple Python interface. Check out the examples! twill is open source and written in Python.
- </longdescription>
-</pkgmetadata>
diff --git a/dev-python/twill/twill-0.9-r1.ebuild b/dev-python/twill/twill-0.9-r1.ebuild
deleted file mode 100644
index 127b1b3cfb74..000000000000
--- a/dev-python/twill/twill-0.9-r1.ebuild
+++ /dev/null
@@ -1,51 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI="5"
-
-PYTHON_COMPAT=( python2_7 pypy )
-
-inherit distutils-r1
-
-MY_PV="${PV/_beta/b}"
-MY_P="${PN}-${MY_PV}"
-
-DESCRIPTION="Simple scripting language for web browsing with Python API"
-HOMEPAGE="http://twill.idyll.org/"
-SRC_URI="http://darcs.idyll.org/~t/projects/${MY_P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="amd64 ~arm ~arm64 ppc ~ppc64 x86"
-IUSE="doc examples"
-
-REQUIRED_USE="doc? ( || ( $(python_gen_useflags 'python2*') ) )"
-
-DEPEND="
- dev-python/setuptools[${PYTHON_USEDEP}]
- doc? (
- $(python_gen_cond_dep 'dev-python/epydoc[${PYTHON_USEDEP}]' 'python2*')
- $(python_gen_cond_dep 'virtual/python-dnspython[${PYTHON_USEDEP}]' 'python2*')
- )"
-
-S="${WORKDIR}/${MY_P}"
-
-pkg_setup() {
- use doc && DISTUTILS_ALL_SUBPHASE_IMPLS=( 'python2*' )
-}
-
-python_compile_all() {
- if use doc; then
- python_setup 'python2*'
- pushd doc > /dev/null || die
- chmod +x make-epydoc.sh || die
- ./make-epydoc.sh || die
- popd> /dev/null || die
- fi
-}
-
-python_install_all() {
- use doc && HTML_DOCS=( doc/epydoc-html/. )
- use examples && local EXAMPLES=( examples/. )
- distutils-r1_python_install_all
-}